libjamon-java_2.7-5_all.deb


Advertisement

Description

libjamon-java - Java API for easy monitoring production applications

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libjamon-java
Package version 2.7
Package release 5
Package architecture all
Package type deb
Installed size 211 B
Download size 142.53 KB
Official Mirror ftp.br.debian.org
The Java Application Monitor (JAMon) is a free, simple, high
performance, thread safe, Java API that allows developers to easily
monitor production applications. JAMon can be used to determine
application performance bottlenecks, user/application interactions,
track application scalability, and more.

Alternatives

Package Version Architecture Repository
libjamon-java_2.7-5_all.deb 2.7 all Debian Main
libjamon-java - - -

Download

Type URL
Binary Package libjamon-java_2.7-5_all.deb
Source Package libjamon-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjamon-java deb package:
    # sudo apt-get install libjamon-java

Files

Path
/usr/share/doc/libjamon-java/changelog.Debian.gz
/usr/share/doc/libjamon-java/copyright
/usr/share/java/jamon-2.7.jar
/usr/share/java/jamon.jar
/usr/share/maven-repo/com/jamonapi/jamon/2.7/jamon-2.7.jar
/usr/share/maven-repo/com/jamonapi/jamon/2.7/jamon-2.7.pom
/usr/share/maven-repo/com/jamonapi/jamon/debian/jamon-debian.jar
/usr/share/maven-repo/com/jamonapi/jamon/debian/jamon-debian.pom

Changelog

2014-09-08 - Emmanuel Bourg <ebourg@apache.org>
libjamon-java (2.7-5) unstable; urgency=medium
* Team upload.
* Depend on libservlet3.1-java and libtomcat8-java instead of
libservlet2.5-java and libtomcat6-java (Closes: #759636)
* Switch to debhelper level 9
* debian/rules: Removed the call to patchsys-quilt.mk
* Removed the unused ${shlibs:Depends} variable
2013-12-25 - Miguel Landaeta <nomadium@debian.org>
libjamon-java (2.7-4) unstable; urgency=low
* Team upload.
* Provide Maven artifacts. (Closes: #729087)
- Add dependency on maven-repo-helper.
- Add pom.xml file.
* Bump Standards-Version to 3.9.5. No changes were required.
* Update Homepage field.
* Use canonical URLs in Vcs-* fields.
2012-06-25 - Miguel Landaeta <miguel@miguel.cc>
libjamon-java (2.7-3) unstable; urgency=low
* Team upload.
[ Miguel Landaeta ]
* Rename ant build files patch.
* Fix FTBFS with OpenJDK7.
* Bump Standards-Version to 3.9.3. No changes were required.
[ tony mancill ]
* Remove needless dependency on JRE.
2010-05-03 - Torsten Werner <twerner@debian.org>
libjamon-java (2.7-2) unstable; urgency=low
* Switch to source format 3.0.
* Update Standards-Version: 3.8.4.
2009-11-30 - Thierry Carrez <thierry.carrez@ubuntu.com>
libjamon-java (2.7-1ubuntu1) lucid; urgency=low
* Merge from debian testing, remaining changes:
- debian/control: Build-depend on libjetty-java rather than full jetty
- debian/control, debian/rules: Depend on geronimo-interceptor-3.0-spec
rather than glassfish-javaee, to avoid pulling glassfish into main
- debian/control: Use -headless runtimes, bump dependency to java5
- debian/ant.properties: Build java5 code to match dependency
2009-09-13 - Luke Cycon <lcycon@gmail.com>
libjamon-java (2.7-1) unstable; urgency=low
[ Emmanuel Bourg ]
* Update of the URLs
* Rename Jakarta Commons to Apache Commons
[ Torsten Werner ]
* new upstream version
* Move package to Alioth and change Maintainer.
* Update Vcs and Homepage headers in debian/control.
* Switch from kaffe to default-jdk and default-jre.
* Add Build-Depends: glassfish-javaee, jetty.
* Disable compiler warnings.
* Switch to tomcat6.
* Add missing Build-Depends: liblog4j1.2-java.
[ Luke Cycon ]
* Added new patch (api-fix.diff)
- Fix issues to allow building by Java 1.6
- Fix issues caused be recenct tomcat API updates
* Bump Standards-Version: 3.8.3. No changes.
* Updated Vcs address in debian/control/ svn+ssh:// to svn://
* Add build depends: quilt
* Updated copyright to comply with Debian Stadards
* Moved package to correct section ( java )
* Added debian/README.source
* Added myself to uploaders
2009-08-25 - Thierry Carrez <thierry.carrez@ubuntu.com>
libjamon-java (2.5-1ubuntu2) karmic; urgency=low
* Added debian/ant.properties to build java2-compatible code
2009-08-17 - Thierry Carrez <thierry.carrez@ubuntu.com>
libjamon-java (2.5-1ubuntu1) karmic; urgency=low
* debian/control, debian/rules: Build with gcj-jdk
* debian/control: Depend on default-jre-headless | java2-runtime-headless
2007-05-27 - Torsten Werner <twerner@debian.org>
libjamon-java (2.5-1) unstable; urgency=low
* Initial release (Closes: #426315)

See Also

Package Description
libjana-dev_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb interface library for time-related personal information (dev. files)
libjana-doc_0.0.0+git20091215.9ec1da8a-3_all.deb interface library for time-related personal information (documentation)
libjana-ecal-dev_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb implementation of libjana based on evolution-data-server (dev. files)
libjana-ecal-doc_0.0.0+git20091215.9ec1da8a-3_all.deb implementation of libjana based on evolution-data-server (documentation)
libjana-ecal0_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb implementation of libjana based on evolution-data-server
libjana-examples_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb Example applications for libjana, libjana-ecal and libjana-gtk
libjana-gtk-dev_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb GTK+ widgets to visualise libjana data (development files)
libjana-gtk-doc_0.0.0+git20091215.9ec1da8a-3_all.deb GTK+ widgets to visualise libjana data (documentation)
libjana-gtk0_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb GTK+ widgets to visualise libjana data
libjana-test_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb test applications for libjana and libjana-ecal
libjana0_0.0.0+git20091215.9ec1da8a-3+b3_amd64.deb interface library for time-related personal information
libjanino-java-doc_2.7.0-2_all.deb runtime compiler for Java expressions - documentation
libjanino-java_2.7.0-2_all.deb runtime compiler for Java expressions - library
libjansi-java_1.4-3_all.deb Java library for generating and interpreting ANSI escape sequences
libjansi-native-java_1.0-4_all.deb Java library for ANSI escape sequences - native component
Advertisement
Advertisement