libjakarta-ecs-java_1.4.2-4_all.deb


Advertisement

Description

libjakarta-ecs-java - Element construction set for various markup languages

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libjakarta-ecs-java
Package version: 1.4.2
Package release: 4
Package architecture: all
Package type: deb
Installed size: 466 B
Download size: 361.24 KB
Official Mirror: ftp.br.debian.org
Generation API directly supports HTML 4.0 and XML, but can easily be extended to create tags for any markup language. Documents are created through native Java objects instead of generating the markup directly.

Alternatives

Requires

    Download

    Source package: jakarta-ecs

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libjakarta-ecs-java deb package:
      # sudo apt-get install libjakarta-ecs-java

    Files

    • /usr/share/doc/libjakarta-ecs-java/AUTHORS
    • /usr/share/doc/libjakarta-ecs-java/README
    • /usr/share/doc/libjakarta-ecs-java/changelog.Debian.gz
    • /usr/share/doc/libjakarta-ecs-java/changelog.gz
    • /usr/share/doc/libjakarta-ecs-java/copyright
    • /usr/share/java/ecs-1.4.2.jar
    • /usr/share/java/ecs.jar
    • /usr/share/maven-repo/ecs/ecs/1.4.2/ecs-1.4.2.jar
    • /usr/share/maven-repo/ecs/ecs/1.4.2/ecs-1.4.2.pom
    • /usr/share/maven-repo/ecs/ecs/debian/ecs-debian.jar
    • /usr/share/maven-repo/ecs/ecs/debian/ecs-debian.pom

    Changelog

    2014-10-13 - Emmanuel Bourg <ebourg@apache.org> jakarta-ecs (1.4.2-4) unstable; urgency=medium * Added an explicit build dependency on libxerces2-java since it's no longer on the Ant classpath (Closes: #765057) * Standards-Version updated to 3.9.6 (no changes)

    2014-03-06 - Emmanuel Bourg <ebourg@apache.org> jakarta-ecs (1.4.2-3) unstable; urgency=medium * Team upload. * Package adopted by the Java Team (Closes: #640778) * Install the Maven artifacts in /usr/share/maven-repo * Enabled the debug symbols * Removed the files related to log4j in the debian directory * Changed the watch file to check ecs instead of log4j * Switch to source format 3.0 (quilt) * debian/control: - Removed the runtime dependency on the JRE - Fixed a typo in the package description (Closes: #658268) - Standards-Version updated to 3.9.5 - Added the missing Vcs-* fields * debian/rules: Removed simple-patchsys.mk * Switch to debhelper level 9

    2011-09-06 - Kalle Kivimaa <killer@debian.org> jakarta-ecs (1.4.2-2) unstable; urgency=low * Package orphaned.

    2010-01-30 - Onkar Shinde <onkarshinde@ubuntu.com> jakarta-ecs (1.4.2-1.2) unstable; urgency=low * Non-maintainer upload. * debian/control - Change build dependency default-jdk-builddep to default-jdk as no -gcj package is being built. - Change jre dependencies to -headless. Remove unnecessary dependency java-common. - Add build and runtime dependency libregexp-java. - Update standards version to 3.8.4. * debian/rules - Add ant arguments to specify source version 1.4. - Add regexp to list of jar files for compilation classpath. Both these changes fix FTBFS. (Closes: #562437)

    2009-11-27 - Philipp Spitzer <philipp+debian@spitzer.priv.at> jakarta-ecs (1.4.2-1.1) unstable; urgency=low [ Philipp Spitzer ] * Non-maintainer upload. * Renamed "enum" variable to "enumerate" as "enum" became a Java keyword (Closes: #543076). [ gregor herrmann ] * debian/control: remove section from binary package, change section to java in source package.

    2008-10-24 - Kalle Kivimaa <killer@debian.org> jakarta-ecs (1.4.2-1) unstable; urgency=low * Initial release (Closes: #503279). * lib-dir is ignored in the build to conform with the policy. * Binary jars and classes as well as pregenerated javadocs removed from the orig.tar.gz.

    Advertisement
    Advertisement