libio-compress-perl_2.066-1_all.deb


Advertisement

Description

libio-compress-perl - bundle of IO::Compress modules

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libio-compress-perl
Package version 2.066
Package release 1
Package architecture all
Package type deb
Installed size 887 B
Download size 231.95 KB
Official Mirror ftp.br.debian.org
This package contains the following IO::Compress and IO::Uncompress modules:
- Compress::Zlib
- IO::Compress::Base
- IO::Compress::Bzip2
- IO::Compress::Deflate
- IO::Compress::Gzip
- IO::Compress::RawDeflate
- IO::Compress::Zip
- IO::Uncompress::Base
- IO::Uncompress::Bunzip2
- IO::Uncompress::Gunzip
- IO::Uncompress::Inflate
- IO::Uncompress::RawInflate
- IO::Uncompress::Unzip
Compress::Zlib is a Perl external module which provides an interface to
the info-zip zlib compression library. zlib is a general purpose
compression library.
Some of the features provided by Compress::Zlib include:
* in-memory compression and decompression
* read and write gzip (.gz) files directly.
IO::Compress::Bunzip2 and IO::Uncompress::Bunzip2 provide a Perl interface
that allows transparent reading and writing bzip2 compressed data to files or
buffers.
IO::Compress::Base is the base class for all IO::Compress and IO::Uncompress
modules. It is not intended for direct use in application code. Its sole
purpose is to be sub-classed by IO::Compress modules.

Alternatives

Package Version Architecture Repository
libio-compress-perl_2.066-1_all.deb 2.066 all Debian Main
libio-compress-perl - - -

Requires

Name Value
libcompress-raw-bzip2-perl >= 2.066
libcompress-raw-zlib-perl >= 2.066
perl -

Provides

Name Value
libcompress-zlib-perl -
libio-compress-base-perl -
libio-compress-bzip2-perl -
libio-compress-zlib-perl -

Replaces

Name Value
libcompress-zlib-perl << 2.020-1
libio-compress-base-perl << 2.020-1
libio-compress-bzip2-perl << 2.020-1
libio-compress-zlib-perl << 2.020-1

Download

Type URL
Binary Package libio-compress-perl_2.066-1_all.deb
Source Package libio-compress-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libio-compress-perl deb package:
    # sudo apt-get install libio-compress-perl

Files

Path
/usr/bin/zipdetails
/usr/share/doc/libio-compress-perl/changelog.Debian.gz
/usr/share/doc/libio-compress-perl/changelog.gz
/usr/share/doc/libio-compress-perl/copyright
/usr/share/doc/libio-compress-perl/examples/compress-zlib/filtdef
/usr/share/doc/libio-compress-perl/examples/compress-zlib/filtinf
/usr/share/doc/libio-compress-perl/examples/compress-zlib/gzcat
/usr/share/doc/libio-compress-perl/examples/compress-zlib/gzgrep
/usr/share/doc/libio-compress-perl/examples/compress-zlib/gzstream
/usr/share/doc/libio-compress-perl/examples/io/anycat
/usr/share/doc/libio-compress-perl/examples/io/bzip2/bzcat
/usr/share/doc/libio-compress-perl/examples/io/bzip2/bzgrep
/usr/share/doc/libio-compress-perl/examples/io/bzip2/bzstream
/usr/share/doc/libio-compress-perl/examples/io/gzip/gzappend
/usr/share/doc/libio-compress-perl/examples/io/gzip/gzcat
/usr/share/doc/libio-compress-perl/examples/io/gzip/gzgrep
/usr/share/doc/libio-compress-perl/examples/io/gzip/gzstream
/usr/share/man/man1/zipdetails.1p.gz
/usr/share/man/man3/Compress::Zlib.3pm.gz
/usr/share/man/man3/File::GlobMapper.3pm.gz
/usr/share/man/man3/IO::Compress::Base.3pm.gz
/usr/share/man/man3/IO::Compress::Bzip2.3pm.gz
/usr/share/man/man3/IO::Compress::Deflate.3pm.gz
/usr/share/man/man3/IO::Compress::FAQ.3pm.gz
/usr/share/man/man3/IO::Compress::Gzip.3pm.gz
/usr/share/man/man3/IO::Compress::RawDeflate.3pm.gz
/usr/share/man/man3/IO::Compress::Zip.3pm.gz
/usr/share/man/man3/IO::Uncompress::AnyInflate.3pm.gz
/usr/share/man/man3/IO::Uncompress::AnyUncompress.3pm.gz
/usr/share/man/man3/IO::Uncompress::Base.3pm.gz
/usr/share/man/man3/IO::Uncompress::Bunzip2.3pm.gz
/usr/share/man/man3/IO::Uncompress::Gunzip.3pm.gz
/usr/share/man/man3/IO::Uncompress::Inflate.3pm.gz
/usr/share/man/man3/IO::Uncompress::RawInflate.3pm.gz
/usr/share/man/man3/IO::Uncompress::Unzip.3pm.gz
/usr/share/perl5/Compress/Zlib.pm
/usr/share/perl5/File/GlobMapper.pm
/usr/share/perl5/IO/Compress/Base.pm
/usr/share/perl5/IO/Compress/Bzip2.pm
/usr/share/perl5/IO/Compress/Deflate.pm
/usr/share/perl5/IO/Compress/FAQ.pod
/usr/share/perl5/IO/Compress/Gzip.pm
/usr/share/perl5/IO/Compress/RawDeflate.pm
/usr/share/perl5/IO/Compress/Zip.pm
/usr/share/perl5/IO/Compress/Adapter/Bzip2.pm
/usr/share/perl5/IO/Compress/Adapter/Deflate.pm
/usr/share/perl5/IO/Compress/Adapter/Identity.pm
/usr/share/perl5/IO/Compress/Base/Common.pm
/usr/share/perl5/IO/Compress/Gzip/Constants.pm
/usr/share/perl5/IO/Compress/Zip/Constants.pm
/usr/share/perl5/IO/Compress/Zlib/Constants.pm
/usr/share/perl5/IO/Compress/Zlib/Extra.pm
/usr/share/perl5/IO/Uncompress/AnyInflate.pm
/usr/share/perl5/IO/Uncompress/AnyUncompress.pm
/usr/share/perl5/IO/Uncompress/Base.pm
/usr/share/perl5/IO/Uncompress/Bunzip2.pm
/usr/share/perl5/IO/Uncompress/Gunzip.pm
/usr/share/perl5/IO/Uncompress/Inflate.pm
/usr/share/perl5/IO/Uncompress/RawInflate.pm
/usr/share/perl5/IO/Uncompress/Unzip.pm
/usr/share/perl5/IO/Uncompress/Adapter/Bunzip2.pm
/usr/share/perl5/IO/Uncompress/Adapter/Identity.pm
/usr/share/perl5/IO/Uncompress/Adapter/Inflate.pm

Changelog

2014-09-23 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.066-1) unstable; urgency=medium
[ gregor herrmann ]
* debian/control: remove Nicholas Bamber from Uploaders on request of
the MIA team.
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* New upstream release.
Fixes "IO::Uncompress::Gunzip: Can no longer gunzip to in-memory file
handle" (Closes: #762486)
* Bump versioned (build) dependencies.
* Declare compliance with Debian Policy 3.9.6.
* Mark package as autopkgtest-able.
2014-02-12 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.064-1) unstable; urgency=medium
* New upstream release.
* Update years of copyright.
* Bump versioned build dependencies.
2013-11-04 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.063-1) unstable; urgency=low
* New upstream release.
* Bump versioned (build) dependencies.
* Declare compliance with Debian Policy 3.9.5.
2013-10-05 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.062-1) unstable; urgency=low
* New upstream release.
* Update years of packaging copyright.
* Bump versioned build dependencies.
2013-06-01 - Xavier Guimard <x.guimard@free.fr>
libio-compress-perl (2.061-1) unstable; urgency=low
* Imported Upstream version 2.061
* Update dependencies versions
2013-05-04 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.060-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ gregor herrmann ]
* Recommend libio-compress-lzma-perl. Thanks to Vincent Lefevre for the
bug report. (Closes: #698790)
* Improve long description. Thanks to Vincent Lefevre for the hints.
[ Salvatore Bonaccorso ]
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Xavier Guimard ]
* Imported Upstream version 2.060
* Bump Standards-Version to 3.9.4
* Update debian/copyright years
2012-08-11 - Alessandro Ghedini <ghedo@debian.org>
libio-compress-perl (2.055-1) unstable; urgency=low
* New upstream release
* Add myself to Uploaders
* Bump build deps versions
2012-05-04 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.052-1) unstable; urgency=low
[ Alessandro Ghedini ]
* New upstream release 2.049
* Use ${source:Upstream-Version} instead of manually setting the required
version for libcompress-raw-{bzip2,zlib}-perl
[ Scott Kitterman ]
* Remove myself from uploaders
[ gregor herrmann ]
* New upstream release 2.052.
* Bump build dependencies on libcompress-raw-zlib-perl and
libcompress-raw-bzip2-perl to >= 2.052.
* debian/rules: remove unneeded override_dh_auto_configure.
* debian/copyright: update to Copyright-Format 1.0.
* Bump Standards-Version to 3.9.3 (no changes).
2012-01-30 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.048-1) unstable; urgency=low
* New upstream release.
* Update years of upstream and packaging copyright.
* Bump build and runtime dependencies on libcompress-raw-zlib-perl and
libcompress-raw-bzip2-perl to >= 2.048.
2011-12-19 - gregor herrmann <gregoa@debian.org>
libio-compress-perl (2.046-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
libio-digest-perl_0.11-1_all.deb Perl module to calculate digests while reading or writing
libio-dirent-perl_0.05-1+b2_amd64.deb Perl module for accessing dirent structs returned by readdir
libio-epoll-perl_0.03-2+b1_amd64.deb Perl interface to the Epoll IO Multiplexing subsystem
libio-file-withpath-perl_0.08-1_all.deb IO::File extension that keeps the pathname
libio-handle-util-perl_0.01-1_all.deb module providing helper functions for IO::Handle
libio-html-perl_1.001-1_all.deb open an HTML file with automatic charset detection
libio-interactive-perl_0.0.6-1_all.deb utility module for interactive I/O
libio-interface-perl_1.07-2+b1_amd64.deb socket methods to get/set interface characteristics
libio-lcdproc-perl_0.037-1_all.deb Perl extension to connect to a LCD display through lcdproc
libio-lockedfile-perl_0.23+d030220-3_all.deb IO::LockedFile Class - supply object methods for locking files
libio-multiplex-perl_1.13-1_all.deb object-oriented interface to select() for Perl
libio-pager-perl_0.31-1_all.deb module to select a pager and pipe text to it
libio-pipely-perl_0.005-1_all.deb portable way to create pipe() or pipe-like handles
libio-prompt-perl_0.997002-1_all.deb module to interactively prompt for user input
libio-prompt-tiny-perl_0.002-1_all.deb module that prompts for user input with a default option
Advertisement
Advertisement