libio-async-loop-epoll-perl_0.16-1_all.deb


Advertisement

Description

libio-async-loop-epoll-perl - Perl extension for an event loop using epoll

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libio-async-loop-epoll-perl
Package version 0.16
Package release 1
Package architecture all
Package type deb
Installed size 65 B
Download size 10.36 KB
Official Mirror ftp.br.debian.org
IO::Async::Loop::Epoll is a Perl module that provides an implementation of
an event loop that uses the epoll() system call. The epoll system call, which
is currently only available on Linux, scales in constant O(1) time. For many
open filehandles, you will get significantly better performance using this
algorithm.
It uses the IO::Epoll (libio-epoll-perl) module for this functionality.

Alternatives

Package Version Architecture Repository
libio-async-loop-epoll-perl_0.16-1_all.deb 0.16 all Debian Main
libio-async-loop-epoll-perl - - -

Requires

Name Value
libio-async-perl >= 0.60
liblinux-epoll-perl -
perl -

Download

Type URL
Binary Package libio-async-loop-epoll-perl_0.16-1_all.deb
Source Package libio-async-loop-epoll-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libio-async-loop-epoll-perl deb package:
    # sudo apt-get install libio-async-loop-epoll-perl

Files

Path
/usr/share/doc/libio-async-loop-epoll-perl/changelog.Debian.gz
/usr/share/doc/libio-async-loop-epoll-perl/changelog.gz
/usr/share/doc/libio-async-loop-epoll-perl/copyright
/usr/share/man/man3/IO::Async::Loop::Epoll.3pm.gz
/usr/share/perl5/IO/Async/Loop/Epoll.pm

Changelog

2013-09-21 - Florian Schlichting <fsfs@debian.org>
libio-async-loop-epoll-perl (0.16-1) unstable; urgency=low
[ gregor herrmann ]
* New upstream release (0.13).
* Replace libio-epoll-perl (build) dependency with liblinux-epoll-perl.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 0.16
* Bump years of upstream copyright
* Bump Standards-Version to 3.9.4 (no change)
* Bump (build-)dependency on libio-async-perl to 0.60
* Add myself to uploaders and copyright
* Add new spelling.patch
2012-04-10 - Alessandro Ghedini <ghedo@debian.org>
libio-async-loop-epoll-perl (0.12-1) unstable; urgency=low
* Team upload
* New upstream release
* Remove libtest-exception-perl from build depends (Closes: #667469)
* Update upstream copyright years
* Remove patches (merged upstream)
2012-04-01 - gregor herrmann <gregoa@debian.org>
libio-async-loop-epoll-perl (0.11-2) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* Add patches to round timeouts up to the nearest full millisecond.
Thanks to Niko Tyni for the analysis and the patches.
(Closes: #646649)
* debian/copyright: update to Copyright-Format 1.0.
* Bump Standards-Version to 3.9.3 (no changes).
2011-02-19 - gregor herrmann <gregoa@debian.org>
libio-async-loop-epoll-perl (0.11-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
+ Update for the new IO::Async 0.33 API
* Refresh copyright information
[ gregor herrmann ]
* Add /me to Uploaders.
* Update years of upstream copyright.
* Remove version from libio-epoll-perl (build) dependency.
* Add build dependencies on libtest-fatal-perl and libtest-pod-perl.
2010-12-03 - Salvatore Bonaccorso <carnil@debian.org>
libio-async-loop-epoll-perl (0.08-1) unstable; urgency=low
* Team upload.
* New upstream release
- Fixes FTBFS (Closes: #605811)
* Refresh debian/copyright:
- Explicitly refer to GPL-1 licence text in common-licenses.
- Refer to Debian systems in general instead of only Debian GNU/Linux
systems.
* Bump Debehlper compat level to 8. Use now Build.PL.
* debian/control:
- Bump versioned Build-Depends on debhelper (>= 8).
- Move perl to Build-Depends for Module::Build. 
* Bump Standards-Version to 3.9.1.
* Convert to '3.0 (quilt)' source package format.
2009-10-13 - Jonathan Yu <jawnsy@cpan.org>
libio-async-loop-epoll-perl (0.07-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
+ Only compatible with libio-async-perl (>= 0.24)
* Standards-Version 3.8.3 (no changes)
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ryan Niebur ]
* Update jawnsy's email address
2009-07-19 - Jonathan Yu <frequency@cpan.org>
libio-async-loop-epoll-perl (0.05-1) unstable; urgency=low
* Initial Release (Closes: #537653)

See Also

Package Description
libio-async-loop-glib-perl_0.21-1_all.deb Perl extension for an event loop using GLib
libio-async-perl_0.64-1_all.deb module providing asynchronous filehandle I/O
libio-bufferedselect-perl_1.0-1_all.deb Perl module for line-buffered select interface
libio-callback-perl_1.12-2_all.deb emulate file interface for a code reference
libio-capture-perl_0.05-3_all.deb Abstract Base Class to build modules to capture output
libio-captureoutput-perl_1.1103-1_all.deb module for capturing STDOUT and STDERR from Perl code, subprocesses or XS
libio-compress-lzma-perl_2.066-1_all.deb modules for reading and writing lzma/xz files/buffers
libio-compress-perl_2.066-1_all.deb bundle of IO::Compress modules
libio-digest-perl_0.11-1_all.deb Perl module to calculate digests while reading or writing
libio-dirent-perl_0.05-1+b2_amd64.deb Perl module for accessing dirent structs returned by readdir
libio-epoll-perl_0.03-2+b1_amd64.deb Perl interface to the Epoll IO Multiplexing subsystem
libio-file-withpath-perl_0.08-1_all.deb IO::File extension that keeps the pathname
libio-handle-util-perl_0.01-1_all.deb module providing helper functions for IO::Handle
libio-html-perl_1.001-1_all.deb open an HTML file with automatic charset detection
libio-interactive-perl_0.0.6-1_all.deb utility module for interactive I/O
Advertisement
Advertisement