libindimain0_0.9.8.1-5.1+b1_amd64.deb


Advertisement

Description

libindimain0 - Instrument-Neutral Device Interface library -- main library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libindimain0
Package version 0.9.8.1
Package release 5.1+b1
Package architecture amd64
Package type deb
Installed size 122 B
Download size 36.04 KB
Official Mirror ftp.br.debian.org
INDI (Instrument-Neutral Device Interface) is a distributed XML-based
control protocol designed to operate astronomical instrumentation.
INDI is small, flexible, easy to parse, scalable, and stateless.
It supports common DCS functions such as remote control, data acquisition,
monitoring, and a lot more.
This package contains the main shared library.

Alternatives

Package Version Architecture Repository
libindimain0_0.9.8.1-5.1+b1_i386.deb 0.9.8.1 i386 Debian Main
libindimain0 - - -

Requires

Name Value
libc6 >= 2.15
libcfitsio2 >= 3.370
libindi-data >= 0.9.8.1-5.1
libnova-0.14-0 -
multiarch-support -

Download

Type URL
Binary Package libindimain0_0.9.8.1-5.1+b1_amd64.deb
Source Package libindi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libindimain0 deb package:
    # sudo apt-get install libindimain0

Files

Path
/usr/lib/x86_64-linux-gnu/libindimain.so.0
/usr/lib/x86_64-linux-gnu/libindimain.so.0.9.8
/usr/share/doc/libindimain0/changelog.Debian.amd64.gz
/usr/share/doc/libindimain0/changelog.Debian.gz
/usr/share/doc/libindimain0/changelog.gz
/usr/share/doc/libindimain0/copyright

Changelog

2014-09-29 - Ondřej Surý <ondrej@debian.org>
libindi (0.9.8.1-5.1) unstable; urgency=medium
* Non-maintainer upload
* Change B-D to libjpeg-dev to finish the transition to libjpeg-turbo
(Closes: #763480)
2014-08-30 - Maximiliano Curia <maxy@debian.org>
libindi (0.9.8.1-5) unstable; urgency=medium
* Update symbols with the buildds logs and kfreebsd porter box log.
* New patch: freebsd_support
* Update build dependencies.
2014-07-18 - Maximiliano Curia <maxy@debian.org>
libindi (0.9.8.1-4) unstable; urgency=medium
* Remove libusb-dev build dependency. (Closes: #754746)
* Update symbols with the buildds logs. (Closes: #754747)
* New patch: no-sys-io.patch. (Closes: #668134)
2014-07-12 - Maximiliano Curia <maxy@debian.org>
libindi (0.9.8.1-3) unstable; urgency=medium
* Improve dependencies, libindialignmentdriver0 is the only library that
does a dlopen of the plugins. (Closes: #747855)
* Update symbols files. (Closes: #749962)
2014-05-07 - Maximiliano Curia <maxy@debian.org>
libindi (0.9.8.1-2) unstable; urgency=medium
* Update symbols from 0.9.8.1-1 buildlogs.
* Add dh sequence pkgkde_symbolshelper.
* Release to unstable.
2014-04-01 - Maximiliano Curia <maxy@debian.org>
libindi (0.9.8.1-1) experimental; urgency=medium
* Update watch file.
* New upstream release.
* Remove patch: libdir.diff, applied by upstream.
* Remove patch: setINDIproperty_mayhem_fix.diff, applied by upstream.
* Remove patch: getINDIproperty_mayhem_fix.diff, applied by upstream.
* Refresh patches.
* Update build dependencies.
* Bump libindidriver soversion.
* Update symbols.
* New lib package libindialignmentdriver0.
* Install binary plugins in an arch-dependant dir.
2013-11-20 - Maximiliano Curia <maxy@debian.org>
libindi (0.9.7-1) unstable; urgency=low
* New upstream release.
* New patch: setINDIproperty_mayhem_fix.diff fix for
http://www.forallsecure.com/bug-
reports/f7467b92bdec47c7d8213b93db76f57e58e97215/
* New patch: getINDIproperty_mayhem_fix.diff fix for
http://www.forallsecure.com/bug-
reports/3ef71f68767fec365de8eb61f91a4ca0be01b5fc/
* Refresh patches.
* Add libindimain0 and libindidriver0 packages.
* Add symbols files.
* Add myself to the Uploaders field.
* Bump debhelper b-d to 9.
* Bump Standards-Version, no changes needed.
* Update install files.
* Bump compat to 9.
* Make -dbg package m-a: same.
* Add new packages to -dev package.
* Update symbols files.
* Bump so name of libindidriver to 0b.
2012-03-25 - Pino Toscano <pino@debian.org>
libindi (0.9.1-2) unstable; urgency=low
* Release to unstable.
* Bump the libnova-dev build dependency to >= 0.14.0. (Not really needed,
but makes sure it is built with an up-to-date libnova.)
2012-03-23 - Pino Toscano <pino@debian.org>
libindi (0.9.1-1) experimental; urgency=low
* New upstream release.
* It seems ABI is broken (new virtual method), so:
- bump the SONAME to 0b (update patch abi.diff)
- rename libindi0a to libindi0b
* Bump Standards-Version to 3.9.3, no changes required.
* Switch copyright to copyright-format 1.0.
2012-01-16 - Pino Toscano <pino@debian.org>
libindi (0.9-1) unstable; urgency=low
* New upstream release:
- provides the fix by Nobuhiro Iwamatsu (thanks!) for compiling on SuperH.
(Closes: #644456)
* Update the patches:
- destdir.diff: drop, applied upstream
- fix-pkgconfig.diff: drop, applied upstream
- format-security.diff: drop, applied upstream
- libdir.diff: refresh, dropping the applied parts
* boost is no more a dependency, so remove libboost-dev from the the build
dependencies and from the libindi-dev dependencies.
* libindi-dev: add dependency on libcfitsio3-dev, as cfitsio headers are
included in public headers.
* Update copyright.
* Upstream does not keep a stable ABI while not bumping the SONAME, so:
- bump the SONAME to 0a (patch abi.diff)
- rename libindi0 to libindi0a
- drop the symbols file of libindi, "replaced" by a tight shlibs

See Also

Package Description
libindirect-perl_0.33-1_amd64.deb module warning about using the indirect object syntax
libinfgtk3-0.6-0_0.6.7-1~deb8u1_amd64.deb infinote-based collaborative editing (Gtk widgets)
libinfinity-0.6-0_0.6.7-1~deb8u1_amd64.deb infinote-based collaborative editing
libinfinity-0.6-dev_0.6.7-1~deb8u1_amd64.deb infinote-based collaborative editing - development files
libinfinity-0.6-doc_0.6.7-1~deb8u1_all.deb infinote-based collaborative editing - documentation
libini-config-dev_0.4.0-1_amd64.deb Development files for libini_config
libini-config5_0.4.0-1_amd64.deb INI file parser for C
libini4j-java-doc_0.5.2-SNAPSHOT-5_all.deb Java API for handling Windows ini file format (documentation)
libini4j-java_0.5.2-SNAPSHOT-5_all.deb Java API for handling Windows ini file format (library)
libinifiles-ocaml-dev_1.2-3_amd64.deb read and write .ini files for OCaml
libinifiles-ocaml_1.2-3_amd64.deb read and write .ini files for OCaml (runtime)
libinklevel-dev_0.8.0-3_amd64.deb development files for libinklevel5
libinklevel5_0.8.0-3_amd64.deb library for checking the ink level of your local printer
libinline-c-perl_0.64-1_all.deb C Language Support for Inline
libinline-files-perl_0.68-1_all.deb module to handle multiple virtual files at the end of your code
Advertisement
Advertisement