libimport-into-perl_1.002004-1_all.deb


Advertisement

Description

libimport-into-perl - module for importing packages into other packages

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libimport-into-perl
Package version 1.002004
Package release 1
Package architecture all
Package type deb
Installed size 55 B
Download size 11.18 KB
Official Mirror ftp.br.debian.org
Import::Into creates a global method import::into which you can call on
any package to import it into another package. This is useful because
there are many diferent ways to write exporters: some use Exporter, some
use Sub::Exporter, some use Moose::Exporter, some use Exporter::Declare
and some things are pragmas.
And if you want to re-export other things, you have to know which is which.
Exporter subclasses provide export_to_level, but if they overrode their
import method all bets are off. Sub::Exporter provides an into parameter
but figuring out something used it isn't trivial. Pragmas need to have
their import method called directly since they affect the current unit of
compilation. Import::Into can be used to import packages into other packages
without having to deal with the specific details of every exporting approach.

Alternatives

Package Version Architecture Repository
libimport-into-perl_1.002004-1_all.deb 1.002004 all Debian Main
libimport-into-perl - - -

Requires

Name Value
libmodule-runtime-perl -
perl -

Download

Type URL
Binary Package libimport-into-perl_1.002004-1_all.deb
Source Package libimport-into-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libimport-into-perl deb package:
    # sudo apt-get install libimport-into-perl

Files

Path
/usr/share/doc/libimport-into-perl/changelog.Debian.gz
/usr/share/doc/libimport-into-perl/changelog.gz
/usr/share/doc/libimport-into-perl/copyright
/usr/share/man/man3/Import::Into.3pm.gz
/usr/share/perl5/Import/Into.pm

Changelog

2014-07-12 - gregor herrmann <gregoa@debian.org>
libimport-into-perl (1.002004-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Add new upstream copyright holder.
* Add (build) dependency on libmodule-runtime-perl.
2014-05-06 - gregor herrmann <gregoa@debian.org>
libimport-into-perl (1.002002-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop spelling.patch, merged upstream.
2014-05-06 - gregor herrmann <gregoa@debian.org>
libimport-into-perl (1.002001-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Strip trailing slash from metacpan URLs.
* Add a patch to fix a spelling mistake.
2013-12-25 - gregor herrmann <gregoa@debian.org>
libimport-into-perl (1.002000-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Add new upstream copyright holder.
* Declare compliance with Debian Policy 3.9.5.
2013-10-22 - gregor herrmann <gregoa@debian.org>
libimport-into-perl (1.001001-1) unstable; urgency=low
* Team upload.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Declare compliance with Debian Policy 3.9.4.
2012-07-31 - Nuno Carvalho <smash@cpan.org>
libimport-into-perl (1.001000-1) unstable; urgency=low
* Initial Release. (Closes: #683423)

See Also

Package Description
libimvirt-perl_0.9.6-1_all.deb Perl module for detecting several virtualizations
libincidenceeditorsng4_4.14.1-1+deb8u1_amd64.deb incidence editors library
libindi-data_0.9.8.1-5.1_all.deb Instrument-Neutral Device Interface library -- shared data
libindi-dev_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- development files
libindi-plugins_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- plugins
libindi0b_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- client library
libindialignmentdriver0_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- alignment driver lib
libindicate-dev_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - development files
libindicate-doc_0.6.92-2+deb8u1_all.deb library for raising indicators via DBus - documentation
libindicate-gtk-dev_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - GTK+ bindings development files
libindicate-gtk0.1-cil-dev_0.6.92-2+deb8u1_all.deb CLI bindings for libindicate-gtk2 - development files
libindicate-gtk0.1-cil_0.6.92-2+deb8u1_all.deb CLI bindings for libindicate-gtk3
libindicate-gtk3-3_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - GTK bindings
libindicate-gtk3-dev_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - GTK bindings development files
libindicate-gtk3_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - GTK+ bindings
Advertisement
Advertisement