libimobiledevice-utils_1.1.6+dfsg-3.1_amd64.deb


Advertisement

Description

libimobiledevice-utils - Library for communicating with iPhone and iPod Touch devices

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libimobiledevice-utils
Package version 1.1.6+dfsg
Package release 3.1
Package architecture amd64
Package type deb
Installed size 284 B
Download size 74.71 KB
Official Mirror ftp.br.debian.org
libimobiledevice is a library that talks the native Apple USB protocols that
the iPhone and iPod Touch use. Unlike other projects, libimobiledevice does
not depend on using any existing libraries from Apple.
This package contains utilities and examples which use libimobiledevice.

Alternatives

Package Version Architecture Repository
libimobiledevice-utils_1.1.6+dfsg-3.1_i386.deb 1.1.6+dfsg i386 Debian Main
libimobiledevice-utils - - -

Requires

Name Value
libc6 >= 2.14
libgcrypt20 >= 1.6.1
libgnutls-deb0-28 >= 3.2.10-0
libimobiledevice4 >= 1.1.6
libplist2 >= 1.11
libtasn1-6 >= 4.0-0
libusbmuxd2 >= 1.0.9

Download

Type URL
Binary Package libimobiledevice-utils_1.1.6+dfsg-3.1_amd64.deb
Source Package libimobiledevice

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libimobiledevice-utils deb package:
    # sudo apt-get install libimobiledevice-utils

Files

Path
/usr/bin/idevice_id
/usr/bin/idevicebackup
/usr/bin/idevicebackup2
/usr/bin/idevicecrashreport
/usr/bin/idevicedate
/usr/bin/idevicedebugserverproxy
/usr/bin/idevicediagnostics
/usr/bin/ideviceenterrecovery
/usr/bin/ideviceimagemounter
/usr/bin/ideviceinfo
/usr/bin/idevicename
/usr/bin/idevicepair
/usr/bin/ideviceprovision
/usr/bin/idevicescreenshot
/usr/bin/idevicesyslog
/usr/share/doc/libimobiledevice-utils/changelog.Debian.gz
/usr/share/doc/libimobiledevice-utils/copyright
/usr/share/man/man1/idevice_id.1.gz
/usr/share/man/man1/idevicebackup.1.gz
/usr/share/man/man1/idevicebackup2.1.gz
/usr/share/man/man1/idevicecrashreport.1.gz
/usr/share/man/man1/idevicedate.1.gz
/usr/share/man/man1/idevicedebugserverproxy.1.gz
/usr/share/man/man1/idevicediagnostics.1.gz
/usr/share/man/man1/ideviceenterrecovery.1.gz
/usr/share/man/man1/ideviceimagemounter.1.gz
/usr/share/man/man1/ideviceinfo.1.gz
/usr/share/man/man1/idevicename.1.gz
/usr/share/man/man1/idevicepair.1.gz
/usr/share/man/man1/ideviceprovision.1.gz
/usr/share/man/man1/idevicescreenshot.1.gz
/usr/share/man/man1/idevicesyslog.1.gz

Changelog

2014-08-17 - Sebastian Ramacher <sramacher@debian.org>
libimobiledevice (1.1.6+dfsg-3.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/control: Switch libgnutls-dev in libimobiledevice-dev's Depends to
libgnutls28-dev to reflect Build-Depends changes. (Closes: #747536)
2014-07-23 - Chow Loong Jin <hyperair@debian.org>
libimobiledevice (1.1.6+dfsg-3) unstable; urgency=medium
* Team upload
* [1855046] Update gnutls and gcrypt build-deps (Closes: #747536)
2014-06-23 - Chow Loong Jin <hyperair@debian.org>
libimobiledevice (1.1.6+dfsg-2) unstable; urgency=medium
* [169b453] Fix libimobiledevice-utils.manpages.
- Drop duplicate idevicebackup.1 entry
- Add idevicename.1 and idevicecrashreport.1
Thanks to Artur Rona (Closes: #750955)
* [583a454] Fix dependency on transitional libtasn1-3-dev package
(Closes: #731707)
2014-04-14 - Chow Loong Jin <hyperair@debian.org>
libimobiledevice (1.1.6+dfsg-1) unstable; urgency=medium
* Team upload
* [51f7f7a] Imported Upstream version 1.1.6
* [ed48bf8] Update build-dependencies
* [052c1b3] Bump Standards-Version to 3.9.5 (no changes required)
* [b89ebca] Refresh patches
* [dbe83f7] Build-dep on libtasn-1-6-dev instead of libtasn-1-3-dev
(Closes: #731707)
* [09293bb] Downgrade usbmuxd dependency to recommends and suggest
libusbmuxd-tools
(Closes: #658541)
* [0a602f1] Use symbol script to hide private symbols
* [f85dcf3] Update symbols file.
Drop private symbols, and add new symbols
* [7338f73] Drop unused patches
* [99e4676] Exclude jquery.js
* [64e7829] Update copyright file
2013-10-30 - Chow Loong Jin <hyperair@debian.org>
libimobiledevice (1.1.5-2) unstable; urgency=low
* [0052e46] Drop hal fdi file.
That stuff doesn't work anymore. (Closes: #728151)
2013-10-28 - Chow Loong Jin <hyperair@debian.org>
libimobiledevice (1.1.5-1) experimental; urgency=low
* Team upload.
* Ack NMU from Andreas Metzler
* [1282e33] Imported Upstream version 1.1.5 (Closes: #709369):
- Adapt to libusbmuxd API changes (Closes: #682275)
* [27231df] Refresh or drop patches
- 00git_ios5_support.patch: Drop, applied upstream
- 01-libs.private.patch: Refresh
- 02-add-missing-linking.patch: Drop, applied upstream
- 03_ac_pkg_swig_m4_fixed.patch: Drop, no longer relevant
- 04_libplist_DSO_linking.patch: Drop, applied upstream
- 05_remove_gcry_need.patch: Drop, no longer relevant
* [0f497a0] Drop --host and --build arguments from configure.
This is already applied by dh_auto_configure automatically.
* [a370ab0] Reindent build-depends and drop trailing whitespace
* [a3fffe5] Bump dh compat to 9 for buildflags
* [40725ee] Enable multi-arch
* [65d74c4] Move dh --with parameter after $@
* [596a2b7] Update command for removing *.la for multiarch path
* [979998b] Update .manpages file for new utilities
* [3c37d78] Don't ship embedded jquery.js
2013-10-19 - Andreas Metzler <ametzler@debian.org>
libimobiledevice (1.1.5-0.2) experimental; urgency=low
* Non-maintainer upload.
* libimobiledevice4-dbg replaces/conflicts libimobiledevice2-dbg.
Closes: #726752
2013-10-12 - Andreas Metzler <ametzler@debian.org>
libimobiledevice (1.1.5-0.1) experimental; urgency=low
* Non-maintainer upload.
* Sync from Ubuntu.
+ New upstream version. Closes: #709369
+ Includes fix for CVE-2013-2142: insecure /tmp usage. Closes: #710885
+ Compatible with newer libusbmuxd. Closes: #682275
+ New upstream version does not use gnutls_*_set_priority functions
anymore. Closes: #624066
+ Package builds. Closes: #713689
+ Does not depend on libusbmuxd1. Closes: #725637
* configure with --disable-silent-rules
* Delete ubuntu-revision on symbol string_concat@Base in 
debian/libimobiledevice4.symbols.
* Update authors and download location in debian/copyright.

See Also

Package Description
libimobiledevice4_1.1.6+dfsg-3.1_amd64.deb Library for communicating with the iPhone and iPod Touch
libimport-into-perl_1.002004-1_all.deb module for importing packages into other packages
libimvirt-perl_0.9.6-1_all.deb Perl module for detecting several virtualizations
libincidenceeditorsng4_4.14.1-1+deb8u1_amd64.deb incidence editors library
libindi-data_0.9.8.1-5.1_all.deb Instrument-Neutral Device Interface library -- shared data
libindi-dev_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- development files
libindi-plugins_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- plugins
libindi0b_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- client library
libindialignmentdriver0_0.9.8.1-5.1+b1_amd64.deb Instrument-Neutral Device Interface library -- alignment driver lib
libindicate-dev_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - development files
libindicate-doc_0.6.92-2+deb8u1_all.deb library for raising indicators via DBus - documentation
libindicate-gtk-dev_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - GTK+ bindings development files
libindicate-gtk0.1-cil-dev_0.6.92-2+deb8u1_all.deb CLI bindings for libindicate-gtk2 - development files
libindicate-gtk0.1-cil_0.6.92-2+deb8u1_all.deb CLI bindings for libindicate-gtk3
libindicate-gtk3-3_0.6.92-2+deb8u1_amd64.deb library for raising indicators via DBus - GTK bindings
Advertisement
Advertisement