libimage-size-perl_3.232-1_all.deb


Advertisement

Description

libimage-size-perl - module for determining image sizes in several common formats

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libimage-size-perl
Package version 3.232
Package release 1
Package architecture all
Package type deb
Installed size 129 B
Download size 44.83 KB
Official Mirror ftp.br.debian.org
Image::Size is a Perl module capable of determining image sizes from several
common formats. It handles XPM, XBM, GIF, JPEG, PNG, MNG, the PPM family of
formats (PPM/PGM/PBM), TIFF, FlashMX (Shockwave Flash version 6), WMF/EMF,
and more.
It supports additional file types through Image::Magick (see perlmagick), and
the included "imgsize" script provides access to Image::Size from the shell.

Alternatives

Package Version Architecture Repository
libimage-size-perl_3.232-1_all.deb 3.232 all Debian Main
libimage-size-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libimage-size-perl_3.232-1_all.deb
Source Package libimage-size-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libimage-size-perl deb package:
    # sudo apt-get install libimage-size-perl

Files

Path
/usr/bin/imgsize
/usr/share/doc/libimage-size-perl/README
/usr/share/doc/libimage-size-perl/changelog.Debian.gz
/usr/share/doc/libimage-size-perl/changelog.gz
/usr/share/doc/libimage-size-perl/copyright
/usr/share/doc/libimage-size-perl/examples/make_gallery.pl
/usr/share/man/man1/imgsize.1p.gz
/usr/share/man/man3/Image::Size.3pm.gz
/usr/share/perl5/Image/Size.pm

Changelog

2012-06-08 - gregor herrmann <gregoa@debian.org>
libimage-size-perl (3.232-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* New upstream release.
* Refresh patches.
* debian/copyright: update to Copyright-Format 1.0.
* debian/copyright: update copyright years and license stanzas.
* Bump Standards-Version to 3.9.3 (no changes).
* Set debhelper compatibility level to 8.
2010-10-04 - Jonathan Yu <jawnsy@cpan.org>
libimage-size-perl (3.230-1) unstable; urgency=low
* New upstream release
+ Drop author tests, they've been moved to xt/
+ Adds support for Windows WMF files
* Refresh patches, remove critic patch (moved to xt/)
* Standards-Version 3.9.1 (no changes)
* Drop dependencies for compression stuff; perl 5.10 is available in
stable
* No longer use AUTHOR_TESTING, drop debhelper dependency
2010-05-03 - Jonathan Yu <jawnsy@cpan.org>
libimage-size-perl (3.221-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Rewrite control description
* Standards-Version 3.8.4 (no changes)
* Use new 3.0 (quilt) source format
* Update copyright to new DEP5 format
* Update imgsize exit code patch
* Add patch to fix POD spelling errors
[ gregor herrmann ]
* debian/copyright: update years of upstream copyright.
2009-11-10 - Jonathan Yu <jawnsy@cpan.org>
libimage-size-perl (3.220-1) unstable; urgency=low
* New upstream release
2009-10-22 - Jonathan Yu <jawnsy@cpan.org>
libimage-size-perl (3.210-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Add myself to Uploaders and Copyright
* Updated watch with mangle to handle new versions
* Remove the install-imgsize patch; it's now installed by default
* Add patch to disable perlcritic
[ Ryan Niebur ]
* Update ryan52's email address
[ gregor herrmann ]
* debian/control: add libio-compress-perl as another alternative (build)
dependency for getting Compress::Zlib.
2009-08-21 - gregor herrmann <gregoa@debian.org>
libimage-size-perl (3.2-3) unstable; urgency=low
* Add "perl (>= 5.10)" as an alternative build dependency on
libcompress-zlib-perl as a preparation for the Perl 5.10.1 transition
(cf. #542686).
* Set Standards-Version to 3.8.3 (no changes).
* Reword short description.
* Minimize debian/rules, adjust versioned build dependencies on debhelper
and quilt.
* debian/control: change my email address.
2009-08-14 - Christoph Berg <myon@debian.org>
libimage-size-perl (3.2-2) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ gregor herrmann ]
* Rename source package to libimage-size-perl.
[ Christoph Berg ]
* Remove me from Uploaders.
2009-02-28 - Ryan Niebur <ryanryan52@gmail.com>
image-size (3.2-1) unstable; urgency=low
[ gregor herrmann ]
* Add debian/README.source to document quilt usage, as required by
Debian Policy since 3.8.0.
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Ryan Niebur ]
* New upstream release
* debhelper 7
* machine readable copyright format
* add me to uploaders
* bump Standards-Version to 3.8.0
[ gregor herrmann ]
* debian/control: remove build dependency on libmodule-build-perl, dh7
prefers ExtUtils::MakeMaker.
* debian/rules: touch Makefile after unpatching Makefile.PL.
2008-03-26 - gregor herrmann <gregor+debian@comodo.priv.at>
image-size (3.1.1-2) unstable; urgency=low
* Update patch imgsize-fixes to make it compatible with the new enabled
warnings; based on a patch from Reid Priedhorsky, thanks!
Closes: #472760
* debian/copyright: add Debian Perl Group to copyright holders for the
packaging.

See Also

Package Description
libimager-perl_1.000+dfsg-2+b3_amd64.deb Perl extension for generating 24-bit images
libimager-qrcode-perl_0.033-1.2+b1_amd64.deb Generate QR code with Imager using libqrencode
libimap-admin-perl_1.6.7-1_all.deb Perl module for administrating IMAP servers
libimdb-film-perl_0.53-1_all.deb Perl extension for retrieving movie info from IMDB.com
libiml-dev_1.0.3-5_amd64.deb Integer Matrix Library, development files
libiml0_1.0.3-5_amd64.deb Integer Matrix Library, runtime files
libimlib2-dev_1.4.6-2+deb8u2_amd64.deb image loading, rendering, saving library (development files)
libimlib2_1.4.6-2+deb8u2_amd64.deb image loading, rendering, saving library
libimobiledevice-dev_1.1.6+dfsg-3.1_amd64.deb Library for communicating with iPhone and iPod Touch devices
libimobiledevice-doc_1.1.6+dfsg-3.1_all.deb Library for communicating with iPhone and iPod Touch devices
libimobiledevice-utils_1.1.6+dfsg-3.1_amd64.deb Library for communicating with iPhone and iPod Touch devices
libimobiledevice4_1.1.6+dfsg-3.1_amd64.deb Library for communicating with the iPhone and iPod Touch
libimport-into-perl_1.002004-1_all.deb module for importing packages into other packages
libimvirt-perl_0.9.6-1_all.deb Perl module for detecting several virtualizations
libincidenceeditorsng4_4.14.1-1+deb8u1_amd64.deb incidence editors library
Advertisement
Advertisement