libident_0.22-3_amd64.deb


Advertisement

Description

libident - simple RFC1413 client library - runtime

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libident
Package version 0.22
Package release 3
Package architecture amd64
Package type deb
Installed size 84 B
Download size 13.95 KB
Official Mirror ftp.br.debian.org
This is a small library to interface to the Ident protocol server;
"ident" enables a remote host to find out who's the owner of a
network connection.
/usr/sbin/in.identtestd is a small daemon (to be started from inetd)
that does an ident lookup on you if you telnet into it. Can be used
to verify that your Ident server is working correctly.

Alternatives

Package Version Architecture Repository
libident_0.22-3_i386.deb 0.22 i386 Debian Main
libident - - -

Requires

Name Value
libc6 >= 2.3.5-1

Download

Type URL
Binary Package libident_0.22-3_amd64.deb
Source Package libident

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libident deb package:
    # sudo apt-get install libident

Files

Path
/usr/lib/libident.so.0
/usr/lib/libident.so.0.22
/usr/sbin/in.identtestd
/usr/share/doc/libident/README.gz
/usr/share/doc/libident/changelog.Debian.gz
/usr/share/doc/libident/copyright
/usr/share/man/man8/in.identtestd.8.gz

Changelog

2005-03-04 - Paul Slootman <paul@debian.org>
libident (0.22-3) unstable; urgency=low
* acknowledge NMUs.
closes:#209057,#103890,#176348,#187072,#190712,#198996,#208040
(with a different fix for 198996, remove the bashisms instead of forcing bash)
* fix section and priorities.
closes:#209102
* Added IPv6 patches from http://kebo.vlsm.org/debian-ipv6/patch/libident/
* Added misc patches, collected in the exim fork of libident.
* Updated to Debian policy version 3.6.1.
* fix XSI:isms in shell tests and deprecated head usage.
closes:#256234
* Include section info in package.
closes:#288750
* Take options out of $(AR) in Makefile, to facilitate cross-building.
closes:#282911
* Upload of new version mentioned in #231723 will follow after checking it...
2003-09-07 - Petter Reinholdtsen <pere@debian.org>
libident (0.22-2.2) unstable; urgency=low
* Non-maintainer upload.
* Remove obsolete 'undef LD_PRELOAD', to get the source building on
the autobuilders. (Closes: #209057)
2003-08-31 - Petter Reinholdtsen <pere@debian.org>
libident (0.22-2.1) unstable; urgency=low
* Non-maintainer upload.
* Add missing manpage symlinks. (Closes: #103890)
* Rebuilding library should fix prelinking problem. (Closes: #176348)
* New upload will end up in the pool archive structure.
Not really a bug, but it will solve it.  (Closes: #187072)
* Fix typo in in.identtestd(8). (Closes: #190712)
* Set SHELL=/bin/bash in debian/rules to avoid build errors when using
a POSIX shell.  Patch from Göran Weinholt.  (Closes: #198996)
* Add -D_REENTRANT when compiling the static library, to make sure the
package follow Debian policy 11.2. (Closes: #208040)
1999-10-28 - Paul Slootman <paul@debian.org>
libident (0.22-2) unstable; urgency=low
* updated to debian policy version 3.0.1.
1999-01-13 - Paul Slootman <paul@debian.org>
libident (0.22-1) unstable; urgency=low
* new upstream source.
* added workaround for ident servers that return a different format string,
i.e. "%u,%U,%g,%G,%l,%L,%p,%c,%C" (Red Hat 5.0?) to prevent possible
segmentation violation. Fix obtained from exim mailing list, originally
from Darrell Fuhriman <darrell@grumblesmurf.net>.
1998-10-01 - Paul Slootman <paul@debian.org>
libident (0.21-7) unstable; urgency=low
* fixed the shlibs dependency version number.
* updated to debian policy version 2.4.1.4.
1998-09-07 - Paul Slootman <paul@debian.org>
libident (0.21-6) unstable; urgency=low
* provide versionless .so link in -dev package. fixes:#26453
* provide symlink /usr/doc/libident-dev to libident in -dev package.
1998-08-25 - Paul Slootman <paul@debian.org>
libident (0.21-5) unstable; urgency=low
* Didn't conform to policy (no separate -dev package). fixes:#22092
* libident-dev now contains the man3 manpage, the include file, and the
static library
* libident now contains the tester program and the shared library.
* manpage ident.3 now compressed. fixes:#20342
* debian/files and debian/substvars now removed in clean target. fixes:#25403
1998-03-19 - Paul Slootman <paul@debian.org>
libident (0.21-4) unstable; urgency=high
* new maintainer
* don't strip libs _completely_! fixes #17670,#17009,16487
* added dependency info
* wrote manpage for in.identtestd
* should now adhere to debian policy version 2.4.0.0
1997-12-11 - Rob Browning <rlb@cs.utexas.edu>
libident (0.21-3) unstable; urgency=low
* Changed architecture to "all" from i386.  Couldn't see any reason not
to.  If anyone knows different, speak up.  Closes Bug #13700.

See Also

Package Description
libidl-dev_0.8.14-0.4+b1_amd64.deb development files for programs that use libIDL
libidl0_0.8.14-0.4+b1_amd64.deb library for parsing CORBA IDL files
libidm-console-framework-java_1.1.7-2_all.deb IDM Console Framework for the 389 Directory Server Console
libidn11-dev_1.29-1+deb8u2_amd64.deb Development files for GNU Libidn, an IDN library
libidn11-java_1.29-1+deb8u2_all.deb Java port of the GNU Libidn library, an IDN implementation
libidn11_1.29-1+deb8u2_amd64.deb GNU Libidn library, implementation of IETF IDN specifications
libidn2-0-dev_0.10-2+deb8u1_amd64.deb Internationalized domain names (IDNA2008) development files
libidn2-0_0.10-2+deb8u1_amd64.deb Internationalized domain names (IDNA2008) library
libidna-punycode-perl_1.100-1_all.deb module to encode Unicode string in Punycode
libido-0.1-0_0.3.4-1.1_amd64.deb widgets and other objects used for indicators
libido-0.1-dev_0.3.4-1.1_amd64.deb development files for the libido library
libido3-0.1-0_0.3.4-1.1_amd64.deb widgets and other objects used for indicators - GTK3 version
libido3-0.1-dev_0.3.4-1.1_amd64.deb development files for the libido library - GTK3 version
libidw-java-doc_1.6.1-1_all.deb InfoNode Docking Windows (javadoc)
libidw-java_1.6.1-1_all.deb InfoNode Docking Windows (similar to JInternalFrames)
Advertisement
Advertisement