libhttp-proxy-perl_0.301-1+deb8u1_all.deb


Advertisement

Description

libhttp-proxy-perl - pure Perl HTTP proxy

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libhttp-proxy-perl
Package version: 0.301
Package release: 1+deb8u1
Package architecture: all
Package type: deb
Installed size: 279 B
Download size: 109.27 KB
Official Mirror: ftp.br.debian.org
HTTP::Proxy implements the methods needed to run a pure-perl HTTP proxy using LWP. Useful for lightweight, easy to configure proxies. The most interesting feature of this proxy object is its ability to filter the HTTP requests and responses through user-defined filters.

Alternatives

    Download

    Source package: libhttp-proxy-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libhttp-proxy-perl deb package:
      # sudo apt-get install libhttp-proxy-perl

    Changelog

    2017-06-28 - gregor herrmann <gregoa@debian.org> libhttp-proxy-perl (0.301-1+deb8u1) jessie; urgency=medium * Add patch to fix broken custom 'via' handling. (Patch taken from upstream release 0.304.) (Closes: #788350)

    2014-08-03 - gregor herrmann <gregoa@debian.org> libhttp-proxy-perl (0.301-1) unstable; urgency=medium * New upstream release. * Strip trailing slash from metacpan URLs. * Update years of packaging copyright. * Drop build dependencies on libtest-pod-{,coverage-}perl. Tests are release tests now. * Declare compliance with Debian Policy 3.9.5.

    2013-05-26 - gregor herrmann <gregoa@debian.org> libhttp-proxy-perl (0.300-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. Fixes "FTBFS with perl 5.18: POD" (Closes: #709830) * Build depend on Module::Build 0.38. * Set Standards-Version to 3.9.4 (no changes). * Drop patch pod_coverage.patch, the issue is fixed upstream. * debian/copyright: switch formatting to Copyright-Format 1.0. * Update years of upstream and packaging copyright. * Add a patch to fix a spelling mistake in the POD.

    2011-07-03 - Salvatore Bonaccorso <carnil@debian.org> libhttp-proxy-perl (0.25-1) unstable; urgency=low * Team upload. * New upstream release * debian/copyright: Update copyright years. * debian/patches: - Remove pod_spelling.patch as it was fixed upstream. - Update pod_coverage.patch to exclude too 'worker' subroutine. * debian/control: Move perl from Build-Depends-Indep to Build-Depends.

    2011-05-05 - gregor herrmann <gregoa@debian.org> libhttp-proxy-perl (0.24-3) unstable; urgency=low * Add a patch to work around a failure in the pod-coverage test under perl 5.12 (closes: #578940). * Set Standards-Version to 3.9.2 (no changes).

    2011-04-04 - gregor herrmann <gregoa@debian.org> libhttp-proxy-perl (0.24-2) unstable; urgency=low [ Tim Retout ] * Email change: Tim Retout -> diocles@debian.org [ gregor herrmann ] * Prepare build and runtime dependencies for libwww-perl 6 (closes: #620482). * Switch to source format 3.0 (quilt). * Switch to debhelper 8. * Remove version from perl (build) dependency. * Update copyright format. * Set Standards-Version to 3.9.1 (no further changes). * Email change: Jose Luis Rivas -> ghostbar@debian.org * Remove patches from source package that have not been used for some time. * Update patch headers.

    2009-08-04 - Tim Retout <tim@retout.co.uk> libhttp-proxy-perl (0.24-1) unstable; urgency=medium [ gregor herrmann ] * New upstream release. * debian/copyright: adjust years of copyright. * Add debian/README.source to document quilt usage, as required by Debian Policy since 3.8.0. * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * debian/control: Added: ${misc:Depends} to Depends: field. * Remove build dependency on libmodule-build-perl, debhelper prefers EUMM. * debian/rules: use "--with quilt", adjust build dependencies. * debian/copyright: add years of upstream copyright. * debian/control: remove leading article from short description. * New patch hashbang.patch: adds/fixes hashbangs in example scripts. [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Jose Luis Rivas ] * Updated Standards-Version to 3.8.2. * Updated debian/rules to use debhelper 7. * Updated debian/control dependencies and added me as uploader. * Updated debian/copyright. [ Tim Retout ] * New upstream release (0.24). + Fixes FTBFS. (Closes: #521977) * Set urgency to medium for RC bug fix. * Add author/description to pod_spelling.patch. * debian/control: + Remove >= 2 from libwww-perl (build-)dependency; Debian has always had a version larger than this. + Add self to Uploaders. + Extend the long description.

    Advertisement
    Advertisement