libhdf4g-dev - Hierarchical Data Format library -- transitional development package

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libhdf4g-dev
Package version: 4.2.10
Package release: 3
Package architecture: all
Package type: deb
Installed size: 42 B
Download size: 13.03 KB
Official Mirror:
HDF is a multi-object file format for storing and transferring graphical and numerical data mainly used in scientific computing. HDF supports several different data models, including multidimensional arrays, raster images, and tables. Each defines a specific aggregate data type and provides an API for reading, writing, and organizing the data and metadata. New data models can be added by the HDF developers or users. This package is provided for transitional purpose. It can be safely removed after upgrading.




    Source package: libhdf4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libhdf4g-dev deb package:
      # sudo apt-get install libhdf4g-dev


    • /usr/share/doc/libhdf4g-dev/NEWS.Debian.gz
    • /usr/share/doc/libhdf4g-dev/changelog.Debian.gz
    • /usr/share/doc/libhdf4g-dev/copyright


    2014-10-21 - Johan Van de Wauw <> libhdf4 (4.2.10-3) unstable; urgency=medium [ Fernando Seiti Furusato ] * Fix endianness definition for ppc64el. [ Johan Van de Wauw ] * Disable tests on s390x (closes: #764353) * Remove unneeded build dep groff

    2014-10-05 - Johan Van de Wauw <> libhdf4 (4.2.10-2) unstable; urgency=medium * Add build-time checks * Fix wrong endianness s390x/mips(closes: #761603) * Fix ncgen test errors on arm64 (based on fedora changes) * Fix documentation paths * Add lintian override for spurious svn conflict files * Remove duplicate binary control fields * Add debian/source/format * Fix short descriptions, bump standards version * Clarify which version of the GPL applies to the debian packaging * Remove obsolete document prerm/postinst

    2014-09-13 - Johan Van de Wauw <> libhdf4 (4.2.10-1) unstable; urgency=medium * Add support for GNU Hurd * Fix kfreebsd-64 bit

    2014-08-14 - Johan Van de Wauw <> libhdf4 (4.2.10-1~exp1) experimental; urgency=medium * Add watchfile * Imported Upstream version 4.2.10 * Fix vcs link * Fix package synopsis length * Rewrite control file using cme * Fix debian/ to match debian/control * Use original source tarball rather than a tarball containing this tarball * Don't copy configufiles to fmpool (dir no longer exists) * Import ubuntu patches changes by doko (closes: #684361,#742421) * Add rsync as build-dep * Use libtoolize and autoreconf (closes: #639720,#744613) * Set debhelper version to 9 * Bump standards version * Copy sources using own bash script * enable hardening * Fix String literals * add Mips64(el) support (closes: #753493) * Add myself to uploaders

    2011-07-20 - Francesco Paolo Lovergine <> libhdf4 (4.2r4-12) unstable; urgency=low * Previous version did not revert an unreleased change by David Paleino: + debian/control: build-depend on libjpeg-dev rather than libjpeg62-dev (closes: #569249) * Ack previous NMU: - Empty dependency_libs in .la helper file (closes: #620593, #605002). - Depend on libjpeg-dev (closes: #629968). * Policy bumped to 3.9.2, no changes required.

    2010-09-13 - Francesco Paolo Lovergine <> libhdf4 (4.2r4-11) unstable; urgency=high * Fixes hdfi.h for SPARC. Thanks Aurelien Jarno. (closes: #596603)

    2010-01-18 - Francesco Paolo Lovergine <> libhdf4 (4.2r4-10) unstable; urgency=low * Revised hdfi.h to support superH arch. (closes: #562796)

    2010-01-14 - Francesco Paolo Lovergine <> libhdf4 (4.2r4-9) unstable; urgency=low * Pre-apply kfreebsd patch to manage arch correctly in (closes: #542522) * Updated autotools patch by re-autoconfiscating. (closes: #562796)

    2010-01-13 - Francesco Paolo Lovergine <> libhdf4 (4.2r4-8) unstable; urgency=low * Added a conflict/replace against old libhdf4g-dev for the new libhdf4-alt-dev packaga, introduced after Lenny. (closes: #562856)

    2009-10-13 - Francesco Paolo Lovergine <> libhdf4 (4.2r4-7) unstable; urgency=low * Added a missing dh_installdeb -a that prevented adding required ldconfig at library installation/removing. * Updated autotools patch by autoreconfing. (closes: #542522)