libhash-flatten-perl_1.19-1_all.deb


Advertisement

Description

libhash-flatten-perl - flatten/unflatten complex data hashes

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libhash-flatten-perl
Package version 1.19
Package release 1
Package architecture all
Package type deb
Installed size 32 B
Download size 11.23 KB
Official Mirror ftp.br.debian.org
Hash::Flatten converts back and forth between a nested hash structure and
a flat hash of delimited key-value pairs. Useful for protocols that only
support key-value pairs (such as CGI and DBMs).

Alternatives

Package Version Architecture Repository
libhash-flatten-perl_1.19-1_all.deb 1.19 all Debian Main
libhash-flatten-perl - - -

Requires

Name Value
libtest-assertions-perl -
perl -

Download

Type URL
Binary Package libhash-flatten-perl_1.19-1_all.deb
Source Package libhash-flatten-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libhash-flatten-perl deb package:
    # sudo apt-get install libhash-flatten-perl

Files

Path
/usr/share/doc/libhash-flatten-perl/changelog.Debian.gz
/usr/share/doc/libhash-flatten-perl/changelog.gz
/usr/share/doc/libhash-flatten-perl/copyright
/usr/share/man/man3/Hash::Flatten.3pm.gz
/usr/share/perl5/Hash/Flatten.pm

Changelog

2010-10-11 - Ansgar Burchardt <ansgar@debian.org>
libhash-flatten-perl (1.19-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ansgar Burchardt ]
* New upstream release.
* Use tiny debian/rules.
* Use source format 3.0 (quilt).
* debian/copyright: Formatting changes; refer to "Debian systems" instead of
"Debian GNU/Linux systems"; refer to /usr/share/common-licenses/GPL-1.
* Bump Standards-Version to 3.9.1.
* Add myself to Uploaders.
2009-04-08 - Krzysztof Krzy┼╝aniak (eloy) <eloy@debian.org>
libhash-flatten-perl (1.16-2) unstable; urgency=low
* debian/copyright: fixed lincence info. Package is licenced GPL-2+ (included
COPYRIGHT file is GPL version 2 and link mentioned in README points to GPL-3)
2009-04-08 - Krzysztof Krzy┼╝aniak (eloy) <eloy@debian.org>
libhash-flatten-perl (1.16-1) unstable; urgency=low
* Initial Release (closes: #523103).

See Also

Package Description
libhash-merge-perl_0.200-1_all.deb Perl module for merging arbitrarily deep hashes into a single hash
libhash-merge-simple-perl_0.051-1_all.deb Perl module to easily merge two or more hashes
libhash-moreutils-perl_0.05-1_all.deb module with extra hash functions not found in Hash::Util
libhash-multivalue-perl_0.15-1_all.deb module for storing multiple values per key in a hash
libhash-storediterator-perl_0.007-1+b1_amd64.deb Perl module for accessing a hashes internal iterator
libhash-util-fieldhash-compat-perl_0.08-1_all.deb Perl module providing a Hash::Util::FieldHash compatible API
libhash-withdefaults-perl_0.05-1_all.deb class for hashes with key-casing requirements supporting defaults
libhashkit-dev_1.0.18-4_amd64.deb libmemcached hashing functions and algorithms (development files)
libhashkit2_1.0.18-4_amd64.deb libmemcached hashing functions and algorithms
libhavege-dev_1.9.1-1_amd64.deb entropy source using the HAVEGE algorithm - development files
libhavege1_1.9.1-1_amd64.deb entropy source using the HAVEGE algorithm - shared library
libhawknl-dev_1.6.8+dfsg2-1_amd64.deb Hawk game oriented network library API (development headers)
libhawknl_1.6.8+dfsg2-1_amd64.deb Hawk game oriented network library API
libhawtjni-runtime-java_1.10-1_all.deb Java library that provide JNI code generation
libhbaapi-dev_2.2.9-1_amd64.deb SNIA HBAAPI library (development files)
Advertisement
Advertisement