libgtk2-unique-perl_0.05-2+b1_amd64.deb


Advertisement

Description

libgtk2-unique-perl - module for single instance applications

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgtk2-unique-perl
Package version 0.05
Package release 2+b1
Package architecture amd64
Package type deb
Installed size 80 B
Download size 34.94 KB
Official Mirror ftp.br.debian.org
Gtk2::Unique is a Perl interface to the libunique library, which provides a
way to write single instance applications. If you launch a single instance
application twice, the second instance will either quit or send a message to
the running instance.

Alternatives

Package Version Architecture Repository
libgtk2-unique-perl_0.05-2+b1_i386.deb 0.05 i386 Debian Main
libgtk2-unique-perl - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.4
libcairo2 >= 1.2.4
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.24.0
libgtk2-perl -
libgtk2.0-0 >= 2.8.0
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libunique-1.0-0 >= 1.0.2
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libgtk2-unique-perl_0.05-2+b1_amd64.deb
Source Package libgtk2-unique-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgtk2-unique-perl deb package:
    # sudo apt-get install libgtk2-unique-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/UniqueApp.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/UniqueBackend.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/UniqueMessageData.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique/index.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique/Install/Files.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique/Install/unique-autogen.h
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique/Install/unique-perl.h
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Unique/Install/unique.typemap
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Gtk2/Unique/Unique.so
/usr/share/doc/libgtk2-unique-perl/changelog.Debian.amd64.gz
/usr/share/doc/libgtk2-unique-perl/changelog.Debian.gz
/usr/share/doc/libgtk2-unique-perl/changelog.gz
/usr/share/doc/libgtk2-unique-perl/copyright
/usr/share/doc/libgtk2-unique-perl/examples/sample.pl
/usr/share/man/man3/Gtk2::Unique.3pm.gz
/usr/share/man/man3/Gtk2::Unique::index.3pm.gz
/usr/share/man/man3/Gtk2::UniqueApp.3pm.gz
/usr/share/man/man3/Gtk2::UniqueBackend.3pm.gz
/usr/share/man/man3/Gtk2::UniqueMessageData.3pm.gz

Changelog

2014-04-24 - Florian Schlichting <fsfs@debian.org>
libgtk2-unique-perl (0.05-2) unstable; urgency=low
* Team upload
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Switch dh compatibility to level 9 to enable passing of hardening flags
* Declare compliance with Debian Policy 3.9.5
* Forward and add DEP-3 headers to add-whatis
2010-11-20 - gregor herrmann <gregoa@debian.org>
libgtk2-unique-perl (0.05-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Update copyright information
[ Damyan Ivanov ]
* add -a option to xvfb-run invocation
[ gregor herrmann ]
* Set Standards-Version to 3.9.1 (no changes).
* debian/copyright: update license stanzas.
* debian/control: remove version from libgtk2-perl (build) dependency.
2010-03-07 - gregor herrmann <gregoa@debian.org>
libgtk2-unique-perl (0.04-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Add myself to Copyright and Uploaders
* Rewrite control description
* Standards-Version 3.8.3
* Add perl to B-D, as it's not build-essential
* Refresh copyright information
[ Ryan Niebur ]
* Update ryan52's email address
[ gregor herrmann ]
* Refresh patch.
* Convert to source format 3.0 (quilt). Remove quilt framework.
* Set Standards-Version to 3.8.4 (no changes).
* Add /me to Uploaders.
* debian/{rules,control}: activate the test suite again, it seems fixed.
Also remove dbus-x11/dbus-launch, tests pass without them.
* debian/copyright: update Format-Specification and debian/ info.
2009-07-13 - Ryan Niebur <ryanryan52@gmail.com>
libgtk2-unique-perl (0.02-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ryan Niebur ]
* New upstream release
* Debian Policy 3.8.2
[ gregor herrmann ]
* debian/copyright: add year of upstream copyright.
2009-05-25 - Ryan Niebur <ryanryan52@gmail.com>
libgtk2-unique-perl (0.01-1) unstable; urgency=low
* Initial Release. (Closes: #530578)

See Also

Package Description
libgtk2.0-0_2.24.25-3+deb8u2_amd64.deb GTK+ graphical user interface library
libgtk2.0-bin_2.24.25-3+deb8u2_amd64.deb programs for the GTK+ graphical user interface library
libgtk2.0-cil-dev_2.12.10-5.1_amd64.deb CLI binding for the GTK+ toolkit 2.12
libgtk2.0-cil_2.12.10-5.1_amd64.deb CLI binding for the GTK+ toolkit 2.12
libgtk2.0-common_2.24.25-3+deb8u2_all.deb common files for the GTK+ graphical user interface library
libgtk2.0-dev_2.24.25-3+deb8u2_amd64.deb development files for the GTK+ library
libgtk2.0-doc_2.24.25-3+deb8u2_all.deb documentation for the GTK+ graphical user interface library
libgtk3-perl_0.018-1_all.deb Perl bindings for the GTK+ graphical user interface library
libgtk3.0-cil-dev_2.99.3-2_amd64.deb CLI binding for the GTK+ toolkit 3.0
libgtk3.0-cil_2.99.3-2_amd64.deb CLI binding for the GTK+ 3.0 toolkit
libgtkada-bin_2.24.4dfsg-1_amd64.deb Ada binding for the GTK+ GUI (development utilities)
libgtkada-doc_2.24.4dfsg-1_all.deb Ada binding for the GTK+ GUI (documentation)
libgtkada2.24.4-dev_2.24.4dfsg-1_amd64.deb Ada binding for the GTK+ GUI (development files)
libgtkada2.24.4_2.24.4dfsg-1_amd64.deb Ada binding for the GTK+ GUI (dynamic library)
libgtkdatabox-0.9.2-0-dev_0.9.2.0+dfsg-1_amd64.deb Gtk+ library to display large amounts of numerical data (development)
Advertisement
Advertisement