libgtk2-spell-perl_1.04-2+b1_amd64.deb


Advertisement

Description

libgtk2-spell-perl - Perl interface to the GtkSpell library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgtk2-spell-perl
Package version 1.04
Package release 2+b1
Package architecture amd64
Package type deb
Installed size 28 B
Download size 13.40 KB
Official Mirror ftp.br.debian.org
libgtk2-spell-perl allows one to use the GtkSpell library in Perl applications
using a Gtk2/GNOME interface. It can be used in concert with Gtk2::TextView
to provide highlighting of mis-spelled words and a right click pop-up menu
with possible corrections.

Alternatives

Package Version Architecture Repository
libgtk2-spell-perl_1.04-2+b1_i386.deb 1.04 i386 Debian Main
libgtk2-spell-perl - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.4
libcairo2 >= 1.2.4
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglib-perl >= 2:1.240
libglib2.0-0 >= 2.16.0
libgtk2-perl -
libgtk2.0-0 >= 2.8.0
libgtkspell0 >= 2.0.10
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libgtk2-spell-perl_1.04-2+b1_amd64.deb
Source Package libgtk2-spell-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgtk2-spell-perl deb package:
    # sudo apt-get install libgtk2-spell-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Spell.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Spell/Install/Files.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Spell/Install/gtk2spellperl.h
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gtk2/Spell/Install/gtkspell.typemap
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Gtk2/Spell/Spell.so
/usr/share/doc/libgtk2-spell-perl/changelog.Debian.amd64.gz
/usr/share/doc/libgtk2-spell-perl/changelog.Debian.gz
/usr/share/doc/libgtk2-spell-perl/changelog.gz
/usr/share/doc/libgtk2-spell-perl/copyright
/usr/share/man/man3/Gtk2::Spell.3pm.gz

Changelog

2014-04-24 - Florian Schlichting <fsfs@debian.org>
libgtk2-spell-perl (1.04-2) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
* Fix grammar error in package description. Thanks to Clayton Casciato
for the bug report and the patch. (Closes: #687467)
* Drop xz compression for {binary,source} package, set by default by
dpkg since 1.17.{0,6}.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ Florian Schlichting ]
* Switch dh compatibility to level 9 to enable passing of hardening flags
* Update debian/copyright to copyright-format 1.0
* Declare compliance with Debian Policy 3.9.5
2012-01-20 - Ansgar Burchardt <ansgar@debian.org>
libgtk2-spell-perl (1.04-1) unstable; urgency=low
[ Ansgar Burchardt ]
* New upstream release.
* Bump (build-)dep on libglib-perl to >= 2:1.240.
* Remove patch fix-Makefile.PL.patch: fixed upstream.
* Use xz compression for source and binary packages.
* Update my email address.
* debian/control: Convert Vcs-* fields to Git.
* Bumped Standards-Version to 3.9.2.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
2010-08-22 - Chris Butler <chrisb@debian.org>
libgtk2-spell-perl (1.03-5) unstable; urgency=low
* Added build dependency on myspell-en-us | myspell-dictionary-en |
hunspell-dictionary-en to fix test failure (closes: #591129).
* Run tests with LC_ALL=C to prevent the local environment causing test
failures.
* Add myself to Uploaders and copyright.
* Upped Standards-Version to 3.9.1 (no changes).
2010-05-15 - Ansgar Burchardt <ansgar@43-1.org>
libgtk2-spell-perl (1.03-4) unstable; urgency=low
[ Ryan Niebur ]
* Update ryan52's email address
[ Ansgar Burchardt ]
* Fix non-numeric dependencies breaking the build with Perl 5.12.
Thanks to Niko Tyni <ntyni@debian.org> for the patch.
(Closes: #578906)
+ new patch: fix-Makefile.PL.patch
* Use source format 3.0 (quilt).
* Add myself to Uploaders.
* debian/control: Make build-dep on perl unversioned.
* Bump Standards-Version to 3.8.4.
* Use xvfb to run test suite.
* debian/copyright: Formatting changes for current DEP-5 proposal.
2009-01-31 - Ryan Niebur <ryanryan52@gmail.com>
libgtk2-spell-perl (1.03-3) unstable; urgency=low
* Take over for the Debian Perl Group on maintainer's request
(http://lists.debian.org/debian-perl/2008/12/msg00163.html)
* Add debian/watch.
* Add me to uploaders, remove old maintainer(s)
* fix watch file
* debhelper 7
* policy 3.8.0
* disable tests, as they spit out error messages
* machine readable copyright format
2004-07-15 - Marc 'HE' Brockschmidt <he@debian.org>
libgtk2-spell-perl (1.03-2) unstable; urgency=low
* debian/control: I'm a DD.
2004-01-22 - Marc Brockschmidt <marc@dch-faq.de>
libgtk2-spell-perl (1.03-1) unstable; urgency=low
* Initial release.

See Also

Package Description
libgtk2-trayicon-perl_0.06-2+b1_amd64.deb Perl interface to fill the system tray
libgtk2-traymanager-perl_0.05-3+b1_amd64.deb Perl interface to fill the system tray
libgtk2-unique-perl_0.05-2+b1_amd64.deb module for single instance applications
libgtk2.0-0_2.24.25-3+deb8u2_amd64.deb GTK+ graphical user interface library
libgtk2.0-bin_2.24.25-3+deb8u2_amd64.deb programs for the GTK+ graphical user interface library
libgtk2.0-cil-dev_2.12.10-5.1_amd64.deb CLI binding for the GTK+ toolkit 2.12
libgtk2.0-cil_2.12.10-5.1_amd64.deb CLI binding for the GTK+ toolkit 2.12
libgtk2.0-common_2.24.25-3+deb8u2_all.deb common files for the GTK+ graphical user interface library
libgtk2.0-dev_2.24.25-3+deb8u2_amd64.deb development files for the GTK+ library
libgtk2.0-doc_2.24.25-3+deb8u2_all.deb documentation for the GTK+ graphical user interface library
libgtk3-perl_0.018-1_all.deb Perl bindings for the GTK+ graphical user interface library
libgtk3.0-cil-dev_2.99.3-2_amd64.deb CLI binding for the GTK+ toolkit 3.0
libgtk3.0-cil_2.99.3-2_amd64.deb CLI binding for the GTK+ 3.0 toolkit
libgtkada-bin_2.24.4dfsg-1_amd64.deb Ada binding for the GTK+ GUI (development utilities)
libgtkada-doc_2.24.4dfsg-1_all.deb Ada binding for the GTK+ GUI (documentation)
Advertisement
Advertisement