libgssglue1_0.4-2_amd64.deb


Advertisement

Description

libgssglue1 - mechanism-switch gssapi library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgssglue1
Package version 0.4
Package release 2
Package architecture amd64
Package type deb
Installed size 87 B
Download size 26.01 KB
Official Mirror ftp.br.debian.org
libgssglue provides a gssapi interface, but does not implement any
gssapi mechanisms itself; instead it calls other gssapi functions
(e.g., those provided by MIT Kerberos), depending on the requested
mechanism, to do the work.

Alternatives

Package Version Architecture Repository
libgssglue1_0.4-2_i386.deb 0.4 i386 Debian Main
libgssglue1 - - -

Requires

Name Value
libc6 >= 2.7
multiarch-support -

Conflicts

Name Value
libgssapi2 <= 0.11-1

Replaces

Name Value
libgssapi2 <= 0.11-1

Download

Type URL
Binary Package libgssglue1_0.4-2_amd64.deb
Source Package libgssglue

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgssglue1 deb package:
    # sudo apt-get install libgssglue1

Files

Path
/etc/gssapi_mech.conf
/lib/x86_64-linux-gnu/libgssglue.so.1
/lib/x86_64-linux-gnu/libgssglue.so.1.0.0
/usr/share/doc/libgssglue1/changelog.Debian.gz
/usr/share/doc/libgssglue1/changelog.gz
/usr/share/doc/libgssglue1/copyright

Changelog

2012-06-08 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.4-2) unstable; urgency=low
* Add multiarch support
* Use hardening options
2012-05-10 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.4-1) unstable; urgency=high
* New upstream version 0.4
Changes since libgssglue-0.3:
- Fix for CVE-2011-2709
Patch from Marcus Meissner
Note: Although https://bugzilla.novell.com/show_bug.cgi?id=694598
mentions mount.nfs, libgssglue is not used by mount.nfs.
Closes: #670256
* Fix out-of-date-standards-version
* DH compatibility level is 9
2011-12-05 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.3-4) unstable; urgency=low
* DH compatibility level is 8
* Update debian/copyright
2011-10-07 - Julien Cristau <jcristau@debian.org>
libgssglue (0.3-3.1) unstable; urgency=emergency
* Non-maintainer upload.
* Don't use bzip2 compression for the debs (closes: 643950).
2011-09-02 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.3-3) unstable; urgency=low
* Move libgssglue.so back to /usr 
Patch by Steve Langasek
Closes: 639939
2011-07-20 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.3-2) unstable; urgency=low
* Fix "libgssglue1: boot fails when /usr is an NFS mount" 
Closes: 633021
2011-06-23 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.3-1) unstable; urgency=low
* New upstream
Changes since libgssglue-0.2:
+ Add new typedefs defined in RFC 5587 and used in newer versions
of MIT Kerberos.
+ Fixes a compile error in nfs-utils which uses gssapi.h from this
package and other gss headers from the Kerberos distribution.
* Merged upstream:
debian/patches/07-629553-gssapi.h.in.patch
2011-06-17 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.2-3) unstable; urgency=medium
* Fix incompatibility with krb5 1.9
Add debian/patches/07-629553-gssapi.h.in.patch from upstream
Closes: 629553, 629692
* Fix unneeded-build-dep-on-quilt
* Fix out-of-date-standards-version
* Fix debian-rules-missing-recommended-target
2011-03-30 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.2-2) unstable; urgency=low
[ Steve Langasek ]
* debian/patches/01-370825-gssapi_mech.conf.patch: update for multiarch;
look up our gssapi mechs using the default search path instead of an
absolute path since the absolute path won't be the same on all archs (or
the same before and after multiarch).
Closes: 619559
[ Anibal Monsalve Salazar ]
* Remove debian/patches/debian-changes-0.2-1
Closes: 619052
2011-03-18 - Anibal Monsalve Salazar <anibal@debian.org>
libgssglue (0.2-1) unstable; urgency=low
* New upstream release
* Merged upstream: 04-512730-resource_leak.patch
* Debian source format is 3.0 (quilt)
* Fix debhelper-but-no-misc-depends
* Fix out-of-date-standards-version

See Also

Package Description
libgssrpc4_1.12.1+dfsg-19+deb8u4_amd64.deb MIT Kerberos runtime libraries - GSS enabled ONCRPC
libgst-dev_3.2.4-2.1_amd64.deb GNU Smalltalk virtual machine development files
libgst7_3.2.4-2.1_amd64.deb GNU Smalltalk virtual machine shared library
libgstreamer-interfaces-perl_0.06-2+b2_amd64.deb Perl interface to the GStreamer Interfaces library
libgstreamer-ocaml-dev_0.2.0-2+b1_amd64.deb OCaml interface to the gstreamer library -- development files
libgstreamer-ocaml_0.2.0-2+b1_amd64.deb OCaml interface to the gstreamer library -- runtime files
libgstreamer-perl_0.19-1+b1_amd64.deb Perl interface to the GStreamer media processing framework
libgstreamer-plugins-bad0.10-0_0.10.23-7.4+deb8u2_amd64.deb GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-bad0.10-dev_0.10.23-7.4+deb8u2_amd64.deb GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-bad1.0-0_1.4.4-2.1+deb8u2_amd64.deb GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-bad1.0-dev_1.4.4-2.1+deb8u2_amd64.deb GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb GStreamer libraries from the "base" set
libgstreamer-plugins-base0.10-dev_0.10.36-2_amd64.deb GStreamer development files for libraries from the "base" set
libgstreamer-plugins-base1.0-0_1.4.4-2+deb8u1_amd64.deb GStreamer libraries from the "base" set
libgstreamer-plugins-base1.0-dev_1.4.4-2+deb8u1_amd64.deb GStreamer development files for libraries from the "base" set
Advertisement
Advertisement