libgssapi-perl_0.28-2+b2_amd64.deb


Advertisement

Description

libgssapi-perl - Perl extension providing access to the GSSAPIv2 library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgssapi-perl
Package version 0.28
Package release 2+b2
Package architecture amd64
Package type deb
Installed size 194 B
Download size 50.93 KB
Official Mirror ftp.br.debian.org
This module gives access to the routines of the GSSAPI library,
as described in rfc2743 and rfc2744 and implemented by the
Kerberos-1.2 distribution from MIT.
The API presented by this module is a mildly object oriented
reinterpretation of the C API, where opaque C structures are
Perl objects, but the style of function call has been left
mostly untouched.  As a result, most routines modify one or
more of the parameters passed to them, reflecting the C
call-by-reference (or call-by-value-return) semantics.

Alternatives

Package Version Architecture Repository
libgssapi-perl_0.28-2+b2_i386.deb 0.28 i386 Debian Main
libgssapi-perl - - -

Requires

Name Value
libc6 >= 2.14
libcomerr2 >= 1.01
libgssapi-krb5-2 >= 1.12.1+dfsg-2
libk5crypto3 >= 1.6.dfsg.2
libkrb5-3 >= 1.6.dfsg.2
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libgssapi-perl_0.28-2+b2_amd64.deb
Source Package libgssapi-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgssapi-perl deb package:
    # sudo apt-get install libgssapi-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/GSSAPI.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/GSSAPI/OID.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/GSSAPI/Status.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/GSSAPI/OID/Set.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/GSSAPI/GSSAPI.so
/usr/share/doc/libgssapi-perl/changelog.Debian.amd64.gz
/usr/share/doc/libgssapi-perl/changelog.Debian.gz
/usr/share/doc/libgssapi-perl/changelog.gz
/usr/share/doc/libgssapi-perl/copyright
/usr/share/doc/libgssapi-perl/examples/getcred_hostbased.pl
/usr/share/doc/libgssapi-perl/examples/gss-client.pl.gz
/usr/share/doc/libgssapi-perl/examples/gss-server.pl
/usr/share/man/man3/GSSAPI.3pm.gz
/usr/share/man/man3/GSSAPI::OID.3pm.gz
/usr/share/man/man3/GSSAPI::OID::Set.3pm.gz
/usr/share/man/man3/GSSAPI::Status.3pm.gz

Changelog

2012-03-15 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libgssapi-perl (0.28-2) unstable; urgency=low
[ Ansgar Burchardt ]
* Update my email address.
* Email change: Ansgar Burchardt -> ansgar@debian.org
* debian/control: Convert Vcs-* fields to Git.
[ Fabrizio Regalli ]
* Add myself to Uploaders and Copyright.
* Fixed lintian copyright-refers-to-symlink-license message.
[ Florian Schlichting ]
* Add disable_failing_test.patch, so that the test is skipped as it should
be (Closes: #652216).
* Switch dh compatibility to level 9 to enable passing of CFLAGS.
* Bump Standards-Version to 3.9.3 (use copyright-format 1.0).
* Add myself to uploaders and copyright.
[ gregor herrmann ]
* Simplify debian/rules, override not needed with debhelper 9.
* Build-Depend on 9.20120312 to get all hardening flags.
2010-06-05 - Ansgar Burchardt <ansgar@43-1.org>
libgssapi-perl (0.28-1) unstable; urgency=low
* New upstream release.
* Drop patch spelling.patch: Applied upstream.
2010-04-25 - Ansgar Burchardt <ansgar@43-1.org>
libgssapi-perl (0.27-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* Remove Florian Ragwitz from Uploaders (closes: #523172).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* New upstream release.
* Refresh rules for debhelper 7.
* No longer install README.
* Use source format 3.0 (quilt).
* Convert debian/copyright to proposed machine-readable format.
* debian/copyright: Add information about ppport.h.
* debian/control: Make build-dep on perl unversioned.
* Fix spelling error in the documentation.
+ new patch: spelling.patch
* Bump Standards-Version to 3.8.4.
* Add myself to Uploaders.
[ Franck Joncourt ]
* Set debhelper compatibility from 5 to 7.
* Added back OPTIMIZE and LD_RUN_PATH variables in d.rules through the
override_dh_auto_build target. This also requires a dependency on
debhelper (>= 7.0.50).
* Added /me to Uploaders (refreshed both d.control and d.copyright).
2008-07-05 - gregor herrmann <gregoa@debian.org>
libgssapi-perl (0.26-1) unstable; urgency=low
* Take over for the Debian Perl Group with maintainer's permission
(http://lists.debian.org/debian-perl/2008/06/msg00039.html)
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Changed:
Maintainer set to Debian Perl Group <pkg-perl-
maintainers@lists.alioth.debian.org> (was: Florian Ragwitz
<rafl@debian.org>); Florian Ragwitz <rafl@debian.org> moved to
Uploaders.
* Add debian/watch.
* New upstream release.
* debian/copyright: add upstream source location, update
author/copyright/license information from upstream README.
* Add /me to Uploaders.
* Set Standards-Version to 3.8.0 (no changes).
* Refresh debian/rules, no functional changes.
2008-04-01 - Niko Tyni <ntyni@debian.org>
libgssapi-perl (0.22-1.1) unstable; urgency=low
* Non-maintainer upload for the Perl 5.10 transition.
* Don't try to remove /usr/share/perl5 if it doesn't exist. (Closes: #463540)
2006-06-01 - Florian Ragwitz <rafl@debian.org>
libgssapi-perl (0.22-1) unstable; urgency=low
* New upstream release.
+ Doesn't do DNS lookups during make test anymore (Closes: #367377).
* Bump up Standards-Version to 3.7.2 (no changes).
* Add build-dep to libtest-pod-perl and run the pod tests.
2006-03-26 - Florian Ragwitz <rafl@debian.org>
libgssapi-perl (0.20-1) unstable; urgency=low
* Initial Release.

See Also

Package Description
libgssapi3-heimdal_1.6~rc2+dfsg-9+deb8u1_amd64.deb Heimdal Kerberos - GSSAPI support library
libgssdp-1.0-3_0.14.10-1_amd64.deb GObject-based library for SSDP
libgssdp-1.0-dev_0.14.10-1_amd64.deb GObject-based library for SSDP (development files)
libgssdp-doc_0.14.10-1_all.deb GObject-based library for SSDP (documentation)
libgssglue-dev_0.4-2_amd64.deb header files and docs for libgssglue
libgssglue1_0.4-2_amd64.deb mechanism-switch gssapi library
libgssrpc4_1.12.1+dfsg-19+deb8u4_amd64.deb MIT Kerberos runtime libraries - GSS enabled ONCRPC
libgst-dev_3.2.4-2.1_amd64.deb GNU Smalltalk virtual machine development files
libgst7_3.2.4-2.1_amd64.deb GNU Smalltalk virtual machine shared library
libgstreamer-interfaces-perl_0.06-2+b2_amd64.deb Perl interface to the GStreamer Interfaces library
libgstreamer-ocaml-dev_0.2.0-2+b1_amd64.deb OCaml interface to the gstreamer library -- development files
libgstreamer-ocaml_0.2.0-2+b1_amd64.deb OCaml interface to the gstreamer library -- runtime files
libgstreamer-perl_0.19-1+b1_amd64.deb Perl interface to the GStreamer media processing framework
libgstreamer-plugins-bad0.10-0_0.10.23-7.4+deb8u2_amd64.deb GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-bad0.10-dev_0.10.23-7.4+deb8u2_amd64.deb GStreamer development files for libraries from the "bad" set
Advertisement
Advertisement