libgroupsock1_2014.01.13-1_amd64.deb


Advertisement

Description

libgroupsock1 - multimedia RTSP streaming library (network interfaces and sockets)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgroupsock1
Package version 2014.01.13
Package release 1
Package architecture amd64
Package type deb
Installed size 95 B
Download size 25.70 KB
Official Mirror ftp.br.debian.org
The live555.com streaming media code is a set of C++ libraries for multimedia
streaming, using open standard protocols (RTP/RTCP, RTSP, SIP). These
libraries can be used to build applications to stream, receive and process
MPEG, H.263+ or JPEG video, several audio codecs, and can easily be extended
to support additional codecs. They can also be used to build basic RTSP (Real
Time Streaming Protocol) or SIP (Session Initiation Protocol) clients and
servers.
This package contains the groupsock library. The classes in this library
encapsulate network interfaces and sockets. In particular, the "Groupsock"
class encapsulates a socket for sending (and/or receiving) multicast datagrams.

Alternatives

Package Version Architecture Repository
libgroupsock1_2014.01.13-1_i386.deb 2014.01.13 i386 Debian Main
libgroupsock1 - - -

Requires

Name Value
libc6 >= 2.15
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.1.1
multiarch-support -

Download

Type URL
Binary Package libgroupsock1_2014.01.13-1_amd64.deb
Source Package liblivemedia

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgroupsock1 deb package:
    # sudo apt-get install libgroupsock1

Files

Path
/usr/lib/x86_64-linux-gnu/libgroupsock.so.1
/usr/lib/x86_64-linux-gnu/libgroupsock.so.1.0.4
/usr/share/doc/libgroupsock1/NEWS.Debian.gz
/usr/share/doc/libgroupsock1/changelog.Debian.gz
/usr/share/doc/libgroupsock1/changelog.gz
/usr/share/doc/libgroupsock1/copyright

Changelog

2014-01-13 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2014.01.13-1) unstable; urgency=medium
* Team upload.
* New upstream release.
- Rewrote our MD5 implementation to fix license issue (Closes: #728419)
* Update debian/copyright.
* Bump Standards-Version to 3.9.5.
* Update liblivemedia15 to liblivemedia23.
* Remove outdated (and probably non-free) openRTSP.html.
2013-10-30 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2013.10.25-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Link shared libraries with g++ instead of gcc to fix build failure.
* Refresh patches.
* Update shared library versions.
2013-05-05 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2013.04.30-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Upload to unstable after the Debian 7.0 release.
2013-01-16 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2013.01.15-1) experimental; urgency=low
* Team upload.
* New upstream release.
* Drop linker-flags.patch (accepted upstream).
2013-01-16 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2013.01.05-3) experimental; urgency=low
* Team upload.
* Add a pkg-config file for the shared libraries.
2013-01-14 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2013.01.05-2) experimental; urgency=low
* Team upload.
* Move example code into liblivemedia-dev package (where it belongs).
* Add -fPIC -DPIC to CXXFLAGS in addition to CFLAGS to really build a
static PIC version.
2013-01-05 - Benjamin Drung <bdrung@debian.org>
liblivemedia (2013.01.05-1) experimental; urgency=low
* Team upload.
* New upstream release (supporting shared libraries).
* Switch to short format debhelper 9.
* Drop 010_propagate_cflags.diff and 301_hardening.patch (improved version
accepted by upstream).
* Remove the not DFSG-free upstream changelog and replace it with a URL.
* Drop 022_synchronous_rtspclient.patch.
* Add shared libraries. (Closes: #662774)
2012-12-07 - Alessio Treglia <alessio@debian.org>
liblivemedia (2012.11.30-1) experimental; urgency=low
* Team upload.
* New upstream release:
- Fixed another bug in the "ProxyServerMediaSession" destructor.
- Fixed a bug in "ProxyServerMediaSession" that would be triggered if an
"RTSPServer" that uses such an object were deleted. (This also fixes a
memory leak that would occur if a proxy's back-end server failed, but
then restarted.)
- Fixed a bug in "ProxyRTSPClient" that was causing some background tasks
to not be halted when a "ProxyServerMediaSession" deleted.
* Refresh debian/patches/301_hardening.patch, partially adopted upstream.
* Update upstream changelog.
2012-11-22 - Alessio Treglia <alessio@debian.org>
liblivemedia (2012.11.16-1) experimental; urgency=low
* Team upload.
* Imported Upstream version 2012.11.16
* Refresh patches.
* Update upstream changelog.
* Enable hardening flags.
* debian/patches/301_hardening.patch:
- Prevent build failure when compiled with -Wformat
-Werror=format-security.
- Pass LDFLAGS to the linker.
* Bump Standards.
2012-11-04 - Alessio Treglia <alessio@debian.org>
liblivemedia (2012.10.24-1) experimental; urgency=low
* Team upload.
* New upstream release.
* Update upstream changelog.

See Also

Package Description
libgrss-1.0-0_0.5.0-3_amd64.deb Glib-based library to manage RSS and Atom feeds
libgrss-dev_0.5.0-3_amd64.deb Glib-based library to manage RSS and Atom feeds - development files
libgs-dev_9.06~dfsg-2+deb8u7_amd64.deb interpreter for the PostScript language and for PDF - Development Files
libgs9-common_9.06~dfsg-2+deb8u7_all.deb interpreter for the PostScript language and for PDF - common files
libgs9_9.06~dfsg-2+deb8u7_amd64.deb interpreter for the PostScript language and for PDF - Library
libgsasl7-dev_1.8.0-6_amd64.deb Development files for the GNU SASL library
libgsasl7_1.8.0-6_amd64.deb GNU SASL library
libgsecuredelete-dev_0.2.1-2_amd64.deb wrapper library for the secure-delete tools - development files
libgsecuredelete0_0.2.1-2_amd64.deb wrapper library for the secure-delete tools
libgsf-1-114_1.14.30-2_amd64.deb Structured File Library - runtime version
libgsf-1-common_1.14.30-2_all.deb Structured File Library - common files
libgsf-1-dev_1.14.30-2_amd64.deb Structured File Library - development files
libgsf-bin_1.14.30-2_amd64.deb Structured File Library - programs
libgsl0-dev_1.16+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- development package
libgsl0ldbl_1.16+dfsg-2_amd64.deb GNU Scientific Library (GSL) -- library package
Advertisement
Advertisement