libgpg-error-dev_1.17-3_amd64.deb


Advertisement

Description

libgpg-error-dev - library for common error values and messages in GnuPG components (development)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgpg-error-dev
Package version 1.17
Package release 3
Package architecture amd64
Package type deb
Installed size 220 B
Download size 73.34 KB
Official Mirror ftp.br.debian.org
Library that defines common error values for all GnuPG
components.  Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
pinentry, SmartCard Daemon and possibly more in the future.
This package contains the headers and other files needed to compile
against this library.

Alternatives

Package Version Architecture Repository
libgpg-error-dev_1.17-3_i386.deb 1.17 i386 Debian Main
libgpg-error-dev - - -

Requires

Name Value
libc6 >= 2.3.4
libgpg-error0 = 1.17-3

Download

Type URL
Binary Package libgpg-error-dev_1.17-3_amd64.deb
Source Package libgpg-error

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgpg-error-dev deb package:
    # sudo apt-get install libgpg-error-dev

Files

Path
/usr/bin/gpg-error
/usr/bin/gpg-error-config
/usr/include/x86_64-linux-gnu/gpg-error.h
/usr/lib/x86_64-linux-gnu/libgpg-error.a
/usr/lib/x86_64-linux-gnu/libgpg-error.la
/usr/lib/x86_64-linux-gnu/libgpg-error.so
/usr/share/aclocal/gpg-error.m4
/usr/share/doc/libgpg-error-dev/README.gz
/usr/share/doc/libgpg-error-dev/TODO.Debian
/usr/share/doc/libgpg-error-dev/changelog.Debian.gz
/usr/share/doc/libgpg-error-dev/changelog.gz
/usr/share/doc/libgpg-error-dev/copyright
/usr/share/info/gpgrt.info.gz
/usr/share/man/man1/gpg-error-config.1.gz
/usr/share/man/man1/gpg-error.1.gz

Changelog

2014-12-12 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.17-3) unstable; urgency=medium
[ David Prévot ]
* Force rebuild of gmo files
* Update Polish translation, thanks to Jakub Bogusz
* Update French translation
* Update Ukrainian translation, thanks to Yuri Chornoivan
* Update Danish translation, thanks to Joe Hansen
* Update Dutch translation, thanks to Freek de Kruijf
* Update Japanese translation, thanks to NIIBE Yutaka
* Add Russian translation, thanks to Ineiev
* Update Italian translation, thanks to Milo Casagrande
* Add Chinese (traditional) translation, thanks to Jedi Lin
* Add Portuguese translation, thanks to Paulo Tomé (Closes: #770893)
* Add Serbian translation, thanks to Мирослав Николић
* Update Czech translation, thanks to Petr Pisar
2014-10-24 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.17-2) unstable; urgency=medium
* added arch-specific lock-obj header for added
mips64el-unknown-linux-gnuabi64 (Closes: #766135)
2014-09-29 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.17-1) unstable; urgency=medium
* New upstream release (Closes: #762322)
- debian/patches: all merged upstream
* added arch-specific lock-obj header for i586-pc-linux-gnu
(Closes: #764881)
* bumped all symbols to 1.14 since version node GPG_ERROR_1.0 was
introduced there. (Closes: #765430)
* use upstream's manpage for gpg-error-config
* bump Standards-Version to 3.9.6 (no changes needed)
2014-09-22 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.16-2) unstable; urgency=medium
* added headers for powerpc64el and sparc64 (Closes: #762322)
* fix build timestamp for reproducibility (Closes: #762397)
2014-09-18 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.16-1) unstable; urgency=medium
* New upstream release
- drop patches, applied upstream
* move /usr/include/gpg-error.h to /usr/include/$ARCH/gpg-error.h
(addresses part of #643341)
2014-09-09 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.15-1) unstable; urgency=medium
* New upstream release (skipping 1.14)
* move to debhelper 9
* complete move from dh_autotools-dev to dh_autoreconf
* drop all debian/patches -- applied upstream
* update the text of gpg-error-config.1, since it has not been called
libgpg-error-config for years
* update gpg-error-config to mention --mt
* debian/copyright: use DEP5 
* adopt new symbol visibility (GPG_ERROR_1.0) from upstream
* fix locking problem at close with patch from upstream
2014-08-28 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.13-4) unstable; urgency=medium
* moving to git
* using pristine-tar
* wrap-and-sort to clean up debian/*
2014-08-07 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.13-3) unstable; urgency=medium
* Avoid dumping the native lock-obj header when cross-building, since it
will not exist.  I think this resolves the FTCBFS issue.  Thanks to
Helmut Grohne for all the useful guidance! (Closes: #753047)
* update da.po. Thanks, Joe Hansen! (Closes: #754128)
2014-08-06 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.13-2) unstable; urgency=medium
* adopt upstream's variant of the hppa tuning.
2014-08-05 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.13-1) unstable; urgency=medium
* Adopt by pkg-gnupg team, after conferring with previous maintainer.  Thanks,
Jose Carlos Garcia Sogo!
* tweak hppa lock-obj struct. (Closes: #757060) Thanks, John David Anglin!
* bump standards-version to 3.9.5 (no changes needed)

See Also

Package Description
libgpg-error0_1.17-3_amd64.deb library for common error values and messages in GnuPG components
libgpgme++2_4.14.2-2+deb8u2_amd64.deb c++ wrapper library for gpgme
libgpgme11-dev_1.5.1-6_amd64.deb GPGME - GnuPG Made Easy (development files)
libgpgme11_1.5.1-6_amd64.deb GPGME - GnuPG Made Easy (library)
libgphoto2-2-dev_2.5.4-1.1+b2_amd64.deb gphoto2 digital camera library (transitional package)
libgphoto2-6_2.5.4-1.1+b2_amd64.deb gphoto2 digital camera library
libgphoto2-dev-doc_2.5.4-1.1_all.deb gphoto2 digital camera library (development documentation)
libgphoto2-dev_2.5.4-1.1+b2_amd64.deb gphoto2 digital camera library (development files)
libgphoto2-l10n_2.5.4-1.1_all.deb gphoto2 digital camera library - localized messages
libgphoto2-port10_2.5.4-1.1+b2_amd64.deb gphoto2 digital camera port library
libgpiv-mpi3_0.6.1-4.1+b1_amd64.deb library for Particle Image Velocimetry (PIV) - MPI version
libgpiv3-common_0.6.1-4.1+b1_amd64.deb library for Particle Image Velocimetry (PIV) - common files
libgpiv3-dev_0.6.1-4.1+b1_amd64.deb library for Particle Image Velocimetry (PIV) - development files
libgpiv3-doc_0.6.1-4.1_all.deb library for Particle Image Velocimetry (PIV) - documentation
libgpiv3_0.6.1-4.1+b1_amd64.deb library for Particle Image Velocimetry (PIV)
Advertisement
Advertisement