libgnomevfs2-0_2.24.4-6+b1_amd64.deb


Advertisement

Description

libgnomevfs2-0 - GNOME Virtual File System (runtime libraries)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgnomevfs2-0
Package version 2.24.4
Package release 6+b1
Package architecture amd64
Package type deb
Installed size 905 B
Download size 481.03 KB
Official Mirror ftp.br.debian.org
GNOME VFS is the GNOME virtual file system.  It is the foundation of the
Nautilus file manager.  It provides a modular architecture and ships with
several modules that implement support for local files, http, ftp and others.
It provides an URI-based API, a backend supporting asynchronous file
operations, a MIME type manipulation library and other features.
This package contains the runtime libraries and the default modules.

Alternatives

Package Version Architecture Repository
libgnomevfs2-0_2.24.4-6+b1_i386.deb 2.24.4 i386 Debian Main
libgnomevfs2-0 - - -

Requires

Name Value
gconf-service -
libacl1 >= 2.2.51-8
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libavahi-glib1 >= 0.6.16
libc6 >= 2.15
libdbus-1-3 >= 1.0.2
libdbus-glib-1-2 >= 0.78
libgconf-2-4 >= 3.2.5
libglib2.0-0 >= 2.37.3
libgnomevfs2-common = 1:2.24.4-6
libgnutls-deb0-28 >= 3.3.0
libselinux1 >= 1.32
libxml2 >= 2.7.4
multiarch-support -
zlib1g >= 1:1.1.4

Conflicts

Name Value
libbonobo2-0 << 2.15.0

Replaces

Name Value
libgnomevfs2-common << 2.12.2-4

Download

Type URL
Binary Package libgnomevfs2-0_2.24.4-6+b1_amd64.deb
Source Package gnome-vfs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnomevfs2-0 deb package:
    # sudo apt-get install libgnomevfs2-0

Files

Path
/usr/lib/x86_64-linux-gnu/libgnomevfs-2.so.0
/usr/lib/x86_64-linux-gnu/libgnomevfs-2.so.0.2400.4
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libcomputer.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libdns-sd.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libfile.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libgzip.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libnetwork.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libsftp.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libtar.so
/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/modules/libvfs-test.so
/usr/share/doc/libgnomevfs2-0/AUTHORS
/usr/share/doc/libgnomevfs2-0/NEWS.gz
/usr/share/doc/libgnomevfs2-0/README
/usr/share/doc/libgnomevfs2-0/TODO
/usr/share/doc/libgnomevfs2-0/changelog.Debian.amd64.gz
/usr/share/doc/libgnomevfs2-0/changelog.Debian.gz
/usr/share/doc/libgnomevfs2-0/changelog.gz
/usr/share/doc/libgnomevfs2-0/copyright

Changelog

2014-07-05 - Andreas Henriksson <andreas@fatal.se>
gnome-vfs (1:2.24.4-6) unstable; urgency=medium
* Team upload
- brown paper bag release.
* Also make libgnomevfs2-dev depend on libgnutls28-dev
- like the build-dependency, this drops libgnutls-dev (gnutls26)
2014-07-05 - Andreas Henriksson <andreas@fatal.se>
gnome-vfs (1:2.24.4-5) unstable; urgency=medium
* Team upload.
[ Dimitri John Ledkov ]
* Switch to gnutls28 (Closes: #747455).
* Drop gcrypt library dependency, gnutls can do thread locking.
2013-11-06 - Josselin Mouette <joss@debian.org>
gnome-vfs (1:2.24.4-4) unstable; urgency=low
* Switch to multiarch.
+ Update installation paths.
+ Remove the daemon and the smb backend, it doesn’t build anymore 
and nobody uses it anyway. It avoids adding a new package just for 
the daemon. 
+ Set Multi-Arch fields: lib and dev are MA: same, -common and -bin 
are MA: foreign.
+ Remove gnome:Version stuff.
* Remove FAM support. The library is not ported to MA, and anyway 
gnome-vfs is not used by nautilus anymore, which was the application 
with a use for that feature.
* 41_test_srcdir.patch: new patch. Get autoreconf to work with a more 
recent automake.
2013-05-11 - Emilio Pozuelo Monfort <pochu@debian.org>
gnome-vfs (1:2.24.4-3) unstable; urgency=low
* debian/patches/40_disable_deprecated.patch:
+ New patch, don't define G_DISABLE_DEPRECATED. Fixes FTBFS.
Closes: #707381.
* debian/control.in,
debian/rules:
+ Run dh_autoreconf.
* debian/patches/90_relibtoolize.patch
debian/patches/99_ltmain_as-needed.patch:
+ Removed, no longer needed.
2013-04-28 - Michael Biebl <biebl@debian.org>
gnome-vfs (1:2.24.4-2) unstable; urgency=low
[ Josselin Mouette ]
* Update repository URL.
[ Andreas Beckmann ]
* libgnomevfs2-common: Add dummy prerm/postrm as a workaround for gconf2
related upgrade failures caused by a dangling /usr/bin/python symlink.
Closes: #706110
2011-03-16 - Michael Biebl <biebl@debian.org>
gnome-vfs (1:2.24.4-1) unstable; urgency=low
* New upstream release.
* Switch to source format 3.0 (quilt)
- Drop Build-Depends on quilt.
- Add debian/source/format.
- Remove /usr/share/cdbs/1/rules/patchsys-quilt.mk from debian/rules.
* Fix debian/watch.
* Bump Standards-Version to 3.9.1. No further changes.
* Refresh debian/patches/24_home_dir_fakeroot.patch.
* Link libgnomevfs against libgcrypt. Closes: #554667
- Update GnuTLS configure check to also check for libgcrypt using
AM_PATH_LIBGCRYPT.
- Add Build-Depends on libgcrypt11-dev.
* debian/patches/31_link_tests_and_programs_against_required_libs.patch
- Link binaries in test/ and programs/ against all required libs to not
fail with binutils-gold and GCC 4.5.
* Refresh debian/patches/90_relibtoolize.patch.
* Bump debhelper compatibility level to 8.
2011-02-07 - Michael Biebl <biebl@debian.org>
gnome-vfs (1:2.24.3-2) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/control: Move the library to section oldlibs.
[ Josselin Mouette ]
* Smbclient, HAL and Avahi are available on all architectures, require 
them unconditionally.
* Drop type-handling usage. Closes: #587877.
* Bump standards version accordingly.
[ Michael Biebl ]
* Disable HAL support. Closes: #599020
This will make gnome-vfs fall back to good old /etc/mtab, which is good
enough for legacy applications which still actually use the deprecated
gnome-vfs.
* Make samba and avahi configure flags not arch specific.
2010-04-05 - Josselin Mouette <joss@debian.org>
gnome-vfs (1:2.24.3-1) unstable; urgency=low
* New upstream release.
* 90_relibtoolize.patch: updated for the new version.

See Also

Package Description
libgnomevfs2-bin_2.24.4-6+b1_amd64.deb GNOME Virtual File System (support binaries)
libgnomevfs2-common_2.24.4-6_all.deb GNOME Virtual File System (common files)
libgnomevfs2-dev_2.24.4-6+b1_amd64.deb GNOME Virtual File System library (development files)
libgnomevfs2-extra_2.24.4-6+b1_amd64.deb GNOME Virtual File System (extra modules)
libgnu-regexp-java_1.1.4-4_all.deb Regular Expressions for Java
libgnuift0-dev_0.1.14-12.1_amd64.deb libgnuift development files
libgnuift0c2a_0.1.14-12.1_amd64.deb GNU Image Finding Tool - libraries
libgnuinet-java_1.1.2-2_all.deb extension library to provide extra network protocol support
libgnujaf-java-doc_1.1.1-8_all.deb free implementation of the javabeans activation framework (docs)
libgnujaf-java_1.1.1-8_all.deb free implementation of the javabeans activation framework
libgnumail-java-doc_1.1.2-9_all.deb free implementation of the javamail API (Javadocs)
libgnumail-java_1.1.2-9_all.deb free implementation of the javamail API
libgnupg-interface-perl_0.50-3_all.deb Perl interface to GnuPG
libgnupg-perl_0.19-1_all.deb interface to GnuPG using its coprocess interface
libgnuplot-iostream-dev_0~20140302.gitc8919a0+dfsg-2_all.deb C++ programming interface for gnuplot. Headers
Advertisement
Advertisement