libgnomeui-0_2.24.5-3_amd64.deb


Advertisement

Description

libgnomeui-0 - GNOME user interface library - runtime files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgnomeui-0
Package version 2.24.5
Package release 3
Package architecture amd64
Package type deb
Installed size 831 B
Download size 313.80 KB
Official Mirror ftp.br.debian.org
This package contains the shared library for the base GNOME library
functions (User Interface functions).

Alternatives

Package Version Architecture Repository
libgnomeui-0_2.24.5-3_i386.deb 2.24.5 i386 Debian Main
libgnomeui-0 - - -

Requires

Name Value
gconf-service -
libart-2.0-2 >= 2.3.17
libatk1.0-0 >= 1.12.4
libbonobo2-0 >= 2.32.1-3~
libbonoboui2-0 >= 2.15.1
libc6 >= 2.14
libcairo2 >= 1.2.4
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgconf-2-4 >= 3.2.5
libgdk-pixbuf2.0-0 >= 2.22.0
libglade2-0 >= 1:2.6.4-2~
libglib2.0-0 >= 2.35.9
libgnome-2-0 -
libgnome-keyring0 >= 2.20.3
libgnomecanvas2-0 >= 2.11.1
libgnomeui-common = 2.24.5-3
libgnomevfs2-0 >= 1:2.17.90
libgtk2.0-0 >= 2.14
libice6 >= 1:1.0.0
liborbit-2-0 >= 1:2.14.10
libpango-1.0-0 >= 1.17.5
libpangocairo-1.0-0 >= 1.17.5
libpangoft2-1.0-0 >= 1.17.5
libpopt0 >= 1.14
libsm6 -
libx11-6 -
libxml2 >= 2.6.27
multiarch-support -

Download

Type URL
Binary Package libgnomeui-0_2.24.5-3_amd64.deb
Source Package libgnomeui

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnomeui-0 deb package:
    # sudo apt-get install libgnomeui-0

Files

Path
/usr/lib/x86_64-linux-gnu/libgnomeui-2.so.0
/usr/lib/x86_64-linux-gnu/libgnomeui-2.so.0.2400.5
/usr/lib/x86_64-linux-gnu/libglade/2.0/libgnome.so
/usr/share/doc/libgnomeui-0/AUTHORS
/usr/share/doc/libgnomeui-0/NEWS.gz
/usr/share/doc/libgnomeui-0/README
/usr/share/doc/libgnomeui-0/changelog.Debian.gz
/usr/share/doc/libgnomeui-0/changelog.gz
/usr/share/doc/libgnomeui-0/copyright

Changelog

2013-12-27 - Josselin Mouette <joss@debian.org>
libgnomeui (2.24.5-3) unstable; urgency=low
* Switch to multiarch. Closes: #642417.
+ Update build-dependencies.
+ Require a MA-enabled libglade for the modules path.
+ Make libgnomeui-0 and -dev MA: same, make -common MA: foreign.
+ Update installation paths.
* Drop gnome:Version.
* Move to section oldlibs.
* 99_ltmain_as-needed.patch: dropped, obsolete.
2011-09-05 - Michael Biebl <biebl@debian.org>
libgnomeui (2.24.5-2) unstable; urgency=low
* debian/patches/01_link_libm.patch: Explicitly link against -lm.
Closes: #640455
* Use dh-autoreconf to update the build system.
2011-07-30 - Michael Biebl <biebl@debian.org>
libgnomeui (2.24.5-1) unstable; urgency=low
* New upstream release.
* debian/watch:
- Switch .bz2 tarballs.
- Don't run uupdate.
* Switch to dpkg source format 3.0 (quilt).
* Bump Standards-Version to 3.9.2. No further changes.
* Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* Remove old Conflicts/Replaces which are no longer necessary.
* Remove Build-Depends on dpkg-dev (>= 1.13.19) as even lenny has a more
recent version.
* Switch to debhelper compatibility level 8.
- Update Build-Depends on debhelper.
- Strip debian/tmp/ from .install files.
* Stop installing libtool .la files.
* Small tweaks to the description synopsis.
2010-04-05 - Josselin Mouette <joss@debian.org>
libgnomeui (2.24.3-1) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* libgnomeui-0-dbg is section debug and not libdevel.
[ Josselin Mouette ]
* New upstream release.
2009-09-26 - Josselin Mouette <joss@debian.org>
libgnomeui (2.24.2-1) unstable; urgency=low
* Add libglib2.0-doc and libgtk2.0-doc to b-d-i to ensure proper
xrefs.
* Stop mentioning GNOME 2.
* New upstream translation release.
2009-03-06 - Sebastian Dröge <slomo@debian.org>
libgnomeui (2.24.1-1) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* Add ${misc:Depends} dependencies to all packages that don't have it.
[ Sebastian Dröge ]
* New upstream bugfix release.
2009-03-02 - Josselin Mouette <joss@debian.org>
libgnomeui (2.24.0-2) unstable; urgency=low
* Upload to unstable.
2008-11-11 - Josselin Mouette <joss@debian.org>
libgnomeui (2.24.0-1) experimental; urgency=low
[ Loic Minier ]
* Properly anchor package name regexp.
[ Emilio Pozuelo Monfort ]
* debian/libgnomeui-doc.doc-base: fix section.
[ Josselin Mouette ]
* 08_is_desktop_crash.patch: new patch. Work around 
gnome_vfs_file_info_get_mime_type unexpectdly returning NULL.
Closes: #498212.
* Remove -1 in build-dependencies.
* Fix spelling of GNOME in the doc-base summary.
* Standards version is 3.8.0.
[ Deng Xiyue ]
* Use POSIX standard regex classes in sed trick in debian/rules.
[ Josselin Mouette ]
* New upstream release.
+ 07_fix_desktop_dir.patch, 08_is_desktop_crash.patch: dropped, 
obsolete.
* Update build-depends and depends accordingly.
* Build-depend on gtk+ 2.14 so that we always end up with a version 
that doesn’t need the filechooser backend.
* Remove dh_gtkmodules call.
* Stop installing the filechooser backends.
2008-04-10 - Sebastian Dröge <slomo@debian.org>
libgnomeui (2.22.1-1) experimental; urgency=low
* New upstream bugfix release.
2008-03-14 - Sebastian Dröge <slomo@debian.org>
libgnomeui (2.22.0.1-1) experimental; urgency=low
[ Loic Minier ]
* Tighten libgnomeui package name extraction.
[ Sebastian Dröge ]
* New upstream stable release:
+ Upload to experimental first because of intrusive changes.
+ debian/control.in:
- Update build dependencies.
+ debian/libgnomeui-0.shlibs:
- Update shlibs >= 2.22.0 because of new API.
+ debian/libgnomeui-0.install:
- Ship all file chooser backends, including the GIO one.
+ debian/patches/99_ltmain_as-needed.patch:
- Updated to apply cleanly again.
* debian/control.in:
+ Update Standards-Version to 3.7.3, no additional changes needed.

See Also

Package Description
libgnomeui-common_2.24.5-3_all.deb GNOME user interface library - common files
libgnomeui-dev_2.24.5-3_amd64.deb GNOME user interface library - development files
libgnomeui-doc_2.24.5-3_all.deb GNOME user interface library - documentation files
libgnomevfs2-0_2.24.4-6+b1_amd64.deb GNOME Virtual File System (runtime libraries)
libgnomevfs2-bin_2.24.4-6+b1_amd64.deb GNOME Virtual File System (support binaries)
libgnomevfs2-common_2.24.4-6_all.deb GNOME Virtual File System (common files)
libgnomevfs2-dev_2.24.4-6+b1_amd64.deb GNOME Virtual File System library (development files)
libgnomevfs2-extra_2.24.4-6+b1_amd64.deb GNOME Virtual File System (extra modules)
libgnu-regexp-java_1.1.4-4_all.deb Regular Expressions for Java
libgnuift0-dev_0.1.14-12.1_amd64.deb libgnuift development files
libgnuift0c2a_0.1.14-12.1_amd64.deb GNU Image Finding Tool - libraries
libgnuinet-java_1.1.2-2_all.deb extension library to provide extra network protocol support
libgnujaf-java-doc_1.1.1-8_all.deb free implementation of the javabeans activation framework (docs)
libgnujaf-java_1.1.1-8_all.deb free implementation of the javabeans activation framework
libgnumail-java-doc_1.1.2-9_all.deb free implementation of the javamail API (Javadocs)
Advertisement
Advertisement