libgnomeada2.24.4_2.24.4dfsg-1_amd64.deb


Advertisement

Description

libgnomeada2.24.4 - Ada binding for the GNOME GUI (dynamic library)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgnomeada2.24.4
Package version 2.24.4dfsg
Package release 1
Package architecture amd64
Package type deb
Installed size 494 B
Download size 81.74 KB
Official Mirror ftp.br.debian.org
GtkAda is a library that allows programmers to write GTK+ applications in the
Ada programming language.
This library will let you run Ada applications compiled with GNOME.

Alternatives

Package Version Architecture Repository
libgnomeada2.24.4_2.24.4dfsg-1_i386.deb 2.24.4dfsg i386 Debian Main
libgnomeada2.24.4 - - -

Requires

Name Value
libbonoboui2-0 >= 2.15.1
libc6 >= 2.14
libgcc1 >= 1:4.1.1
libglib2.0-0 >= 2.12.0
libgnat-4.9 >= 4.9.1-4
libgnomeui-0 >= 2.22.0
libgtkada2.24.4 -
multiarch-support -

Download

Type URL
Binary Package libgnomeada2.24.4_2.24.4dfsg-1_amd64.deb
Source Package libgtkada

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnomeada2.24.4 deb package:
    # sudo apt-get install libgnomeada2.24.4

Files

Path
/usr/lib/x86_64-linux-gnu/libgnomeada.so.2.24.4
/usr/share/doc/libgnomeada2.24.4/changelog.Debian.gz
/usr/share/doc/libgnomeada2.24.4/copyright
/usr/share/lintian/overrides/libgnomeada2.24.4

Changelog

2014-11-09 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.4dfsg-1) unstable; urgency=medium
* Repackage without GFDL documentation. Closes: #768539.
- control: drop sphinx build-deps and javascript binary-deps.
- patches/*, rules, libgtkada-doc.*: do not patch/build/install docs.
- control: update description of -doc package.
- copyright, README.source: adjust comments about stripped parts.
- TODO: no hope to generate the reference manual anymore.
2014-10-06 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.4-2) unstable; urgency=medium
* Avoid Suggesting: -doc (=binary:Version). During binNMUs, -doc is not
rebuilt, so =binary:Version cannot be satisfied anymore.
* Standards-Version: 3.9.6 (no changes).
2014-05-11 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.4-1) unstable; urgency=medium
* New upstream release. Updated repackaging (xz), patches, README.source.
* Package renamings per Ada policy. Versioned preinst not needed anymore.
* links: instead of embedding javascript in generated html.
* lintian-overrides: license not repeated despite file names.
* rules: run-tests target obsoleted by sadt from devscripts.
* tests: xvfb-run depends on xauth for Debian tests. Closes: #740742.
* (Build-)Depends: concrete cairo2-dev before virtual cairo-dev.
2013-11-07 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.1-14) unstable; urgency=low
[ Jean-Baptiste Lallement ]
*  Add missing dependency 'libglu1-mesa-dev | libglu-dev' to
libgtkglada2.24.1-dev. (LP: #1244896) (Closes: #727753)
This completes the work-around for  #720991 explained in debian/rules.
[ Nicolas Boulenguez ]
* Standards-Version: 3.9.5 without changes.
* source/options: use default compressor for Debian diff.
2013-08-28 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.1-13) unstable; urgency=low
* Revert "share library_dir" changes, which sometimes FTBFS: dynamic/static
variants of same ALI may conflict depending on compilation order.
* control (Build-Depends): provide concrete mesa-dev before virtual gl-dev.
* rules: let info page search images in /usr/share/doc/.
Only duplicate versioned project for -arch and after the first one exists.
* source.lintian-overrides: correct syntax.
2013-08-26 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.1-12) unstable; urgency=low
[Martin Pitt <martin.pitt@ubuntu.com]
* Add missing libgtkgl2.0-dev dependency to libgtkglada2.24.1-dev (spotted
by autopkgtest). Closes: #718259.
* debian/tests/control: Add xvfb test dependency.
* debian/tests/link-with-shared: Run test program through xvfb as it needs a
$DISPLAY.
[Nicolas Boulenguez]
* Remove any symlink in documentation directories.
* Build-Depends: unversioned cairo-dev and gl-dev.
* gtkada-config: more efficient generation. Split arch/indep install
overrides so that sed is only called for existing package.
* Share library_dir. Use src/tools/obj/, no reason to create ours.
* Use pkg-config for LDLIBS. I removed it because it created unneeded
dependencies, but --as-needed drops them automatically now.
2013-07-22 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.1-11) unstable; urgency=low
* copyright: now machine-readable.
* lintian-overrides: a patch removing a non DFSG license must contain it
* rules, patches/01-doc.diff: typo in manpage, COPYING as license.
2013-07-15 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (2.24.1-10) unstable; urgency=low
* Add -lm to the gtkada.gpr link list (Closes: #695055).
Patch from Thorsten Glaser.

See Also

Package Description
libgnomecanvas2-0_2.30.3-2_amd64.deb powerful object-oriented display engine - runtime files
libgnomecanvas2-common_2.30.3-2_all.deb powerful object-oriented display engine - common files
libgnomecanvas2-dev_2.30.3-2_amd64.deb powerful object-oriented display engine - development files
libgnomecanvas2-doc_2.30.3-2_all.deb powerful object-oriented display engine - documentation files
libgnomecanvasmm-2.6-1c2a_2.26.0-1.1_amd64.deb C++ wrappers for libgnomecanvas2 (shared library)
libgnomecanvasmm-2.6-dev_2.26.0-1.1_amd64.deb C++ wrappers for libgnomecanvas2 (development files)
libgnomecanvasmm-2.6-doc_2.26.0-1.1_all.deb C++ wrappers for libgnomecanvas2 (documentation)
libgnomedesktop2.0-cil-dev_2.26.0-8_all.deb CLI binding for GNOME Desktop 2.24
libgnomedesktop2.20-cil_2.26.0-8_all.deb CLI binding for GNOME Desktop 2.24
libgnomekbd-common_3.6.0-1_all.deb GNOME library to manage keyboard configuration - common files
libgnomekbd-dev_3.6.0-1_amd64.deb GNOME library to manage keyboard configuration - development files
libgnomekbd8_3.6.0-1_amd64.deb GNOME library to manage keyboard configuration - shared library
libgnomeui-0_2.24.5-3_amd64.deb GNOME user interface library - runtime files
libgnomeui-common_2.24.5-3_all.deb GNOME user interface library - common files
libgnomeui-dev_2.24.5-3_amd64.deb GNOME user interface library - development files
Advertisement
Advertisement