libgnome2-perl_1.045-1+b1_amd64.deb


Advertisement

Description

libgnome2-perl - Perl interface to the GNOME libraries

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgnome2-perl
Package version 1.045
Package release 1+b1
Package architecture amd64
Package type deb
Installed size 709 B
Download size 243.81 KB
Official Mirror ftp.br.debian.org
libgnome2-perl allows one to write programs with a GNOME user
interface in Perl.
GNOME is a project to build a complete, user-friendly desktop based
entirely on free software.
Find out more about GNOME at http://www.gnome.org.
The perl bindings follow the C API very closely, and the C reference
documentation should be considered the canonical source:
http://developer.gnome.org/doc/API/2.0/libgnome/index.html
This module is part of gtk2-perl.
To discuss gtk2-perl, ask questions and flame/praise the authors,
join gtk-perl-list@gnome.org at lists.gnome.org.
Also have a look at the gtk2-perl website and sourceforge project page,
http://gtk2-perl.sourceforge.net

Alternatives

Package Version Architecture Repository
libgnome2-perl_1.045-1+b1_i386.deb 1.045 i386 Debian Main
libgnome2-perl - - -

Requires

Name Value
gconf-service -
libart-2.0-2 >= 2.3.17
libatk1.0-0 >= 1.12.4
libbonobo2-0 >= 2.32.1-3~
libbonoboui2-0 >= 2.15.1
libc6 >= 2.4
libcairo2 >= 1.2.4
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgconf-2-4 >= 3.2.5
libgdk-pixbuf2.0-0 >= 2.22.0
libglib-perl -
libglib2.0-0 >= 2.35.9
libgnome-2-0 -
libgnome2-canvas-perl -
libgnome2-vfs-perl -
libgnomecanvas2-0 >= 2.11.1
libgnomeui-0 >= 2.22.0
libgnomevfs2-0 >= 1:2.17.90
libgtk2-perl -
libgtk2.0-0 >= 2.8.0
libice6 >= 1:1.0.0
liborbit-2-0 >= 1:2.14.10
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libpopt0 >= 1.14
libsm6 -
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libgnome2-perl_1.045-1+b1_amd64.deb
Source Package libgnome2-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnome2-perl deb package:
    # sudo apt-get install libgnome2-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/About.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/App.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/AppBar.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/AppHelper.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/AuthenticationManager.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Bonobo.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Client.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/ColorPicker.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Config.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/DateEdit.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Druid.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/DruidPage.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/DruidPageEdge.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/DruidPageStandard.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Entry.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/FileEntry.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/FontPicker.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/HRef.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Help.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/I18N.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/IconEntry.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/IconList.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/IconSelection.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/IconTextItem.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/IconTheme.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/ModuleInfo.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/PasswordDialog.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/PixmapEntry.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/PopupMenu.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Program.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Score.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Scores.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Sound.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Thumbnail.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/ThumbnailFactory.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/UIDefs.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/URL.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Util.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Window.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/WindowIcon.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/enums.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/index.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/main.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Bonobo/Dock.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Bonobo/DockItem.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Config/Iterator.pod
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/Files.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/doctypes
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/gnome.typemap
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/gnome2perl-autogen.h
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/gnome2perl-versions.h
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/gnome2perl.h
/usr/lib/x86_64-linux-gnu/perl5/5.20/Gnome2/Install/gnome2perl.typemap
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Gnome2/Gnome2.so
/usr/share/doc/libgnome2-perl/NEWS.gz
/usr/share/doc/libgnome2-perl/TODO
/usr/share/doc/libgnome2-perl/TODO.Debian
/usr/share/doc/libgnome2-perl/changelog.Debian.amd64.gz
/usr/share/doc/libgnome2-perl/changelog.Debian.gz
/usr/share/doc/libgnome2-perl/changelog.gz
/usr/share/doc/libgnome2-perl/copyright
/usr/share/doc/libgnome2-perl/examples/druid.pl
/usr/share/doc/libgnome2-perl/examples/session-management.pl
/usr/share/man/man3/Gnome2.3pm.gz
/usr/share/man/man3/Gnome2::About.3pm.gz
/usr/share/man/man3/Gnome2::App.3pm.gz
/usr/share/man/man3/Gnome2::AppBar.3pm.gz
/usr/share/man/man3/Gnome2::AppHelper.3pm.gz
/usr/share/man/man3/Gnome2::AuthenticationManager.3pm.gz
/usr/share/man/man3/Gnome2::Bonobo.3pm.gz
/usr/share/man/man3/Gnome2::Bonobo::Dock.3pm.gz
/usr/share/man/man3/Gnome2::Bonobo::DockItem.3pm.gz
/usr/share/man/man3/Gnome2::Client.3pm.gz
/usr/share/man/man3/Gnome2::ColorPicker.3pm.gz
/usr/share/man/man3/Gnome2::Config.3pm.gz
/usr/share/man/man3/Gnome2::Config::Iterator.3pm.gz
/usr/share/man/man3/Gnome2::DateEdit.3pm.gz
/usr/share/man/man3/Gnome2::Druid.3pm.gz
/usr/share/man/man3/Gnome2::DruidPage.3pm.gz
/usr/share/man/man3/Gnome2::DruidPageEdge.3pm.gz
/usr/share/man/man3/Gnome2::DruidPageStandard.3pm.gz
/usr/share/man/man3/Gnome2::Entry.3pm.gz
/usr/share/man/man3/Gnome2::FileEntry.3pm.gz
/usr/share/man/man3/Gnome2::FontPicker.3pm.gz
/usr/share/man/man3/Gnome2::HRef.3pm.gz
/usr/share/man/man3/Gnome2::Help.3pm.gz
/usr/share/man/man3/Gnome2::I18N.3pm.gz
/usr/share/man/man3/Gnome2::IconEntry.3pm.gz
/usr/share/man/man3/Gnome2::IconList.3pm.gz
/usr/share/man/man3/Gnome2::IconSelection.3pm.gz
/usr/share/man/man3/Gnome2::IconTextItem.3pm.gz
/usr/share/man/man3/Gnome2::IconTheme.3pm.gz
/usr/share/man/man3/Gnome2::ModuleInfo.3pm.gz
/usr/share/man/man3/Gnome2::PasswordDialog.3pm.gz
/usr/share/man/man3/Gnome2::PixmapEntry.3pm.gz
/usr/share/man/man3/Gnome2::PopupMenu.3pm.gz
/usr/share/man/man3/Gnome2::Program.3pm.gz
/usr/share/man/man3/Gnome2::Score.3pm.gz
/usr/share/man/man3/Gnome2::Scores.3pm.gz
/usr/share/man/man3/Gnome2::Sound.3pm.gz
/usr/share/man/man3/Gnome2::Thumbnail.3pm.gz
/usr/share/man/man3/Gnome2::ThumbnailFactory.3pm.gz
/usr/share/man/man3/Gnome2::UIDefs.3pm.gz
/usr/share/man/man3/Gnome2::URL.3pm.gz
/usr/share/man/man3/Gnome2::Util.3pm.gz
/usr/share/man/man3/Gnome2::Window.3pm.gz
/usr/share/man/man3/Gnome2::WindowIcon.3pm.gz
/usr/share/man/man3/Gnome2::enums.3pm.gz
/usr/share/man/man3/Gnome2::index.3pm.gz
/usr/share/man/man3/Gnome2::main.3pm.gz

Changelog

2014-05-22 - Damyan Ivanov <dmn@debian.org>
libgnome2-perl (1.045-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 1.045
* drop pod-spelling.patch, applied upstream
2013-11-09 - Damyan Ivanov <dmn@debian.org>
libgnome2-perl (1.044-1) unstable; urgency=low
* Team upload
* Imported Upstream version 1.044
* drop pods-extra-mkdir.patch, not needed anymore
* drop trailing slash from metacpan URLs
* claim conformance with Policy 3.9.5
2013-10-17 - Damyan Ivanov <dmn@debian.org>
libgnome2-perl (1.043-2) unstable; urgency=low
* Team upload
* bump years of upstream copyright
2013-10-17 - Damyan Ivanov <dmn@debian.org>
libgnome2-perl (1.043-1) unstable; urgency=low
* Team upload
[ Ryan Niebur ]
* Update ryan52's email address
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
* Fix grammar error in package description. Thanks to Clayton Casciato
for the bug report and the patch. (Closes: #687365)
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Damyan Ivanov ]
* New upstream release
+ Avoid misusing the macro PL_na, thus preventing issues when Gnome2 is
used in conjunction with certain XS modules, among them XML::Parser and
String::Approx.
* rules: use plain dh three-liner
* require debhelper 9.20120312 and set the compatibility level to 9 in order
to get all the hardening magic
* source format '3.0 (quilt)'
* add patch adding -p to an extra mkdir invocation, causing failure if the
directory already exists
* rules: install ChangeLog.pre-git as (obsolete, but still useful) upstream
change log
* claim conformance with Policy v3.9.4
* add patch fixinf a small typo in documentation
2009-03-12 - Ryan Niebur <ryanryan52@gmail.com>
libgnome2-perl (1.042-2) unstable; urgency=low
* Take over for the Debian Perl Group on maintainer's request
(http://lists.debian.org/debian-perl/2008/12/msg00163.html)
* Add me to uploaders, remove old maintainer(s)
* dh7
* docs
* policy 3.8.1
* use the glib patch to add whatis entries
* machine readable copyright format
2008-03-15 - Marc 'HE' Brockschmidt <he@debian.org>
libgnome2-perl (1.042-1) unstable; urgency=low
* New upstream release
* debian/control: 
- Change Maintainer to reflect "team" maintainership
- Bump Standards-Version to 3.7.3 (no changes needed)
- Fix duplicated "allows" in description. (Closes: #466285)
* debian/watch: Fixed. (Closes: #415924, #449611)
* debian/copyright: Converted to UTF8
2006-04-23 - Marc 'HE' Brockschmidt <he@debian.org>
libgnome2-perl (1.040-1) unstable; urgency=low
* New upstream release.
* debian/control: Bump Standards-Version. No changes.
2005-07-01 - Marc 'HE' Brockschmidt <he@debian.org>
libgnome2-perl (1.023-1) unstable; urgency=low
* New upstream release.
2005-06-12 - Marc 'HE' Brockschmidt <he@debian.org>
libgnome2-perl (1.022-1) unstable; urgency=low
* New upstream release.
2005-03-06 - Marc 'HE' Brockschmidt <he@debian.org>
libgnome2-perl (1.021-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
libgnome2-vfs-perl_1.082-1+b1_amd64.deb Perl interface to the 2.x series of the GNOME VFS library
libgnome2-wnck-perl_0.16-3+b1_amd64.deb Perl interface to the Window Navigator Construction Kit
libgnome2.0-cil-dev_2.24.2-3_amd64.deb CLI binding for GNOME 2.24
libgnome2.24-cil_2.24.2-3_amd64.deb CLI binding for GNOME 2.24
libgnomeada2.24.4-dev_2.24.4dfsg-1_amd64.deb Ada binding for the GNOME GUI (development files)
libgnomeada2.24.4_2.24.4dfsg-1_amd64.deb Ada binding for the GNOME GUI (dynamic library)
libgnomecanvas2-0_2.30.3-2_amd64.deb powerful object-oriented display engine - runtime files
libgnomecanvas2-common_2.30.3-2_all.deb powerful object-oriented display engine - common files
libgnomecanvas2-dev_2.30.3-2_amd64.deb powerful object-oriented display engine - development files
libgnomecanvas2-doc_2.30.3-2_all.deb powerful object-oriented display engine - documentation files
libgnomecanvasmm-2.6-1c2a_2.26.0-1.1_amd64.deb C++ wrappers for libgnomecanvas2 (shared library)
libgnomecanvasmm-2.6-dev_2.26.0-1.1_amd64.deb C++ wrappers for libgnomecanvas2 (development files)
libgnomecanvasmm-2.6-doc_2.26.0-1.1_all.deb C++ wrappers for libgnomecanvas2 (documentation)
libgnomedesktop2.0-cil-dev_2.26.0-8_all.deb CLI binding for GNOME Desktop 2.24
libgnomedesktop2.20-cil_2.26.0-8_all.deb CLI binding for GNOME Desktop 2.24
Advertisement
Advertisement