libglade2-dev_2.6.4-2_amd64.deb


Advertisement

Description

libglade2-dev - development files for libglade

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libglade2-dev
Package version 2.6.4
Package release 2
Package architecture amd64
Package type deb
Installed size 523 B
Download size 116.71 KB
Official Mirror ftp.br.debian.org
This library allows one to load externally stored user interfaces into
programs. This allows alteration of the interface without recompilation
of the program.
The interfaces can also be edited with GLADE.

Alternatives

Package Version Architecture Repository
libglade2-dev_2.6.4-2_i386.deb 2.6.4 i386 Debian Main
libglade2-dev - - -

Requires

Name Value
libglade2-0 = 1:2.6.4-2
libgtk2.0-dev >= 2.0.6
libxml2-dev -
python:any >= 2.0

Replaces

Name Value
libglade2-0 << 2.0.1-10

Download

Type URL
Binary Package libglade2-dev_2.6.4-2_amd64.deb
Source Package libglade2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libglade2-dev deb package:
    # sudo apt-get install libglade2-dev

Files

Path
/usr/bin/libglade-convert
/usr/include/libglade-2.0/glade/glade-build.h
/usr/include/libglade-2.0/glade/glade-init.h
/usr/include/libglade-2.0/glade/glade-parser.h
/usr/include/libglade-2.0/glade/glade-xml.h
/usr/include/libglade-2.0/glade/glade.h
/usr/lib/x86_64-linux-gnu/libglade-2.0.a
/usr/lib/x86_64-linux-gnu/libglade-2.0.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libglade-2.0.pc
/usr/share/doc-base/libglade2-dev
/usr/share/doc/libglade2-dev/AUTHORS
/usr/share/doc/libglade2-dev/NEWS.gz
/usr/share/doc/libglade2-dev/README
/usr/share/doc/libglade2-dev/changelog.Debian.gz
/usr/share/doc/libglade2-dev/changelog.gz
/usr/share/doc/libglade2-dev/copyright
/usr/share/doc/libglade2-dev/examples/bonobo.glade
/usr/share/doc/libglade2-dev/examples/example.glade.gz
/usr/share/doc/libglade2-dev/examples/first.glade
/usr/share/doc/libglade2-dev/examples/simple.glade.gz
/usr/share/gtk-doc/html/libglade/GladeXML.html
/usr/share/gtk-doc/html/libglade/home.png
/usr/share/gtk-doc/html/libglade/index.html
/usr/share/gtk-doc/html/libglade/index.sgml
/usr/share/gtk-doc/html/libglade/left.png
/usr/share/gtk-doc/html/libglade/libglade-Libglade-Build.html
/usr/share/gtk-doc/html/libglade/libglade-Libglade-Initialisation.html
/usr/share/gtk-doc/html/libglade/libglade-Libglade-SAX-Parser.html
/usr/share/gtk-doc/html/libglade/libglade-dtd-exceptions.html
/usr/share/gtk-doc/html/libglade/libglade-dtd.html
/usr/share/gtk-doc/html/libglade/libglade-embedding.html
/usr/share/gtk-doc/html/libglade/libglade-extending.html
/usr/share/gtk-doc/html/libglade/libglade-i18n.html
/usr/share/gtk-doc/html/libglade/libglade-lib.html
/usr/share/gtk-doc/html/libglade/libglade-modules.html
/usr/share/gtk-doc/html/libglade/libglade-notes.html
/usr/share/gtk-doc/html/libglade/libglade.devhelp
/usr/share/gtk-doc/html/libglade/libglade.devhelp2
/usr/share/gtk-doc/html/libglade/right.png
/usr/share/gtk-doc/html/libglade/style.css
/usr/share/gtk-doc/html/libglade/up.png
/usr/share/man/man1/libglade-convert.1.gz

Changelog

2013-12-26 - Josselin Mouette <joss@debian.org>
libglade2 (1:2.6.4-2) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/libglade2-dev.lintian:
- Removed, libglade2-dev depends on python now.
[ Loïc Minier ]
* Fix globbing in watch file.
[ Josselin Mouette ]
* Patch from Steve Langasek to add MA support. Closes: #650787.
+ Use MA installation paths.
+ Switch do DH compat 9.
+ Update {build-,}dependencies.
* Bump shlibs to take the new module path into account.
* Use python:any dependency in the -dev package.
* Drop the .la file.
* 01_pre-multiarch_path.patch: new patch. Search modules in 
the pre-multiarch version’s path.
* Bump standards version.
* Fix spelling error in description. Closes: #687367.
* Move to section oldlibs.
* Switch to 3.0 quilt format.
* Use dh-autoreconf. Closes: #558573.
2009-04-04 - Sebastian Dröge <slomo@debian.org>
libglade2 (1:2.6.4-1) unstable; urgency=low
[ Loic Minier ]
* Use ge-nl instead of ge in preinst for robustness.
[ Josselin Mouette ]
* Build-depend on libglib2.0-doc and libgtk2.0-doc to ensure proper 
xrefs.
[ Sebastian Dröge ]
* New upstream bugfix release.
* Update Standards-Version to 3.8.1.
2008-11-11 - Josselin Mouette <joss@debian.org>
libglade2 (1:2.6.3-1) unstable; urgency=low
[ Kilian Krause ]
* Use binary:version and source:Version for binnNMU-safe uploads as
added in dpkg-dev 1.13.19. Add to Build-Depends accordingly.
[ Emilio Pozuelo Monfort ]
* debian/libglade2-dev.doc-base: fix section.
[ Josselin Mouette ]
* New upstream bugfix and documentation release.
* Build-depend on glib 2.10.
* Standards version is 3.8.0.
2007-07-31 - Loic Minier <lool@dooz.org>
libglade2 (1:2.6.2-1) unstable; urgency=low
* New upstream stable release; no API change; bug fixes.
2007-06-19 - Loic Minier <lool@dooz.org>
libglade2 (1:2.6.1-1) unstable; urgency=low
[ Josselin Mouette ]
* Fix grammatical error in the description (closes: #405575).
[ Loic Minier ]
* Add a get-orig-source target to retrieve the upstream tarball.
* New upstream stable release; with API additions.
- Bump shlibs to >= 1:2.6.1.
* Add #DEBHELPER# to libglade2-dev.preinst; doh!
* Wrap build-deps and deps.
* Update "Suggests" to glade | glade-gnome.
* Fix licensing in copyright.
* Fix upstream URL in copyright.
* Fix watch file to use HTTP and track all stable versions.
* Cleanups.
2006-12-23 - Loic Minier <lool@dooz.org>
libglade2 (1:2.6.0-4) unstable; urgency=medium
* People who had upgraded libglade2 from any version before 1:2.6.0-2 would
get a symlink in symlink; this symlink in symlink is now removed on
upgrades in preinst, and the symlink creation postinst snippet tests for
the existence of the symlink; thanks Lior Kaplan; closes: #404185.
2006-12-15 - Loic Minier <lool@dooz.org>
libglade2 (1:2.6.0-3) unstable; urgency=medium
[ Josselin Mouette ]
* rules: call clean-la.mk.
* Require gnome-pkg-tools 0.7.
[ Loic Minier ]
* Build-depend on python (>= 2.0) instead of python2.3; thanks
Andreas Barth.
* Downgrade libglade2-dev dependency on python for libglade-convert to
>= 2.0 as well.
2006-08-10 - Loic Minier <lool@dooz.org>
libglade2 (1:2.6.0-2) unstable; urgency=low
* Remove the /usr/share/doc/libglade2-dev/html symlink in libglade2-dev's
prerm, thanks Lior Kaplan and "hungerburg". (Closes: #314789)
2006-08-08 - Loic Minier <lool@dooz.org>
libglade2 (1:2.6.0-1) unstable; urgency=low
* New upstream release; no API changes.
* Bump up Standards-Version to 3.7.2.
* Bump up Debhelper compatibility level to 5.
* Add ${misc:Depends}.
2005-06-08 - Josselin Mouette <joss@debian.org>
libglade2 (1:2.5.1-2) unstable; urgency=low
* Upload to unstable.

See Also

Package Description
libglade2.0-cil-dev_2.12.10-5.1_amd64.deb CLI binding for the Glade libraries 2.6
libglade2.0-cil_2.12.10-5.1_amd64.deb CLI binding for the Glade libraries 2.6
libglademm-2.4-1c2a_2.6.7-4_amd64.deb C++ wrappers for libglade2 (shared library)
libglademm-2.4-dev_2.6.7-4_amd64.deb C++ wrappers for libglade2 (development files)
libglademm-2.4-doc_2.6.7-4_all.deb C++ wrappers for libglade2 (documentation)
libgladeui-2-6_3.18.3-1_amd64.deb GTK+ User Interface Build core library
libgladeui-common_3.18.3-1_all.deb GTK+ User Interface Build core library (common files)
libgladeui-dev_3.18.3-1_amd64.deb GTK+ User Interface Build core library (development files)
libgladeui-doc_3.18.3-1_all.deb GTK+ User Interface Build core library (documentation)
libglapi-mesa_10.3.2-1+deb8u1_amd64.deb free implementation of the GL API -- shared library
libglazedlists-java-doc_1.9.0+dfsg-1_all.deb java list transformation library (documentation)
libglazedlists-java_1.9.0+dfsg-1_all.deb java list transformation library
libglbsp-dev_2.24-2_amd64.deb node builder library for OpenGL-based Doom-style games (headers)
libglbsp3_2.24-2_amd64.deb node builder library for OpenGL-based Doom-style games
libglc-dev_0.7.2-5+b2_amd64.deb An implementation of SGI's OpenGL Character Renderer (GLC)
Advertisement
Advertisement