libgksu2-0_2.0.13~pre1-8_amd64.deb


Advertisement

Description

libgksu2-0 - library providing su and sudo functionality

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgksu2-0
Package version 2.0.13~pre1
Package release 8
Package architecture amd64
Package type deb
Installed size 584 B
Download size 94.24 KB
Official Mirror ftp.br.debian.org
This library comes from the gksu program. It provides a simple
API to use su and sudo in programs that need to execute tasks
as other user. It provides X authentication facilities for running
programs in an X session.

Alternatives

Package Version Architecture Repository
libgksu2-0_2.0.13~pre1-8_i386.deb 2.0.13~pre1 i386 Debian Main
libgksu2-0 - - -

Requires

Name Value
gconf-service -
gconf2 >= 2.28.1-2
libatk1.0-0 >= 1.12.4
libc6 >= 2.2.5
libcairo2 >= 1.2.4
libfontconfig1 >= 2.11
libfreetype6 >= 2.2.1
libgconf-2-4 >= 3.2.5
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.35.9
libgnome-keyring0 >= 3.2.2-2~
libgtk2.0-0 >= 2.12.0
libgtop2-7 >= 2.22.3
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libstartup-notification0 >= 0.4
libx11-6 -
xauth -

Download

Type URL
Binary Package libgksu2-0_2.0.13~pre1-8_amd64.deb
Source Package libgksu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgksu2-0 deb package:
    # sudo apt-get install libgksu2-0

Files

Path
/usr/bin/gksu-properties
/usr/lib/libgksu2.so.0
/usr/lib/libgksu2.so.0.0.2
/usr/lib/libgksu/gksu-run-helper
/usr/share/doc/libgksu2-0/AUTHORS
/usr/share/doc/libgksu2-0/README.Debian
/usr/share/doc/libgksu2-0/changelog.Debian.gz
/usr/share/doc/libgksu2-0/changelog.gz
/usr/share/doc/libgksu2-0/copyright
/usr/share/gconf/schemas/gksu.schemas
/usr/share/libgksu/gksu-properties.ui
/usr/share/libgksu/debian/gconf-defaults.libgksu-su
/usr/share/libgksu/debian/gconf-defaults.libgksu-sudo
/usr/share/locale/ca/LC_MESSAGES/libgksu.mo
/usr/share/locale/cs/LC_MESSAGES/libgksu.mo
/usr/share/locale/da/LC_MESSAGES/libgksu.mo
/usr/share/locale/de/LC_MESSAGES/libgksu.mo
/usr/share/locale/es/LC_MESSAGES/libgksu.mo
/usr/share/locale/eu/LC_MESSAGES/libgksu.mo
/usr/share/locale/fr/LC_MESSAGES/libgksu.mo
/usr/share/locale/hu/LC_MESSAGES/libgksu.mo
/usr/share/locale/it/LC_MESSAGES/libgksu.mo
/usr/share/locale/ja/LC_MESSAGES/libgksu.mo
/usr/share/locale/ko/LC_MESSAGES/libgksu.mo
/usr/share/locale/lt/LC_MESSAGES/libgksu.mo
/usr/share/locale/nb/LC_MESSAGES/libgksu.mo
/usr/share/locale/nl/LC_MESSAGES/libgksu.mo
/usr/share/locale/pl/LC_MESSAGES/libgksu.mo
/usr/share/locale/pt_BR/LC_MESSAGES/libgksu.mo
/usr/share/locale/ro/LC_MESSAGES/libgksu.mo
/usr/share/locale/ru/LC_MESSAGES/libgksu.mo
/usr/share/locale/sk/LC_MESSAGES/libgksu.mo
/usr/share/locale/sv/LC_MESSAGES/libgksu.mo
/usr/share/locale/th/LC_MESSAGES/libgksu.mo
/usr/share/locale/zh_CN/LC_MESSAGES/libgksu.mo
/usr/share/man/man1/gksu-properties.1.gz
/usr/share/pixmaps/gksu.png

Changelog

2014-09-06 - Balint Reczey <balint@balintreczey.hu>
libgksu (2.0.13~pre1-8) unstable; urgency=medium
* Adding myself to uploaders
* Convert packaging to Debhelper
* Build-depend on dh-autoreconf
* Regenerate makefile structure (Closes: #749167, #757782)
* Drop (build-)dependency on cdbs and xbase-clients to keep lintian happy
* Use canonical VCS URLs to keep Lintian happy
[Cody Russell]
* Fix crash with RGBA colormap (Closes: #561379)
[Hideki Yamane]
* Add Japanese translation (Closes: #503461)
[Roland Clobus]
* Fix unguarded variable (Closes: #537718)
2014-05-03 - Emilio Pozuelo Monfort <pochu@debian.org>
libgksu (2.0.13~pre1-7) unstable; urgency=low
[ Josselin Mouette ]
* Update repository URL.
[ Emilio Pozuelo Monfort ]
* debian/patches/03_makefile_spaces.patch:
+ New patch, fix build with make 4.0.
2011-12-07 - Martin Pitt <mpitt@debian.org>
libgksu (2.0.13~pre1-6) unstable; urgency=low
* debian/control.in: Fix Vcs-* URL.
* debian/patches/02_format-security.patch: The previous fix exposed a logic
flaw which caused a NULL pointer crash if calling sudo was successful. Fix
this. (LP: #898874)
2011-10-24 - Michael Biebl <biebl@debian.org>
libgksu (2.0.13~pre1-5) unstable; urgency=low
* Switch to dpkg source format 3.0 (quilt).
* debian/control.in:
- Wrap dependencies.
- Remove obsolete versioned Build-Depends on dpkg-dev.
- Add ${misc:Depends} to libgksu2-dev.
- Bump Standards-Version to 3.9.2. No further changes.
- Remove obsolete Conflicts/Replaces.
* debian/patches/02_format-security.patch:
- Fix build failure with [-Werror=format-security]. Closes: #643423
* debian/patches/28_ld_no_as_needed.patch:
- Fix build failures with binutils-gold. Thanks Matthias Klose for the
patch. Closes: #555180
* Bump debhelper compatibility level to 8.
- Update Build-Depends on debhelper.
- Strip debian/tmp/ from .install files and simplify them a bit.
2011-01-24 - Josselin Mouette <joss@debian.org>
libgksu (2.0.13~pre1-4) unstable; urgency=low
* ru.po: updated Russian translation by Alexander Sashanov.
Closes: #609130, #609141.
2010-11-21 - Josselin Mouette <joss@debian.org>
libgksu (2.0.13~pre1-3) unstable; urgency=low
* pt_BR.po: updated Brazilian Portuguese translation by Sérgio 
Cipolla. Closes: #601168.
* 01_tcdrain_kfreebsd.patch: patch from Petr Salinger. Don’t use 
tcdrain on kfreebsd. Closes: #600365.
2010-10-19 - Josselin Mouette <joss@debian.org>
libgksu (2.0.13~pre1-2) unstable; urgency=low
* 99_intltool.patch: update po/Makefile.in.in with a working intltool 
version. Closes: #599420.
* Build-depend on intltool since it’s how it works nowadays.
2009-06-29 - Gustavo Noronha Silva <kov@debian.org>
libgksu (2.0.13~pre1-1) unstable; urgency=low
* Upstream snapshot
- tries to address the forkpty problem, by basically turning it into a
configure option; this should enable usage in Fedora/RedHat, while
still working good in Debian/Ubuntu (Closes: #540176, #535544)
2009-06-29 - Gustavo Noronha Silva <kov@debian.org>
libgksu (2.0.12-1) unstable; urgency=low
* New upstream release
- includes fix for double free (Closes: #534844)
* debian/control.in:
- patch by seb128 to replace dependency on libglade with gtk+ > 2.12
(which has GtkBuilder)
2009-06-24 - Gustavo Noronha Silva <kov@debian.org>
libgksu (2.0.11-1) unstable; urgency=low
* New upstream release
- should work with sudo when requiretty is on (Closes: #531477)
* debian/libgksu2-0.instal:
- make sure to install the gksu-properties manpage (Closes: #497591)

See Also

Package Description
libgksu2-dev_2.0.13~pre1-8_amd64.deb library providing su and sudo functionality (development files)
libgl-gst_3.2.4-2.1_amd64.deb OpenGL bindings for GNU Smalltalk
libgl1-mesa-dev_10.3.2-1+deb8u1_amd64.deb free implementation of the OpenGL API -- GLX development files
libgl1-mesa-dri_10.3.2-1+deb8u1_amd64.deb free implementation of the OpenGL API -- DRI modules
libgl1-mesa-glx_10.3.2-1+deb8u1_amd64.deb free implementation of the OpenGL API -- GLX runtime
libgl1-mesa-swx11-dev_10.3.2-1+deb8u1_amd64.deb free implementation of the OpenGL API -- development files
libgl1-mesa-swx11_10.3.2-1+deb8u1_amd64.deb free implementation of the OpenGL API -- runtime
libgl2ps-dev_1.3.8-1.2_amd64.deb Lib providing high quality vector output for OpenGL application
libgl2ps0_1.3.8-1.2_amd64.deb Lib providing high quality vector output for OpenGL application
libglacier2-35_3.5.1-6+b3_amd64.deb Libraries implementing a firewall service for ZeroC Ice
libglade2-0_2.6.4-2_amd64.deb library to load .glade files at runtime
libglade2-dev_2.6.4-2_amd64.deb development files for libglade
libglade2.0-cil-dev_2.12.10-5.1_amd64.deb CLI binding for the Glade libraries 2.6
libglade2.0-cil_2.12.10-5.1_amd64.deb CLI binding for the Glade libraries 2.6
libglademm-2.4-1c2a_2.6.7-4_amd64.deb C++ wrappers for libglade2 (shared library)
Advertisement
Advertisement