libgit-wrapper-perl_0.037-2_all.deb


Advertisement

Description

libgit-wrapper-perl - Perl module to wrap git command-line interface

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgit-wrapper-perl
Package version 0.037
Package release 2
Package architecture all
Package type deb
Installed size 101 B
Download size 33.03 KB
Official Mirror ftp.br.debian.org
Git::Wrapper provides an API for git that uses Perl data structures for
argument passing, instead of CLI-style --options as Git does.
Except as documented, every git subcommand is available as a method on
a Git::Wrapper object. Replace any hyphens in the git command with
underscores.

Alternatives

Package Version Architecture Repository
libgit-wrapper-perl_0.037-2_all.deb 0.037 all Debian Main
libgit-wrapper-perl - - -

Requires

Name Value
git -
libfile-pushd-perl >= 1.005
libsort-versions-perl -
perl -

Download

Type URL
Binary Package libgit-wrapper-perl_0.037-2_all.deb
Source Package libgit-wrapper-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgit-wrapper-perl deb package:
    # sudo apt-get install libgit-wrapper-perl

Files

Path
/usr/share/doc/libgit-wrapper-perl/changelog.Debian.gz
/usr/share/doc/libgit-wrapper-perl/changelog.gz
/usr/share/doc/libgit-wrapper-perl/copyright
/usr/share/man/man3/Git::Wrapper.3pm.gz
/usr/share/man/man3/Git::Wrapper::Exception.3pm.gz
/usr/share/man/man3/Git::Wrapper::File::RawModification.3pm.gz
/usr/share/man/man3/Git::Wrapper::Log.3pm.gz
/usr/share/man/man3/Git::Wrapper::Status.3pm.gz
/usr/share/man/man3/Git::Wrapper::Statuses.3pm.gz
/usr/share/perl5/Git/Wrapper.pm
/usr/share/perl5/Git/Wrapper/Exception.pm
/usr/share/perl5/Git/Wrapper/Log.pm
/usr/share/perl5/Git/Wrapper/Status.pm
/usr/share/perl5/Git/Wrapper/Statuses.pm
/usr/share/perl5/Git/Wrapper/File/RawModification.pm

Changelog

2014-10-11 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.037-2) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Drop patch no-devel-checkbin.patch,
libdevel-checkbin-perl is packaged now.
Add build dependency on libdevel-checkbin-perl.
* Add debian/upstream/metadata
* Declare compliance with Debian Policy 3.9.6.
2014-08-13 - Salvatore Bonaccorso <carnil@debian.org>
libgit-wrapper-perl (0.037-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.037
* Refresh no-devel-checkbin.patch patch
2014-07-31 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.035-1) unstable; urgency=medium
* Team upload.
* New upstream release.
2014-07-25 - Salvatore Bonaccorso <carnil@debian.org>
libgit-wrapper-perl (0.034-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.034
* Adjust (build-)dependency for File::pushd.
Make unversioned Build-Depends-Indep and Depends on libfile-pushd-perl
versioned to (>= 1.005).
* Wrap and sort fields in debian/control file
* Refresh no-devel-checkbin.patch patch
2014-05-12 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.032-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update Upstream-Contact and upstream copyright years.
* Drop some build-deps (not required anymore).
* Add patch to remove check for `git' during build.
The check uses the unpackaged Devel::CheckBin module, and we don't need it
anyway due to (build) dependencies.
2014-03-20 - Angel Abad <angel@debian.org>
libgit-wrapper-perl (0.031-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Angel Abad ]
* Imported Upstream version 0.031
* debian/copyright: Update debian/* years
* Bump Standards-Version to 3.9.5 (no changes)
2013-08-08 - Angel Abad <angel@debian.org>
libgit-wrapper-perl (0.030-1) unstable; urgency=low
* Imported Upstream version 0.030
* debian/control: B-D-I on libpath-class-perl
2013-05-31 - Angel Abad <angel@debian.org>
libgit-wrapper-perl (0.029-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Angel Abad ]
* Imported Upstream version 0.029
* debian/copyright: Update debian years
2012-10-24 - Salvatore Bonaccorso <carnil@debian.org>
libgit-wrapper-perl (0.028-1) unstable; urgency=low
* Team upload.
* Imported Upstream version 0.028
2012-09-24 - Angel Abad <angel@debian.org>
libgit-wrapper-perl (0.027-1) unstable; urgency=low
* Imported Upstream version 0.027
* debian/copyright: Update debian years
* Bump Standards-Version to 3.9.4
* debian/patches/fix-bad-whatis.patch: Remove patch, applied upstream

See Also

Package Description
libgit2-21_0.21.1-3_amd64.deb low-level Git library
libgit2-dev_0.21.1-3_amd64.deb low-level Git library (development files)
libgit2-glib-1.0-0_0.0.22-1_amd64.deb glib wrapper library around the libgit2 git access library
libgit2-glib-1.0-dev_0.0.22-1_amd64.deb glib wrapper library around the libgit2 git access library - development files
libgit2-glib-1.0-doc_0.0.22-1_all.deb glib wrapper library around the libgit2 git access library - documentation
libgivaro-dev_3.7.2-1_amd64.deb arithmetic and algebraic computations - development files
libgivaro-doc_3.7.2-1_all.deb Documentation for Givaro
libgivaro1_3.7.2-1_amd64.deb arithmetic and algebraic computations
libgjs-dev_1.42.0-1_amd64.deb Mozilla-based javascript bindings for the GNOME platform
libgjs0e_1.42.0-1_amd64.deb Mozilla-based javascript bindings for the GNOME platform
libgkeyfile-cil-dev_0.1-4_all.deb GObject-based wrapper library for GKeyFile -- CLI development files
libgkeyfile1.0-cil_0.1-4_all.deb GObject-based wrapper library for GKeyFile -- CLI bindings
libgksu2-0_2.0.13~pre1-8_amd64.deb library providing su and sudo functionality
libgksu2-dev_2.0.13~pre1-8_amd64.deb library providing su and sudo functionality (development files)
libgl-gst_3.2.4-2.1_amd64.deb OpenGL bindings for GNU Smalltalk
Advertisement
Advertisement