libgirepository-1.0-1_1.42.0-2.2_amd64.deb


Advertisement

Description

libgirepository-1.0-1 - Library for handling GObject introspection data (runtime library)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package filename libgirepository-1.0-1_1.42.0-2.2_amd64.deb
Package name libgirepository-1.0-1
Package version 1.42.0
Package release 2.2
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://wiki.gnome.org/GObjectIntrospection
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 93.48 KB
Installed size 235.00 KB
GObject Introspection is a project for providing machine readable
introspection data of the API of C libraries. This introspection
data can be used in several different use cases, for example
automatic code generation for bindings, API verification and documentation
generation.
GObject Introspection contains tools to generate and handle the
introspection data.
This package contains a C library for handling the introspection data.

Alternatives

Package Version Architecture Repository
libgirepository-1.0-1_1.42.0-2.2_i386.deb 1.42.0 i386 Debian Main
libgirepository-1.0-1 - - -

Requires

Name Value
libc6 >= 2.14
libffi6 >= 3.0.4
libglib2.0-0 >= 2.39.0

Provides

Name Value
libgirepository1.0-1 -

Conflicts

Name Value
libgirepository1.0-1 -

Replaces

Name Value
libgirepository1.0-1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgirepository-1.0-1_1.42.0-2.2_amd64.deb
Source Package gobject-introspection

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgirepository-1.0-1 deb package:
    # sudo apt-get install libgirepository-1.0-1

Files

Path
/usr/lib/x86_64-linux-gnu/libgirepository-1.0.so.1
/usr/lib/x86_64-linux-gnu/libgirepository-1.0.so.1.0.0
/usr/share/doc/libgirepository-1.0-1/AUTHORS
/usr/share/doc/libgirepository-1.0-1/CONTRIBUTORS
/usr/share/doc/libgirepository-1.0-1/NEWS.gz
/usr/share/doc/libgirepository-1.0-1/README
/usr/share/doc/libgirepository-1.0-1/TODO
/usr/share/doc/libgirepository-1.0-1/changelog.Debian.gz
/usr/share/doc/libgirepository-1.0-1/copyright

Changelog

2014-10-22 - intrigeri <intrigeri@debian.org>
gobject-introspection (1.42.0-2.2) unstable; urgency=medium
* Non-maintainer upload.
* Dont_unconditionally_include_config.h_in_gimarshallingtests.c.patch:
new patch, similar to the one applied in the last upload, that fixed
the same problem in regress.c only (Closes: #764272)
2014-10-21 - intrigeri <intrigeri@debian.org>
gobject-introspection (1.42.0-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Dont_unconditionally_include_config.h_in_regress.c.patch: new patch,
cherry-picked from upstream (Closes: #764272)
2014-10-01 - Michael Biebl <biebl@debian.org>
gobject-introspection (1.42.0-2) unstable; urgency=medium
* dh_girepository: Add a versioned dependency on libgirepository-1.0-1
(>= 1.41.4-1) to ${gir:Depends} if a gir package installs typelib files
into multiarch libdir. This ensures a multiarch capable version of
libgirepository-1.0-1 is installed to avoid breakage on partial upgrades.
2014-09-23 - Andreas Henriksson <andreas@fatal.se>
gobject-introspection (1.42.0-1) unstable; urgency=medium
* New upstream release.
* Drop debian/patches/0001-Hide-more-symbols-that-shouldn-t-be-exported.patch
- now include in new upstream release.
2014-09-19 - Andreas Henriksson <andreas@fatal.se>
gobject-introspection (1.41.91-3) unstable; urgency=medium
* Drop debian/patches/0002-Export-missing-g_typelib_error_quark.patch
- doesn't look like it'll be applied upstream and who cares about
this symbol anyway?
* Drop g_typelib_error_quark from debian/libgirepository-1.0-1.symbols
2014-09-15 - Iain Lane <laney@debian.org>
gobject-introspection (1.41.91-2) experimental; urgency=medium
* dh_girepository: In require_typelib(), always return if we've found the
target typelib in the system directory, since we'll have definitely added
the dependency. Thanks again to mvo.
2014-09-05 - Andreas Henriksson <andreas@fatal.se>
gobject-introspection (1.41.91-1) experimental; urgency=medium
* New upstream development release.
* Add debian/patches/0001-Hide-more-symbols-that-shouldn-t-be-exported.patch
and debian/patches/0002-Export-missing-g_typelib_error_quark.patch
- fix what seems to be mistakenly exported and a missing symbol from
conversion to "Export Symbols Using Compiler Directives"
see https://bugzilla.gnome.org/show_bug.cgi?id=732669
2014-08-31 - Iain Lane <laney@debian.org>
gobject-introspection (1.41.4-1) experimental; urgency=medium
[ Martin Pitt ]
* dh_girepository(1): Point out that --with gir is needed for dh.
(Closes: #692254)
[ Jackson Doak ]
* New upstream release
- Add Test API required by gjs 1.40.1. (LP: #1314441)
- Update symbols file
[ Andreas Henriksson ]
* New upstream development release.
* Drop patch from upstream:
- debian/patches/git_tests_implementation_interface.patch
[ Iain Lane ]
* debian/{rules, dh_girepository}: Apply patch (slightly modified) from
Michael Vogt to use a multiarch libdir. As typelib files are placed into a
subdirectory of libdir, this may cause some packages (those which respect
the `typelibdir' variable in the pcfile) to fail to build until their
.install files are updated. This change allows gir packages to be made
multiarch. (Closes: #755874)
+ debian/patches/pre_multiarch_compat: Search for typelib files in the
pre-multiarch path too.
+ debian/control*: Mark gi packages as M-A: same
2014-04-02 - Emilio Pozuelo Monfort <pochu@debian.org>
gobject-introspection (1.40.0-2) unstable; urgency=medium
* Drop breaks on libgjs0c like was done for 1.38.0-2/sid.
* Upload to unstable.
2014-03-25 - Andreas Henriksson <andreas@fatal.se>
gobject-introspection (1.40.0-1) experimental; urgency=medium
* Bump glib build-dep to >= 2.39.0
- otherwise gir1.2-glib-2.0 doesn't get g_desktop_app_info_search
which is needed by gnome-shell.
* debian/copyright: fix syntax errors caught by lintian
* New upstream release.

See Also

Package Description
libgirepository1.0-dev_1.42.0-2.2_amd64.deb Library for handling GObject introspection data (development files)
libgisi-dev_0.1.0-1_amd64.deb low-level communication library for ISI modems (devel files)
libgisi0_0.1.0-1_amd64.deb low-level communication library for ISI modems
libgisicomm-dev_0.1.0-1_amd64.deb high-level communication library for ISI modems (devel files)
libgisicomm0_0.1.0-1_amd64.deb high-level communication library for ISI modems
libgit-pureperl-perl_0.50-2_all.deb Pure Perl interface to Git repositories
libgit-repository-perl_1.312-1_all.deb Perl interface to Git repositories
libgit-repository-plugin-log-perl_1.312-1_all.deb Git::Repository plugin adding log items
libgit-wrapper-perl_0.037-2_all.deb Perl module to wrap git command-line interface
libgit2-21_0.21.1-3_amd64.deb low-level Git library
libgit2-dev_0.21.1-3_amd64.deb low-level Git library (development files)
libgit2-glib-1.0-0_0.0.22-1_amd64.deb glib wrapper library around the libgit2 git access library
libgit2-glib-1.0-dev_0.0.22-1_amd64.deb glib wrapper library around the libgit2 git access library - development files
libgit2-glib-1.0-doc_0.0.22-1_all.deb glib wrapper library around the libgit2 git access library - documentation
libgivaro-dev_3.7.2-1_amd64.deb arithmetic and algebraic computations - development files
Advertisement
Advertisement