libgimpactutils2.82_2.82-r2704+dfsg-2_amd64.deb


Advertisement

Description

libgimpactutils2.82 - professional 3D Game Multiphysics Library -- GIMPACT

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgimpactutils2.82
Package version 2.82
Package release r2704+dfsg-2
Package architecture amd64
Package type deb
Installed size 95 B
Download size 31.03 KB
Official Mirror ftp.br.debian.org
Bullet professional 3D Game Multiphysics Library provides state of the art
collision detection, soft body and rigid body dynamics.
This package contains the GIMPACT shared library. GIMPACT is a software
library with tools for geometry processing and collision detection, focused on
solving most common problems on Virtual Reality development.
For more information about Bullet, please refer to the libbullet-dev package.

Alternatives

Package Version Architecture Repository
libgimpactutils2.82_2.82-r2704+dfsg-2_i386.deb 2.82 i386 Debian Main
libgimpactutils2.82 - - -

Requires

Name Value
libbulletcollision2.82 -
libc6 >= 2.2.5
libconvexdecomposition2.82 -
libgcc1 >= 1:4.1.1
liblinearmath2.82 -
libstdc++6 >= 4.1.1
multiarch-support -

Download

Type URL
Binary Package libgimpactutils2.82_2.82-r2704+dfsg-2_amd64.deb
Source Package bullet

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgimpactutils2.82 deb package:
    # sudo apt-get install libgimpactutils2.82

Files

Path
/usr/lib/x86_64-linux-gnu/libGIMPACTUtils.so.2.82
/usr/share/doc/libgimpactutils2.82/changelog.Debian.gz
/usr/share/doc/libgimpactutils2.82/changelog.gz
/usr/share/doc/libgimpactutils2.82/copyright

Changelog

2014-03-25 - Markus Koschany <apo@gambaru.de>
bullet (2.82-r2704+dfsg-2) unstable; urgency=medium
* Upload to unstable.
* Update copyright years.
2013-11-01 - Markus Koschany <apo@gambaru.de>
bullet (2.82-r2704+dfsg-1) experimental; urgency=low
* [d23f55a] Imported Upstream version 2.82-r2704+dfsg
* [378223c] Update get-orig-source target for new upstream release.
* [29f37ad] Rename all files to 2.82 because of the usual SONAME change.
* [b6b39a5] debian/control: Rename all binary packages from 2.81 to 2.82.
* [54b5c87] Update copyright years. Add a new contributor.
* [f7bc2d2] Update homepage field to org address.
* [388b5b7] Bump Standards-Version to 3.9.5, no changes.
2013-09-29 - Markus Koschany <apo@gambaru.de>
bullet (2.81-rev2613+dfsg2-1) unstable; urgency=low
* [f3ab74c] Imported Upstream version 2.81-rev2613+dfsg2
- Repack Bullet and remove ParticlesOpenCL demo. It is not clear whether
ParticlesOCL.cl can be distributed under the Zlib license. Since upstream
recommends to use the particle demo from Bullet 3.x anyway, the
ParticlesOpenCL directory is removed from the sources. Thanks to bastien
ROUCARIES for the report. (Closes: #724905)
2013-08-10 - Markus Koschany <apo@gambaru.de>
bullet (2.81-rev2613+dfsg-3) unstable; urgency=low
* [52a6675] debian/control: Move graphviz and doxygen to Indep.
graphviz and doxygen are only required to build the arch:all documentation.
* [b3a4b8a] Build the documentation only in the indep target.
This avoids a FTBFS on armel and is less wasteful for the buildd.
* [2c225f2] Really use canonical Vcs-URI.
* [16530ab] get-orig-source: produce identical tarballs.
* [fc8a3e6] debian/rules: Remove override for dh_builddeb
xz is the default compressor now
* [c2c8f49] Use symlinks and rdfind for deduplication of files.
* [46f4996] Clean up md5, map and html files in libbullet-doc.
Thanks to Dmitry Smirnov for the patch.
* [b8f7e5b] Improve get-orig-source target.
Add an error handler to the get-orig-source target. This is to avoid
extracting the orig.tar file to an existing directory.
* [f59314d] Ensure that bullet can be built twice.
Remove html files in dh_clean target because dpkg-source cannot represent
the changes to those html files.
* [52c9c25] debian/rules: Do not use -Wl, --as-needed anymore. Apparently
this option is too aggressive and also prevents that libgimpactutils is
dynamically linked against libc6.
2013-04-21 - Markus Koschany <apo@gambaru.de>
bullet (2.81-rev2613+dfsg-2) unstable; urgency=low
* [5d413e4] debian/rules: Do not overwrite dh_auto_install anymore.
* [7c09b54] libbullet-dev.install: Install missing include header files.
* [dfd842e] Drop libglui-dev from Build-Depends.
The library is only needed for the Bullet demos. Since we do not use the
demos anyway, dropping libglui-dev is acceptable.
* [7b1d794] Drop change-glui-include-path.patch.
2013-03-25 - Markus Koschany <apo@gambaru.de>
bullet (2.81-rev2613+dfsg-1) unstable; urgency=low
* Initial release.
Thanks to Wen-Yen Chuang, Paul Wise and Gonéri Le Bouder for their
contributions to the initial packaging work. (Closes: #476284)

See Also

Package Description
libginac-dev_1.6.2-1_amd64.deb GiNaC symbolic framework development files
libginac2_1.6.2-1_amd64.deb GiNaC symbolic framework runtime library
libgio-cil_2.22.3-2_all.deb CLI binding for the GIO I/O stack 2.22
libgio2.0-cil-dev_2.22.3-2_all.deb CLI binding for the GIO I/O stack 2.22
libgio3.0-cil-dev_2.99.3-2_amd64.deb CLI binding for GIO 2.24
libgio3.0-cil_2.99.3-2_amd64.deb CLI binding for the GIO libraries 2.24
libgirara-dev_0.2.3-1_amd64.deb library for minimalistic user interfaces (development files)
libgirara-doc_0.2.3-1_all.deb library for minimalistic user interfaces (documentation)
libgirara-gtk3-1_0.2.3-1_amd64.deb library for minimalistic user interfaces (shared libraries, GTK+ 3)
libgirepository-1.0-1_1.42.0-2.2_amd64.deb Library for handling GObject introspection data (runtime library)
libgirepository1.0-dev_1.42.0-2.2_amd64.deb Library for handling GObject introspection data (development files)
libgisi-dev_0.1.0-1_amd64.deb low-level communication library for ISI modems (devel files)
libgisi0_0.1.0-1_amd64.deb low-level communication library for ISI modems
libgisicomm-dev_0.1.0-1_amd64.deb high-level communication library for ISI modems (devel files)
libgisicomm0_0.1.0-1_amd64.deb high-level communication library for ISI modems
Advertisement
Advertisement