libgetopt-lucid-perl_1.05-1_all.deb


Advertisement

Description

libgetopt-lucid-perl - module for parsing command line arguments

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libgetopt-lucid-perl
Package version 1.05
Package release 1
Package architecture all
Package type deb
Installed size 122 B
Download size 31.74 KB
Official Mirror ftp.br.debian.org
Getopt::Lucid is a Perl module for parsing command line arguments, similar in
nature to Getopt::Long (in Perl core). The goal of this module is to provide
good code readability and clarity of intent, relying on plain-English option
specification as opposed to the more symbolic approach of Getopt::Long.

Alternatives

Package Version Architecture Repository
libgetopt-lucid-perl_1.05-1_all.deb 1.05 all Debian Main
libgetopt-lucid-perl - - -

Requires

Name Value
libexception-class-perl -
perl -

Download

Type URL
Binary Package libgetopt-lucid-perl_1.05-1_all.deb
Source Package libgetopt-lucid-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgetopt-lucid-perl deb package:
    # sudo apt-get install libgetopt-lucid-perl

Files

Path
/usr/share/doc/libgetopt-lucid-perl/Todo
/usr/share/doc/libgetopt-lucid-perl/changelog.Debian.gz
/usr/share/doc/libgetopt-lucid-perl/changelog.gz
/usr/share/doc/libgetopt-lucid-perl/copyright
/usr/share/doc/libgetopt-lucid-perl/examples/cpanget
/usr/share/man/man3/Getopt::Lucid.3pm.gz
/usr/share/man/man3/Getopt::Lucid::Exception.3pm.gz
/usr/share/perl5/Getopt/Lucid.pm
/usr/share/perl5/Getopt/Lucid/Exception.pm

Changelog

2013-10-05 - Florian Schlichting <fsfs@debian.org>
libgetopt-lucid-perl (1.05-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 1.05
* Bump year of upstream copyright
* Declare compliance with Debian Policy 3.9.4
* Add myself to uploaders and copyright
2012-03-06 - Fabrizio Regalli <fabreg@fabreg.it>
libgetopt-lucid-perl (1.01-1) unstable; urgency=low
* Imported Upstream version 1.01
* Bump Standards-Version to 3.9.3
* Added myself to Uploaders and Copyright
* Update copyright using copyright-format 1.0
* Sorted B-D-I
* Updated copyright year for main stanza
* Removed no more necessary spelling.patch patch:
the changes is included in source code
2011-12-11 - gregor herrmann <gregoa@debian.org>
libgetopt-lucid-perl (1.00-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* New upstream release.
* Update years of upstream copyright.
* Bump Standards-Version to 3.9.2 (no changes).
* Add /me to Uploaders.
* Make libexception-class-perl (build) dependency unversioned, nothing
older in the archive.
* Add a patch to fix a tiny spelling mistake.
2011-03-20 - Jonathan Yu <jawnsy@cpan.org>
libgetopt-lucid-perl (0.19-1) unstable; urgency=low
* Initial Release (Closes: #619037)

See Also

Package Description
libgetopt-mixed-perl_1.008-10_all.deb Perl module for processing options in GNU-style (= long and short)
libgetopt-ocaml-dev_0.0.20040811-10+b4_amd64.deb command line parsing library for OCaml
libgetopt-simple-perl_1.52-4_all.deb provide a simple wrapper around Getopt::Long
libgetopt-tabular-perl_0.3-2_all.deb table-driven argument parsing for Perl 5
libgetopt-usaginator-perl_0.0012-1_all.deb syntactic sugar for creating a command line usage function
libgettext-ant-tasks-java_0.9.7+svn206-1_all.deb Java classes for internationalization (i18n) - Ant tasks
libgettext-commons-java_0.9.6-2_all.deb Java classes for internationalization (i18n)
libgettext-ocaml-dev_0.3.4-1+b4_amd64.deb OCaml internationalization library
libgettext-ocaml_0.3.4-1+b4_amd64.deb OCaml internationalization shared library
libgettextpo-dev_0.19.3-2_amd64.deb GNU Internationalization library development files
libgettextpo0_0.19.3-2_amd64.deb GNU Internationalization library
libgexiv2-2_0.10.2-2_amd64.deb GObject-based wrapper around the Exiv2 library
libgexiv2-dev_0.10.2-2_amd64.deb GObject-based wrapper around the Exiv2 library - development files
libgf-complete-dev_1.0.2-1_amd64.deb Galois Field Arithmetic - development files
libgf-complete1_1.0.2-1_amd64.deb Galois Field Arithmetic - shared library
Advertisement
Advertisement