libgda-5.0-postgres - PostgreSQL provider for libgda database abstraction library

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libgda-5.0-postgres
Package version: 5.2.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 254 B
Download size: 63.84 KB
Official Mirror:
libgda is a (relatively small) database abstraction/access library integrated on the GLib object model. It can be used as a metadata extractor, to get information about all database objects in a common way, and as an ODBC-like wrapper to access data in different engines through an easier API. This package contains the provider needed to access PostgreSQL databases through libgda.



    Source package: libgda5

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libgda-5.0-postgres deb package:
      # sudo apt-get install libgda-5.0-postgres


    • /usr/lib/libgda-5.0/providers/
    • /usr/lib/pkgconfig/libgda-postgres-5.0.pc
    • /usr/share/doc/libgda-5.0-postgres


    2014-09-25 - Iain Lane <> libgda5 (5.2.2-2) unstable; urgency=medium * Install typelib file into MA libdir.

    2014-01-26 - Emilio Pozuelo Monfort <> libgda5 (5.2.2-1) unstable; urgency=low * New upstream release. + Fixes FTBFS with new gobject-introspection. Closes: #708806. * debian/libgda-5.0-4.symbols: + Add new symbols and remove some private symbols that are no longer exported. + Add Build-Depends-Package field. * debian/rules: + Pass -c4 to dh_makeshlibs. + Enable parallel builds, except for the test suite as it breaks otherwise. * debian/ + Bump Standards-Version to 3.9.4, no changes needed. + Update build-dependencies.

    2012-10-08 - Michael Biebl <> libgda5 (5.0.3-2) unstable; urgency=low [ Cyril Brulebois ] * Link the sqlite provider against sqlite3 (Closes: #667751). [ Michael Biebl ] * Use dh-autoreconf to update the build system. * Drop explicit Build-Depends on gir1.2-freedesktop and gir1.2-glib-2.0.

    2012-02-10 - Michael Biebl <> libgda5 (5.0.3-1) unstable; urgency=low * New upstream release. * Add symbols file for libgda-5.0-4.

    2012-01-04 - Michael Biebl <> libgda5 (5.0.2-2) unstable; urgency=low * Change section of gir1.2-gda-5.0 to introspection. * Update Build-Depends according to - Drop libpopt-dev, zlib1g-dev, scrollkeeper and sgmltools-lite. - Bump libglib2.0-dev to (>= 2.28.0). * Correctly build and install the gtk-doc API documentation. * Update all references to use /usr/share/doc/libgda-5.0-doc. * Suggest devhelp instead of depending on lynx | www-browser for libgda-5.0-doc. * Make test-suite failures fatal. It should pass on all archs now and we want to catch any regressions. * Use dh_python2 to deal with the python scripts in /usr/share/libgda-5.0/gda_trml2*.

    2012-01-03 - Sebastien Bacher <> libgda5 (5.0.2-1) unstable; urgency=low * New series, the packaging is based on the libgda4 one. * The initial update work was done by Murray Cumming on * The update doesn't include the work in progress on the previous series to get the ui components packaged, those are not required for a first upload * debian/watch: - the tarball are .xz [ Murray Cumming ] * Packaging libgda-5.0 * Remove debian/libgda-5.0-common.preinst because it is apparently now unnecessary. * Rename debian/libgda-5.0-doc.doc-base.libgda4-reference to debian/libgda-5.0-doc.doc-base.libgda5-reference and correct 4 to 5 in its contents. * debian/libgda-5.0-doc-install: Remove mentions of /usr/share/doc and /usr/share/doc-base which, for some reason, are no longer generated.

    2011-07-20 - Michael Biebl <> libgda4 (4.2.8-2) unstable; urgency=low * Rely on cdbs to call dh_girepository: - Bump Build-Depends on cdbs to (>= 0.4.90). - Remove custom dh_girepository rules from debian/rules. * debian/libgda-4.0-common.install - Don't install the sales_test.db test data file. * debian/libgda-4.0-common.preinst: - Cleanup /etc/libgda-4.0/sales_test.db on upgrades. * Upload to unstable, remove from debian/rules. * Move Gda-4.0.gir from gir1.2-gda-4.0 into libgda-4.0-dev and add the necessary Breaks/Replaces. * Install libgda-web provider and its corresponding .pc file. * debian/rules: - Be more specific which features we enable to get reliable builds in a tainted build environment. Explicitly disable ldap, gnome-keyring and GTK+ extension and tools support. - Trap errors in for loop using 'set -e'. - Bump shlibs version to (>= 4.2.8) for libgda-4.0-4.