libfuture-perl_0.29-1_all.deb


Advertisement

Description

libfuture-perl - module for operations awaiting completion

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libfuture-perl
Package version 0.29
Package release 1
Package architecture all
Package type deb
Installed size 178 B
Download size 58.84 KB
Official Mirror ftp.br.debian.org
A Future object represents an operation that is currently in progress, or
has recently completed. It can be used in a variety of ways to manage the
flow of control, and data, through an asynchronous program.
Some futures represent a single operation and are explicitly marked as ready
by calling the done or fail methods. These are called "leaf" futures here,
and are returned by the new constructor.
Other futures represent a collection sub-tasks, and are implicitly marked as
ready depending on the readiness of their component futures as required.
These are called "dependent" futures here, and are returned by the various
wait_* and need_* constructors.
It is intended that library functions that perform asynchonous operations
would use Future objects to represent outstanding operations, and allow their
calling programs to control or wait for these operations to complete. The
implementation and the user of such an interface would typically make use of
different methods on the class. The methods below are documented in two
sections; those of interest to each side of the interface.

Alternatives

Package Version Architecture Repository
libfuture-perl_0.29-1_all.deb 0.29 all Debian Main
libfuture-perl - - -

Requires

Name Value
perl >= 5.15.8

Download

Type URL
Binary Package libfuture-perl_0.29-1_all.deb
Source Package libfuture-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfuture-perl deb package:
    # sudo apt-get install libfuture-perl

Files

Path
/usr/share/doc/libfuture-perl/changelog.Debian.gz
/usr/share/doc/libfuture-perl/changelog.gz
/usr/share/doc/libfuture-perl/copyright
/usr/share/doc/libfuture-perl/examples/anyevent.pl
/usr/share/doc/libfuture-perl/examples/io-async.pl
/usr/share/doc/libfuture-perl/examples/poe.pl
/usr/share/man/man3/Future.3pm.gz
/usr/share/man/man3/Future::Phrasebook.3pm.gz
/usr/share/man/man3/Future::Utils.3pm.gz
/usr/share/man/man3/Test::Future.3pm.gz
/usr/share/perl5/Future.pm
/usr/share/perl5/Future/Phrasebook.pod
/usr/share/perl5/Future/Utils.pm
/usr/share/perl5/Test/Future.pm

Changelog

2014-07-19 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.29-1) unstable; urgency=medium
* New upstream release.
2014-06-13 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.28-1) unstable; urgency=medium
* New upstream release.
2014-06-07 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.27-1) unstable; urgency=medium
* New upstream release.
* (Build-)depend on perl >= 5.15.8 for Carp >= 1.25.
2014-06-06 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.26-1) unstable; urgency=medium
* New upstream release.
* Add a Breaks on old versions of libio-async-perl.
Other broken CPAN modules are not in Debian.
2014-02-28 - Salvatore Bonaccorso <carnil@debian.org>
libfuture-perl (0.25-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.25
2014-01-26 - Salvatore Bonaccorso <carnil@debian.org>
libfuture-perl (0.23-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.23
2014-01-14 - Salvatore Bonaccorso <carnil@debian.org>
libfuture-perl (0.22-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.22
* Update copyright years for upstream files
2014-01-01 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.21-1) unstable; urgency=medium
* New upstream release.
* Update years of packaging copyright.
2013-12-25 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.20-1) unstable; urgency=medium
* New upstream release.
* Declare compliance with Debian Policy 3.9.5.
2013-10-02 - gregor herrmann <gregoa@debian.org>
libfuture-perl (0.19-1) unstable; urgency=low
* New upstream release.
* Update years of packaging copyright.

See Also

Package Description
libfuzzy-dev_2.12-1_amd64.deb Recursive piecewise hashing tool (development headers)
libfuzzy2_2.12-1_amd64.deb Recursive piecewise hashing tool (library)
libfxt-dev_0.3.0-1_amd64.deb Multithreaded tracing library
libfxt0_0.3.0-1_amd64.deb Multithreaded tracing library
libfyba-dev_4.1.1-1_amd64.deb Header files for FYBA library
libfyba0_4.1.1-1_amd64.deb FYBA library to read and write norwegian geodata standard format SOSI
libg15-1_1.2.7-2_amd64.deb Library for interfacing with the Logitech G15 keyboards
libg15-dev_1.2.7-2_amd64.deb Library for interfacing with the Logitech G15 keyboards
libg15daemon-client-dev_1.9.5.3-8.3_amd64.deb Development packages for libg15daemon-client
libg15daemon-client1_1.9.5.3-8.3_amd64.deb Development packages for libg15daemon-client
libg15render-dev_1.3.0~svn316-2.3_amd64.deb Library for interfacing with the Logitech G15 keyboards
libg15render1_1.3.0~svn316-2.3_amd64.deb Library for interfacing with the Logitech G15 keyboards
libg2-dev_0.72-5+b1_amd64.deb g2 2D graphics library (development files)
libg20-perl_0.72-5+b1_amd64.deb g2 2D graphics library (Perl module)
libg20_0.72-5+b1_amd64.deb g2 2D graphics library
Advertisement
Advertisement