libfko-perl_2.6.0-2.1+b1_amd64.deb


Advertisement

Description

libfko-perl - FireWall KNock OPerator - Perl module

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libfko-perl
Package version 2.6.0
Package release 2.1+b1
Package architecture amd64
Package type deb
Installed size 200 B
Download size 47.97 KB
Official Mirror ftp.br.debian.org
The FireWall KNock OPerator implements an authorization scheme called
Single Packet Authorization (SPA), based on Netfilter and libpcap.
Its main application is to protect services such as OpenSSH with
an additional layer of security in order to make the exploitation of
vulnerabilities (both 0-day and unpatched code) much more difficult.
The authorization server passively listens for authorization packets via
libcap, so there is no service listening for network connections on the
traditional port. Access to a protected service is only granted after a
valid encrypted and non-replayed packet is detected.
This package provides the FKO module as a Perl interface.

Alternatives

Package Version Architecture Repository
libfko-perl_2.6.0-2.1+b1_i386.deb 2.6.0 i386 Debian Main
libfko-perl - - -

Requires

Name Value
libc6 >= 2.4
libfko2 = 2.6.0-2.1+b1
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libfko-perl_2.6.0-2.1+b1_amd64.deb
Source Package fwknop

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfko-perl deb package:
    # sudo apt-get install libfko-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/FKO.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/FKO_Constants.pl
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/FKO/FKO.so
/usr/share/doc/libfko-perl/NEWS.Debian.gz
/usr/share/doc/libfko-perl/changelog.Debian.amd64.gz
/usr/share/doc/libfko-perl/changelog.Debian.gz
/usr/share/doc/libfko-perl/changelog.gz
/usr/share/doc/libfko-perl/copyright
/usr/share/man/man3/FKO.3pm.gz

Changelog

2014-08-02 - gregor herrmann <gregoa@debian.org>
fwknop (2.6.0-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix "hardcodes /usr/lib/perl5":
Use $Config{vendorarch} in debian/rules.
(Closes: #752472)
2014-01-18 - Franck Joncourt <franck@debian.org>
fwknop (2.6.0-2) unstable; urgency=low
* Moved installation of usr.sbin/fwknopd from d.rules to 
fwknop-apparmor-profile.install file. (Closes: #735766)
* Added copyright stanza for android files in d.copyright
(Closes: #735668).
2014-01-13 - Franck Joncourt <franck@debian.org>
fwknop (2.6.0-1) unstable; urgency=low
* Imported Upstream version 2.6.0
* New fwknop-apparmor-profile package to provide the fwknop-server apparmor
profile.
- New entry in d.control to create the brand new binary package.
- Added BD on dh-apparmor.
- Updated d.rules to used dh_apparmor to manage developer scripts.
- Added fwknop-apparmor-profile.dirs file to create apparmor directory at
install.
- Added fwknop-apparmor-profile as suggested package for the fwknop server
in d.control.
* Bump up debian policy from 3.9.4 to 3.9.5:
- Removed dependencies on dpkg (>= 1.15.4) | install-info
2013-07-28 - Franck Joncourt <franck@debian.org>
fwknop (2.5.1-1) unstable; urgency=low
* Imported Upstream version 2.5.1
2013-07-23 - Franck Joncourt <franck@debian.org>
fwknop (2.5-1) unstable; urgency=low
* Imported Upstream version 2.5
- libfko breaks the old ABI. It is bumped from 1.0.0 up to 2.0.0
old packages libfko1* are renamed as libfko2*.
Updated d.rules to make reference to the new packages.
- Patch gpl2.0.diff applied upstream: Removed it from the patches
directory.
- New python binding
* The new upstream release add a m4 file to the m4 directory.
d.rules: assume the m4 directory is created ; no need to remove it in the
clean target and no need to create it in the configure target anymore.
* Fixed vcs fields in d.control to use the canonical URI.
(Caught by lintian).
* Fixed documentation spelling error (s/GNU Public/GNU General Public/g)
through a new patch 0001_fix-doc.patch.
* Removed useless depdencies default-mta | mail-transport-agent on
fwknop-server in d.rules.
* Used CFLAGS, CPPFLAGS and LDFLAGS variables to enable the hardening flags
to build the libfko-perl binding.
* Bumped up Standards-Version to 3.9.4 - no changes.
* Packaged the libfko python binding:
- d.control: Set X-Python-Version to >= 2.7 and added BD on python-all-dev
Defined the brand new libfko-python binding.
- d.rules: Used dh_python2 debhelper
Added new instances to build and install libfko-python
2013-05-19 - Franck Joncourt <franck@debian.org>
fwknop (2.0.4-2) unstable; urgency=low
* Fixed FTBS ./gpl-2.0.texi:20: raising the section level of @appendixsubsec
which is too low (Closes: #708589):
Added patch gpl-2.0.diff to substitute @appendixsubsec entries by
@appendixsec.

See Also

Package Description
libfko-python_2.6.0-2.1+b1_amd64.deb FireWall KNock OPerator - Python module
libfko2-dev_2.6.0-2.1+b1_amd64.deb FireWall KNock OPerator - developpement library
libfko2_2.6.0-2.1+b1_amd64.deb FireWall KNock OPerator - shared library
libfl-dev_2.5.39-8+deb8u2_amd64.deb static library for flex (a fast lexical analyzer generator)
libflac++-dev_1.3.0-3_amd64.deb Free Lossless Audio Codec - C++ development library
libflac++6_1.3.0-3_amd64.deb Free Lossless Audio Codec - C++ runtime library
libflac-dev_1.3.0-3_amd64.deb Free Lossless Audio Codec - C development library
libflac-doc_1.3.0-3_all.deb Free Lossless Audio Codec - library documentation
libflac-ocaml-dev_0.1.1-3+b1_amd64.deb OCaml interface to the flac library -- developpement files
libflac-ocaml_0.1.1-3+b1_amd64.deb OCaml interface to the flac library -- runtime files
libflac8_1.3.0-3_amd64.deb Free Lossless Audio Codec - runtime C library
libflake-dev_0.11-2_amd64.deb Alternative encoder for the Free Lossless Audio Codec -- Development files
libflamingo-java-doc_5.0-1_all.deb A Swing ribbon container for Java applications (documentation)
libflamingo-java_5.0-1_all.deb A Swing ribbon container for Java applications
libflann-dev_1.8.4-4.1_amd64.deb Fast Library for Approximate Nearest Neighbors - development
Advertisement
Advertisement