libfinance-bank-ie-permanenttsb-perl - perl interface to the PermanentTSB Open24 homebanking

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libfinance-bank-ie-permanenttsb-perl
Package version: 0.4
Package release: 2
Package architecture: all
Package type: deb
Installed size: 140 B
Download size: 28.33 KB
Official Mirror:
Finance::Bank::IE::PermanentTSB provides a set of functions which can be used in perl programs to interact with the Open24 homebanking ( The module will allow the user to check the account balance and to display an account statement for a particular time range. This package also includes a CLI tool (ptsb), which will provide the same functionalities of the module and will also use gnuplot to draw graphs about the status of a bank account.


    Source package: libfinance-bank-ie-permanenttsb-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libfinance-bank-ie-permanenttsb-perl deb package:
      # sudo apt-get install libfinance-bank-ie-permanenttsb-perl


    • /usr/bin/ptsb
    • /usr/share/doc/libfinance-bank-ie-permanenttsb-perl/changelog.Debian.gz
    • /usr/share/doc/libfinance-bank-ie-permanenttsb-perl/changelog.gz
    • /usr/share/doc/libfinance-bank-ie-permanenttsb-perl/copyright
    • /usr/share/man/man1/ptsb.1p.gz
    • /usr/share/man/man3/Finance::Bank::IE::PermanentTSB.3pm.gz
    • /usr/share/man/man3/ptsb_util.3pm.gz
    • /usr/share/perl5/
    • /usr/share/perl5/Finance/Bank/IE/
    • /usr/share/perl5/Finance/Bank/IE/templates/


    2011-06-18 - gregor herrmann <> libfinance-bank-ie-permanenttsb-perl (0.4-2) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ gregor herrmann ] * (Build-)Depend on libswitch-perl, Switch is not in core in 5.14 (closes: #629459). * Switch to source format 3.0 (quilt). * Use tiny debian/rules file. * Set Standards-Version to 3.9.2 (no changes). * Bump debhelper compatibility level to 8. * Add /me to Uploaders. * debian/copyright: update formatting.

    2009-03-08 - Antonio Radici <> libfinance-bank-ie-permanenttsb-perl (0.4-1) unstable; urgency=low * New upstream release * debian/patches/*: + removal of the entire directory because fix-pod-errors was incorporated upstream * debian/rules: removal of quilt dependency * debian/watch + removed because upstream incorporate our suggestions * debian/copyright: removed notice for * debian/control: + added libtest-mockobject-perl, libwww-mechanize-perl and libdate-calc-perl dependencies

    2009-01-31 - Antonio Radici <> libfinance-bank-ie-permanenttsb-perl (0.2+dfsg.1-1) unstable; urgency=low * Initial Release. (Closes: #513699)