libfile-sync-perl_0.11-2+b1_amd64.deb


Advertisement

Description

libfile-sync-perl - Perl interface to sync() and fsync()

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libfile-sync-perl
Package version 0.11
Package release 2+b1
Package architecture amd64
Package type deb
Installed size 85 B
Download size 11.39 KB
Official Mirror ftp.br.debian.org
File::Sync provides Perl interfaces to the Unix sync(2) and POSIX.1b fsync(2)
system calls. The fsync() call is needed for putting messages into qmail
maildirs, and sync() is included for completeness.

Alternatives

Package Version Architecture Repository
libfile-sync-perl_0.11-2+b1_i386.deb 0.11 i386 Debian Main
libfile-sync-perl - - -

Requires

Name Value
libc6 >= 2.2.5
perl >= 5.20.0-4
perlapi-5.20.0 -

Download

Type URL
Binary Package libfile-sync-perl_0.11-2+b1_amd64.deb
Source Package libfile-sync-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfile-sync-perl deb package:
    # sudo apt-get install libfile-sync-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/File/Sync.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/File/Sync/Sync.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/File/Sync/autosplit.ix
/usr/share/doc/libfile-sync-perl/README
/usr/share/doc/libfile-sync-perl/changelog.Debian.amd64.gz
/usr/share/doc/libfile-sync-perl/changelog.Debian.gz
/usr/share/doc/libfile-sync-perl/changelog.gz
/usr/share/doc/libfile-sync-perl/copyright
/usr/share/man/man3/File::Sync.3pm.gz

Changelog

2014-04-13 - Florian Schlichting <fsfs@debian.org>
libfile-sync-perl (0.11-2) unstable; urgency=low
* Team upload
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Switch dh compatibility to level 9 to enable passing of hardening flags
* Declare compliance with Debian Policy 3.9.5
2011-11-26 - gregor herrmann <gregoa@debian.org>
libfile-sync-perl (0.11-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser
field (source stanza); Homepage field (source stanza). Removed: XS-
Vcs-Svn fields.
* debian/watch: use dist-based URL.
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Joachim Breitner ]
* Removed myself from uploaders.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* New upstream release.
* Switch to "3.0 (quilt)" source format.
* Use debhelper 8 and short debian/rules file.
* Reformat debian/copyright.
* Mention module name in long description.
* Bump Standards-Version to 3.9.2; remove version from perl build
dependency.
* Add /me to Uploaders.
* debian/control: remove duplicate fields.
2004-10-08 - Joachim Breitner <nomeata@debian.org>
libfile-sync-perl (0.09-4) unstable; urgency=low
* Fixed section
2004-10-08 - Joachim Breitner <nomeata@debian.org>
libfile-sync-perl (0.09-3) unstable; urgency=low
* Acknowledge NMU (Closes: 158560)
* Adopted by Debian Perl Group (Closes: 274129)
2002-08-28 - Colin Watson <cjwatson@debian.org>
libfile-sync-perl (0.09-2.1) unstable; urgency=low
* NMU for perl 5.8.
* Build-depend on perl (>= 5.8.0-7). Since there was no Build-Depends:
line beforehand, complete it by mentioning debhelper too.
2001-02-24 - Michael Alan Dorman <mdorman@debian.org>
libfile-sync-perl (0.09-2) unstable; urgency=low
* Updated for new perl policy (closes: bug#80652)
2000-02-02 - Michael Alan Dorman <mdorman@debian.org>
libfile-sync-perl (0.09-1) frozen unstable; urgency=low
* New upstream version, fixes perl 5.005 incompatability (closes: bug#55879)
1999-08-09 - Michael Alan Dorman <mdorman@debian.org>
libfile-sync-perl (0.07-1) unstable; urgency=low
* New upstream version.
1999-07-11 - Michael Alan Dorman <mdorman@debian.org>
libfile-sync-perl (0.06-4) unstable; urgency=low
* Too stupid to get binary-arch stuff in right place. (closes: bug#40971)
1999-07-05 - Michael Alan Dorman <mdorman@debian.org>
libfile-sync-perl (0.06-3) unstable; urgency=low
* Corrected lack of binary dependency.
* Modified for new perl packages.
* Modified to use debhelper.

See Also

Package Description
libfile-tail-perl_0.99.3-5_all.deb File::Tail perl module
libfile-tee-perl_0.07-1_all.deb Perl module to duplicate streams like the tee unix command
libfile-touch-perl_0.09-1_all.deb Perl interface to touch-like functions
libfile-type-perl_0.22-2_all.deb module to determine file type using magic structure
libfile-type-webimages-perl_1.01-1_all.deb tool for determining web image file types using magic
libfile-userconfig-perl_0.06-2_all.deb provides configuration directory for applications
libfile-util-perl_4.132140-1_all.deb Perl extension to handle files easily
libfile-which-perl_1.09-1_all.deb Perl module for searching paths for executable programs
libfile-wildcard-perl_0.11-2_all.deb Enhanced glob processing
libfile-write-rotate-perl_0.22-1_all.deb module to deal with files that archive/rotate themselves
libfile-zglob-perl_0.11-1_all.deb extended globs
libfilehandle-fmode-perl_0.14-1+b1_amd64.deb Perl module for checking filehandle status
libfilehandle-unget-perl_0.1623-1_all.deb Perl module that allows ungetting of multiple bytes
libfilesys-df-perl_0.92-5+b1_amd64.deb Module to obtain filesystem disk space information
libfilesys-diskspace-perl_0.05-16_all.deb fetch filesystem size and usage information from Perl
Advertisement
Advertisement