libfile-changenotify-perl_0.24-1_all.deb


Advertisement

Description

libfile-changenotify-perl - module to monitor files for changes

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libfile-changenotify-perl
Package version 0.24
Package release 1
Package architecture all
Package type deb
Installed size 113 B
Download size 36.64 KB
Official Mirror ftp.br.debian.org
File::ChangeNotify is a Perl module that provides a way to monitor files for
changes in an efficient and cross-platform manner. Developers can override
the default mechanism by subclassing the included File::ChangeNotify::Watcher
module, allowing for platform-specific optimizations.

Alternatives

Package Version Architecture Repository
libfile-changenotify-perl_0.24-1_all.deb 0.24 all Debian Main
libfile-changenotify-perl - - -

Requires

Name Value
libclass-load-perl -
liblist-moreutils-perl -
libmodule-pluggable-perl -
libmoose-perl -
libmoosex-params-validate-perl -
libmoosex-semiaffordanceaccessor-perl -
libnamespace-autoclean-perl -
perl << 5.17.0
perl -

Download

Type URL
Binary Package libfile-changenotify-perl_0.24-1_all.deb
Source Package libfile-changenotify-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfile-changenotify-perl deb package:
    # sudo apt-get install libfile-changenotify-perl

Files

Path
/usr/share/doc/libfile-changenotify-perl/changelog.Debian.gz
/usr/share/doc/libfile-changenotify-perl/changelog.gz
/usr/share/doc/libfile-changenotify-perl/copyright
/usr/share/man/man3/File::ChangeNotify.3pm.gz
/usr/share/man/man3/File::ChangeNotify::ConfigData.3pm.gz
/usr/share/man/man3/File::ChangeNotify::Event.3pm.gz
/usr/share/man/man3/File::ChangeNotify::Watcher.3pm.gz
/usr/share/man/man3/File::ChangeNotify::Watcher::Default.3pm.gz
/usr/share/man/man3/File::ChangeNotify::Watcher::Inotify.3pm.gz
/usr/share/man/man3/File::ChangeNotify::Watcher::KQueue.3pm.gz
/usr/share/perl5/File/ChangeNotify.pm
/usr/share/perl5/File/ChangeNotify/ConfigData.pm
/usr/share/perl5/File/ChangeNotify/Event.pm
/usr/share/perl5/File/ChangeNotify/Watcher.pm
/usr/share/perl5/File/ChangeNotify/Watcher/Default.pm
/usr/share/perl5/File/ChangeNotify/Watcher/Inotify.pm
/usr/share/perl5/File/ChangeNotify/Watcher/KQueue.pm

Changelog

2013-11-29 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.24-1) unstable; urgency=low
* Imported Upstream version 0.24
* Wrap and sort fields in debian/control file
* Bump Standards-Version to 3.9.5
2013-08-15 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.23-2) unstable; urgency=low
* Adjust (build-)dependency for Module::Pluggable.
Module::Pluggable will be removed from Perl core in 5.20 and emits now
a warning with 5.18. Add Build-Depends-Indep and Depends on alternate
libmodule-pluggable-perl | perl (<< 5.17.0).
Thanks to Dominic Hargreaves <dom@earth.li> (Closes: #711662)
2013-05-17 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.23-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.23
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
* Make Recommends on liblinux-inotify2-perl unversioned.
Versioned Recommends on liblinux-inotify2-perl (>= 1:1.2) is now already
satisfied in stable.
* Update debian/copyright information.
Update copyright years for upstram files and for debian/* packaging
files.
* Bump Standards-Version to 3.9.4
2012-04-14 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.22-1) unstable; urgency=low
* Imported Upstream version 0.22
* Update debian/copyright file format.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
* Bump Standards-Version to 3.9.3
2012-02-03 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.21-1) unstable; urgency=low
[ gregor herrmann ]
* Switch order of alternative (build) dependencies after the perl 5.12
upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Imported Upstream version 0.21
* Update debian/copyright file.
Update copyright years for upstream files and for debian/* packaging
files.
* Adjust (Build-)Depends(-Indep)
Substitute alternate dependencies on libmoose-perl (>= 2) |
libclass-mop-perl with libclass-load-perl as Class::Load is used now.
Add liblist-moreutils-perl to Build-Depends-Indep.
Change versioned dependencies on libmoosex-params-validate-perl to
unversioned dependencies.
Drop alternate Build-Depends-Indep on perl (>= 5.10.1) |
libtest-simple-perl (>= 0.88).
2011-04-21 - gregor herrmann <gregoa@debian.org>
libfile-changenotify-perl (0.20-2) unstable; urgency=low
* Team upload.
* debian/control: update (build) dependencies to prepare for
Moose/Class::MOP changes.
2011-04-20 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.20-1) unstable; urgency=low
* New upstream release
* Bump Debhelper compat level to 8.
* debian/control:
- Bump versioned Build-Depends on debhelper to (>= 8).
- Add Build-Depends on ibmodule-build-perl (>= 0.360100) | perl
(>= 5.12.0).
* debian/copyright: Update copyright years for upstream stanza.
* Email change: Salvatore Bonaccorso -> carnil@debian.org
* Bump Standards-Version to 3.9.2.
2010-10-18 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.19-1) unstable; urgency=low
* New upstream release
2010-10-16 - Salvatore Bonaccorso <carnil@debian.org>
libfile-changenotify-perl (0.18-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release (0.17)
* Standards-Version 3.9.1 (no changes)
[ Salvatore Bonaccorso ]
* New upstream release (0.18)
* Update my email address.
* debian/control: Drop alternate (Build-)Depends(-Indep) on perl (>=
5.10.0) | libmodule-pluggable-perl as this is already satisfied in
stable and oldstable is gone.

See Also

Package Description
libfile-chdir-perl_0.1008-1_all.deb more sensible way to change directories
libfile-checktree-perl_4.42-1_all.deb module for running many filetest checks on a tree
libfile-chmod-perl_0.40-1_all.deb chmod() override with symbolic and ls-style modes
libfile-configdir-perl_0.013-1_all.deb get directories of configuration files
libfile-copy-link-perl_0.140-1_all.deb Perl extension for replacing a link by a copy of the linked file
libfile-copy-recursive-perl_0.38-1_all.deb Perl extension for recursively copying files and directories
libfile-counterfile-perl_1.04-5_all.deb persistent counter class for Perl
libfile-countlines-perl_0.0.3-1_all.deb module for efficiently counting the number of lines in a file
libfile-data-perl_1.16-3_all.deb interface to file data
libfile-desktopentry-perl_0.07-1_all.deb Perl module to handle freedesktop .desktop files
libfile-dircompare-perl_0.7-1_all.deb Perl module to compare two directories
libfile-extattr-perl_1.09-4+b1_amd64.deb Perl interface to file system extended attributes
libfile-fcntllock-perl_0.22-1+b1_amd64.deb Perl module for file locking with fcntl(2)
libfile-find-object-perl_0.2.9-1_all.deb object oriented File::Find replacement
libfile-find-object-rule-perl_0.0305-1_all.deb alternative interface to File::Find::Object
Advertisement
Advertisement