libexception-class-perl_1.38-1_all.deb


Advertisement

Description

libexception-class-perl - module that allows you to declare real exception classes in Perl

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libexception-class-perl
Package version 1.38
Package release 1
Package architecture all
Package type deb
Installed size 94 B
Download size 29.46 KB
Official Mirror ftp.br.debian.org
Exception::Class allows you to declare exceptions in your modules in a
manner similar to how exceptions are declared in Java.
It features a simple interface allowing programmers to 'declare'
exception classes at compile time.  It also has a base exception
class, Exception::Class::Base, that can be used for classes stored in
files (aka modules ;) ) that are subclasses.
It is designed to make structured exception handling simpler and
better by encouraging people to use hierarchies of exceptions in their
applications.

Alternatives

Package Version Architecture Repository
libexception-class-perl_1.38-1_all.deb 1.38 all Debian Main
libexception-class-perl - - -

Requires

Name Value
libclass-data-inheritable-perl -
libdevel-stacktrace-perl -
perl -

Download

Type URL
Binary Package libexception-class-perl_1.38-1_all.deb
Source Package libexception-class-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libexception-class-perl deb package:
    # sudo apt-get install libexception-class-perl

Files

Path
/usr/share/doc/libexception-class-perl/changelog.Debian.gz
/usr/share/doc/libexception-class-perl/changelog.gz
/usr/share/doc/libexception-class-perl/copyright
/usr/share/man/man3/Exception::Class.3pm.gz
/usr/share/man/man3/Exception::Class::Base.3pm.gz
/usr/share/perl5/Exception/Class.pm
/usr/share/perl5/Exception/Class/Base.pm

Changelog

2014-05-05 - gregor herrmann <gregoa@debian.org>
libexception-class-perl (1.38-1) unstable; urgency=medium
* New upstream release.
* Strip trailing slash from metacpan URLs.
* Update years of copyright.
* Declare compliance with Debian Policy 3.9.5.
2013-09-30 - gregor herrmann <gregoa@debian.org>
libexception-class-perl (1.37-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update copyright years and upstream license.
* Declare compliance with Debian Policy 3.9.4.
2012-05-11 - gregor herrmann <gregoa@debian.org>
libexception-class-perl (1.32-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Update my email address.
* debian/control: Convert Vcs-* fields to Git.
[ Fabrizio Regalli ]
* Bump to 3.9.2 Standard-Version.
* Add myself to Uploaders and Copyright.
* Switch d/compat to 8.
* Build-Depends: switch to debhelper (>= 8).
* Fixed lintian copyright-refers-to-symlink-license message.
[ gregor herrmann ]
* debian/copyright: update to Copyright-Format 1.0.
* Bump Standards-Version to 3.9.3 (no changes).
2010-06-28 - Ansgar Burchardt <ansgar@43-1.org>
libexception-class-perl (1.31-1) unstable; urgency=low
[ Ansgar Burchardt ]
* New upstream release.
* Drop patch typo.patch: applied upstream.
* debian/copyright: Update years of copyright.
[ gregor herrmann ]
* debian/copyright: update license information.
2010-03-22 - Ansgar Burchardt <ansgar@43-1.org>
libexception-class-perl (1.30-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* New upstream release.
+ Add build-dep on perl (>= 5.10.1) | libtest-more-perl (>= 0.88).
+ Remove build-dep on libtest-pod-perl, libtest-pod-coverage-perl:
Tests moved to xt/ upstream.
* Use source format 3.0 (quilt).
* Correct a typo in the documentation.
+ new patch: typo.patch
* Make (build-)dep on perl unversioned.
* Use minimal debian/rules.
* Bump Standards-Version to 3.8.4.
[ gregor herrmann ]
* debian/copyright: update formatting.
2009-05-09 - Ansgar Burchardt <ansgar@43-1.org>
libexception-class-perl (1.29-1) unstable; urgency=low
* New upstream release.
+ depends on perl (>= 5.8.1)
* Bump Standards Version to 3.8.1 (no changes)
2009-02-16 - Ansgar Burchardt <ansgar@43-1.org>
libexception-class-perl (1.26-2) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Ansgar Burchardt ]
* Depend on libdevel-stacktrace-perl (>= 1.2000) instead of (>= 1.20).
Closes: #515594.
* Add myself to Uploaders.
2008-11-01 - Jose Luis Rivas <ghostbar38@gmail.com>
libexception-class-perl (1.26-1) unstable; urgency=low
[ Jose Luis Rivas ]
* New upstream release
* debian/control: 
+ Bumped to Standards-Version 3.8.0 (no changes needed).
+ Bumped dependencies to minimium required versions.
[ gregor herrmann ]
* debian/control:
- change my email address
- wrap a long line
- remove libmodule-build-perl, debhelper7 prefers MakeMaker
- remove leading article and spurious space from short description
* Set debhelper compatibility level to 7; adapt
debian/{control,compat,rules}.
* debian/copyright: switch to new format.

See Also

Package Description
libexception-class-trycatch-perl_1.13-1_all.deb syntactic try/catch sugar for use with Exception::Class
libexception-handler-perl_1.004-1_all.deb perl module Exception::Handler
libexchangemapi-1.0-0_3.12.7-2_amd64.deb client library for accessing Exchange servers - runtime
libexchangemapi-1.0-dev_3.12.7-2_amd64.deb client library for accessing Exchange servers - development
libexempi-dev_2.2.1-2_amd64.deb library to parse XMP metadata (Development files)
libexempi3_2.2.1-2_amd64.deb library to parse XMP metadata (Library)
libexene-smlnj_110.76-2_amd64.deb Concurrent ML library for the X Window System
libexif-dev_0.6.21-2_amd64.deb library to parse EXIF files (development files)
libexif-gtk-dev_0.3.5-5_amd64.deb Library providing GTK+ widgets to display/edit EXIF tags (development files)
libexif-gtk5_0.3.5-5_amd64.deb Library providing GTK+ widgets to display/edit EXIF tags
libexif12_0.6.21-2_amd64.deb library to parse EXIF files
libexiv2-13_0.24-4.1_amd64.deb EXIF/IPTC metadata manipulation library
libexiv2-dev_0.24-4.1_amd64.deb EXIF/IPTC metadata manipulation library - development files
libexiv2-doc_0.24-4.1_all.deb EXIF/IPTC metadata manipulation library - HTML documentation
libexml-java_0.0.20080703-4_all.deb e-xml parsing library for java
Advertisement
Advertisement