libevocosm-4.0-4_4.0.2-3_amd64.deb


Advertisement

Description

libevocosm-4.0-4 - C++ framework for developing evolutionary algorithms

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libevocosm-4.0-4
Package version 4.0.2
Package release 3
Package architecture amd64
Package type deb
Installed size 114 B
Download size 33.01 KB
Official Mirror ftp.br.debian.org
This library provides a framework for programming a wide variety of
evolutionary algorithms, ranging from genetic algorithms to agent
simulations. Evocosm is the foundation for Acovea

Alternatives

Package Version Architecture Repository
libevocosm-4.0-4_4.0.2-3_i386.deb 4.0.2 i386 Debian Main
libevocosm-4.0-4 - - -

Requires

Name Value
libbrahe-1.3-3 >= 1.3.2
libc6 >= 2.2.5
libgcc1 >= 1:4.1.1
libstdc++6 >= 4.4.0

Download

Type URL
Binary Package libevocosm-4.0-4_4.0.2-3_amd64.deb
Source Package libevocosm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libevocosm-4.0-4 deb package:
    # sudo apt-get install libevocosm-4.0-4

Files

Path
/usr/lib/libevocosm-4.0.so.4
/usr/lib/libevocosm-4.0.so.4.0.0
/usr/share/doc/libevocosm-4.0-4/changelog.Debian.gz
/usr/share/doc/libevocosm-4.0-4/changelog.gz
/usr/share/doc/libevocosm-4.0-4/copyright

Changelog

2012-07-07 - Al Stone <ahs3@debian.org>
libevocosm (4.0.2-3) unstable; urgency=low
* Acknowledgement for the NMU. Changes incorporated into package.
* Updated Standards-Version
* Fixes for hardening during build (lintian errors)
* Closes: Bug#662397 -- depend on libpng-dev, not libpng12-dev
* Closes: Bug#678681 -- no longer FTBFS with --as-needed linker option
2012-05-14 - gregor herrmann <gregoa@debian.org>
libevocosm (4.0.2-2.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS: dpkg-source: error: aborting due to unexpected upstream
changes": handle config.{guess,sub} with autotools-dev helpers.
(Closes: #661500)
* Fix "-dev library is broken": add patch vector.patch from Vincent Legout.
(Closes: #658577)
* Fix "ftbfs with GCC-4.7": add patch fix-ftbfs-gcc4.7.diff from Matthias
Klose (missing <unistd.h> include).
(Closes: #667244)
* debian/rules: fix -stamp filename.
2012-01-27 - Al Stone <ahs3@debian.org>
libevocosm (4.0.2-2) unstable; urgency=low
* Acknowledgment for the NMU.  Incorporated changes into package. 
2011-12-23 - Ansgar Burchardt <ansgar@debian.org>
libevocosm (4.0.2-1.1) unstable; urgency=low
* Non-maintainer upload.
* Add build-dependencies on autoconf, automake, libtool. (Closes: #650531)
* libevocosm-dev: Add dependency on libbrahe-dev. (Closes: #652151)
2011-11-28 - Al Stone <ahs3@debian.org>
libevocosm (4.0.2-1) unstable; urgency=low
* New upstream. 
* Remove debian/* that should not have been included.
* Convert to source format 3.0 (quilt).
* Update debhelper compatibility.
* Repair entries in *.la files.
* Add back in doxygen usage from 3.3.0.
* Lintian: add Section field for source.
* Lintian: debhelper needs ${misc:Depends}
* Lintian: no need for virtual package c++abi2-dev
* Lintian: update standards version
* Lintian: description should not start with an article ('a', in this case)
* Incorporate Ubuntu patch to configure only once.  Closes: Bug#641703.
* Ubuntu patch also provides for reconf.  Closes: Bug#641385.
* New upstream no longer has unresolved symbols.  Closes: Bug#558884.
* Thanks for the NMU (3.1.0-3.1).
2007-11-25 - Al Stone <ahs3@debian.org>
libevocosm (3.3.0-1) unstable; urgency=low
* Update to latest upstream (3.3.0)
* Clean up assorted lintian problems
2008-03-22 - Moritz Muehlenhoff <jmm@debian.org>
libevocosm (3.1.0-3.1) unstable; urgency=low
* Non-maintainer upload.
* Fix GCC 4.3 compatibility, patch by Cyril Brulebois (Closes: #454832)
2005-11-26 - Al Stone <ahs3@debian.org>
libevocosm (3.1.0-3) unstable; urgency=low
* Cleaning up shlibs file contents. 
2005-11-21 - Al Stone <ahs3@debian.org>
libevocosm (3.1.0-2) unstable; urgency=low
* Added in proper Conflicts/Replaces statements 
2005-11-21 - Al Stone <ahs3@debian.org>
libevocosm (3.1.0-1) unstable; urgency=low
* New upstream.

See Also

Package Description
libevocosm-dev_4.0.2-3_amd64.deb C++ framework for developing evolutionary algorithms
libevolution_3.12.9~git20141130.241663-1+b1_amd64.deb evolution libraries
libevs-dev_1.4.6-1.1_amd64.deb Standards-based cluster framework, Evs devel files
libevs4_1.4.6-1.1_amd64.deb Standards-based cluster framework, Evs library
libevtlog-dev_0.2.12-6_amd64.deb Syslog event logger library development files
libevtlog0_0.2.12-6_amd64.deb Syslog event logger library
libevview3-3_3.14.1-2+deb8u2_amd64.deb Document (PostScript, PDF) rendering library - Gtk+ widgets
libewf-dev_20140608-2_amd64.deb support for Expert Witness Compression format (development)
libewf2_20140608-2_amd64.deb library with support for Expert Witness Compression Format
libex-monkeypatched-perl_0.03-1_all.deb experimental API for safe monkey-patching
libexactimage-perl_0.8.9-7+deb8u2_amd64.deb fast image manipulation library (Perl bindings)
libexcalibur-logger-java_2.1-6_all.deb Excalibur project's log management system
libexcalibur-logkit-java-doc_2.0-11_all.deb Lightweight and fast designed logging toolkit for Java (API docs)
libexcalibur-logkit-java_2.0-11_all.deb Lightweight and fast designed logging toolkit for Java
libexcel-template-perl_0.34-1_all.deb Perl module for templating Excel files
Advertisement
Advertisement