libenv-path-perl - Perl module implementing advanced operations on path variables

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libenv-path-perl
Package version: 0.19
Package release: 1
Package architecture: all
Package type: deb
Installed size: 87 B
Download size: 21.45 KB
Official Mirror:
Env::Path presents an object-oriented interface to path variables, defined as that subclass of environment variables which name an ordered list of filesystem elements separated by a platform-standard separator. Env::Path is for cases where you need to insert or remove interior path entries, strip redundancies, operate on a path variable without having to know whether the current platform uses ":" or ";", operate on a path variable which may have a different name on different platforms, etc.




    Source package: libenv-path-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libenv-path-perl deb package:
      # sudo apt-get install libenv-path-perl


    • /usr/bin/envpath
    • /usr/share/doc/libenv-path-perl/changelog.Debian.gz
    • /usr/share/doc/libenv-path-perl/changelog.gz
    • /usr/share/doc/libenv-path-perl/copyright
    • /usr/share/doc/libenv-path-perl/examples/Whence
    • /usr/share/man/man1/envpath.1p.gz
    • /usr/share/man/man3/Env::Path.3pm.gz
    • /usr/share/perl5/Env/


    2013-06-29 - Salvatore Bonaccorso <> libenv-path-perl (0.19-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Email change: Salvatore Bonaccorso -> [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Imported Upstream version 0.19 * Change Vcs-Git to canonical URI (git:// * Change based URIs to based URIs * Convert to '3.0 (quilt)' source package format * Update debian/copyright file information. Update format to copyright-format 1.0 as released together with Debian policy 3.9.3. Update copyright years for debian/* packaging files. Refer to Debian systems in general instead of only Debian GNU/Linux systems. Explicity refer to GPL-1 license text included in common-licenses. * Bump Standards-Version to 3.9.4 * Update Debhelper compat level to 8. Adjust versioned Build-Depends on debhelper to (>= 8).

    2009-12-11 - Salvatore Bonaccorso <> libenv-path-perl (0.18-1) unstable; urgency=low * Initial Release. (Closes: #560279)