libdisruptor-java_3.3.0-2_all.deb


Advertisement

Description

libdisruptor-java - Disruptor - High Performance Inter-Thread Messaging Library for Java

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libdisruptor-java
Package version 3.3.0
Package release 2
Package architecture all
Package type deb
Installed size 137 B
Download size 72.84 KB
Official Mirror ftp.br.debian.org
The disruptor is a high-throughput and low-latency concurrency framework.
It is designed to maximize the efficiency of memory allocation, and operate
in a cache-friendly manner so that it will perform optimally on modern
hardware.
At the heart of the disruptor mechanism sits a pre-allocated bounded data
structure in the form of a ring-buffer. Data is added to the ring buffer
through one or more producers and processed by one or more consumers.

Alternatives

Package Version Architecture Repository
libdisruptor-java_3.3.0-2_all.deb 3.3.0 all Debian Main
libdisruptor-java - - -

Download

Type URL
Binary Package libdisruptor-java_3.3.0-2_all.deb
Source Package disruptor

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdisruptor-java deb package:
    # sudo apt-get install libdisruptor-java

Files

Path
/usr/share/doc/libdisruptor-java/changelog.Debian.gz
/usr/share/doc/libdisruptor-java/changelog.gz
/usr/share/doc/libdisruptor-java/copyright
/usr/share/java/disruptor-3.3.0.jar
/usr/share/java/disruptor.jar
/usr/share/maven-repo/com/lmax/disruptor/3.3.0/disruptor-3.3.0.jar
/usr/share/maven-repo/com/lmax/disruptor/3.3.0/disruptor-3.3.0.pom
/usr/share/maven-repo/com/lmax/disruptor/debian/disruptor-debian.jar
/usr/share/maven-repo/com/lmax/disruptor/debian/disruptor-debian.pom

Changelog

2014-07-28 - Emmanuel Bourg <ebourg@apache.org>
disruptor (3.3.0-2) unstable; urgency=medium
* New upstream release
* Updated debian/pom.xml
2014-03-19 - Emmanuel Bourg <ebourg@apache.org>
disruptor (3.2.1-1) unstable; urgency=medium
* New upstream release
* Updated debian/pom.xml
2014-01-22 - Emmanuel Bourg <ebourg@apache.org>
disruptor (3.2.0-1) unstable; urgency=medium
* Initial release (Closes: #736354)

See Also

Package Description
libdist-checkconflicts-perl_0.11-1_all.deb module for declaring version conflicts for a distribution
libdist-inkt-doap-perl_0.022-1_all.deb various DOAP-related roles for Dist::Inkt
libdist-inkt-perl_0.023-2_all.deb yet another distribution builder
libdist-inkt-profile-tobyink-perl_0.023-1_all.deb Dist::Inkt profile for TOBYINK
libdist-inkt-role-hg-perl_0.004-1_all.deb Mercurial-related behaviour for Dist::Inkt
libdist-inkt-role-release-perl_0.004-1_all.deb automatically upload a distribution to the CPAN
libdist-inkt-role-test-kwalitee-perl_0.002-1_all.deb check a distribution's kwalitee at build time
libdist-inkt-role-test-perl_0.002-1_all.deb run various tests on a distribution at build time
libdist-metadata-perl_0.925-1_all.deb module for getting information about a perl module distribution
libdist-zilla-app-command-cover-perl_1.101001-1_all.deb Run Devel::Cover from within Dist::Zilla
libdist-zilla-localetextdomain-perl_0.90-1_all.deb Dist::Zilla plugin that adds support for managing l10n and i18n in Perl modules
libdist-zilla-perl_5.020-1_all.deb Perl distribution builder
libdist-zilla-plugin-changelogfromgit-perl_0.016-1_all.deb Dist::Zilla plugin to build a Changes file from a project's git log
libdist-zilla-plugin-config-git-perl_0.92-1_all.deb Dist::Zilla Git plugin configuration settings module
libdist-zilla-plugin-git-perl_2.025-1_all.deb Dist::Zilla plugins to update your git repository after release
Advertisement
Advertisement