libdevil-dev_1.7.8-9+b1_amd64.deb


Advertisement

Description

libdevil-dev - Cross-platform image loading and manipulation toolkit

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libdevil-dev
Package version: 1.7.8
Package release: 9+b1
Package architecture: amd64
Package type: deb
Installed size: 1.13 KB
Download size: 260.89 KB
Official Mirror: ftp.br.debian.org
Developer's Image Library (DevIL) is a programmer's toolkit which can load, save and convert a wide variety of image formats. It also offers basic manipulation and filtering capabilities. DevIL presents a simple programming interface similar to OpenGL's, which is easy for a developer to learn and use. Ultimate control of the images is left to the developer. This package contains the development files.

Alternatives

    Download

    Source package: devil

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libdevil-dev deb package:
      # sudo apt-get install libdevil-dev

    Files

    • /usr/include/IL/devil_cpp_wrapper.hpp
    • /usr/include/IL/il.h
    • /usr/include/IL/ilu.h
    • /usr/include/IL/ilu_region.h
    • /usr/include/IL/ilut.h
    • /usr/lib/x86_64-linux-gnu/libIL.a
    • /usr/lib/x86_64-linux-gnu/libIL.la
    • /usr/lib/x86_64-linux-gnu/libIL.so
    • /usr/lib/x86_64-linux-gnu/libILU.a
    • /usr/lib/x86_64-linux-gnu/libILU.la
    • /usr/lib/x86_64-linux-gnu/libILU.so
    • /usr/lib/x86_64-linux-gnu/libILUT.a
    • /usr/lib/x86_64-linux-gnu/libILUT.la
    • /usr/lib/x86_64-linux-gnu/libILUT.so
    • /usr/lib/x86_64-linux-gnu/pkgconfig/IL.pc
    • /usr/lib/x86_64-linux-gnu/pkgconfig/ILU.pc
    • /usr/lib/x86_64-linux-gnu/pkgconfig/ILUT.pc
    • /usr/share/doc/libdevil-dev/Libraries.txt
    • /usr/share/doc/libdevil-dev/NEWS.gz
    • /usr/share/doc/libdevil-dev/README.gz
    • /usr/share/doc/libdevil-dev/README.unix
    • /usr/share/doc/libdevil-dev/changelog.Debian.amd64.gz
    • /usr/share/doc/libdevil-dev/changelog.Debian.gz
    • /usr/share/doc/libdevil-dev/changelog.gz
    • /usr/share/doc/libdevil-dev/copyright

    Changelog

    2014-08-18 - Markus Koschany <apo@gambaru.de> devil (1.7.8-9) unstable; urgency=medium * QA upload. * Add lcms2.patch. - Ensure that the build system detects, uses and links against lcms2. (Closes: #745518)

    2014-06-02 - Markus Koschany <apo@gambaru.de> devil (1.7.8-8) unstable; urgency=medium * QA upload. * debian/control: Switch to liblcms2-dev. (Closes: #745518) * wrap-and-sort -sa. * Declare compliance with Debian policy 3.9.5. * debian/rules: Build with autotools_dev. (Closes: #744564) * Build-depend on liballegro4-dev instead of virtual liballegro4.2-dev.

    2013-05-21 - Frank Lichtenheld <djpig@debian.org> devil (1.7.8-7) unstable; urgency=low * QA upload. * Change maintainer to QA group. * Change dependencies on libtiff4-dev to libtiff-dev. Closes: #682176 * Change dependencies on libpng12-dev to libpng-dev. Closes: #662298 * New patch png_set_expand_gray_1_2_4_to_8. Closes: #649554 Based on a patch by Nobuhiro Iwamatsu. * debian/ cleanup: + use dh + bump debhelper compat to 9 - this automatically enables hardening flags. Closes: #653535 + use source format 3.0 (quilt) + remove obsolete VCS links

    2011-07-31 - Muammar El Khatib <muammar@debian.org> devil (1.7.8-6.1) unstable; urgency=low * Non-maintainer upload. * Remove references to other libraries from dependency_libs field. Closes: #633168. * debian/control: Build-Depend on libjpeg-dev instead of libjpeg62-dev. Closes: #633691.

    2009-12-08 - Bradley Smith <bradsmith@debian.org> devil (1.7.8-6) unstable; urgency=high * Fix CVE-2009-3994. Closes: #560080.

    2009-09-10 - Bradley Smith <bradsmith@debian.org> devil (1.7.8-5) unstable; urgency=low * Fix FTBFS. Closes: #545959.

    2009-08-22 - Bradley Smith <bradsmith@debian.org> devil (1.7.8-4) unstable; urgency=low * Add missing depends to libdevil-dev. Closes: #531888.

    2009-08-17 - Bradley Smith <bradsmith@debian.org> devil (1.7.8-3) unstable; urgency=low * Fix kfreebsd FTBFS. Patch thanks to Cyril Brulebois <kibi@debian.org> Closes: #541889. * Update Standards-Version to 3.8.3.

    2009-04-26 - Bradley Smith <bradsmith@debian.org> devil (1.7.8-2) unstable; urgency=low * Add missing libraries in linking of ILUT. Closes: #525363.

    2009-03-24 - Bradley Smith <bradsmith@debian.org> devil (1.7.8-1) unstable; urgency=low * New upstream release. * Add liballegro4.2-dev to Build-Depends. * Update Standards-Version to 3.8.1. (No changes).

    Advertisement
    Advertisement