libdevel-cycle-perl_1.11-2_all.deb


Advertisement

Description

libdevel-cycle-perl - Perl module to detect memory cycles in Perl objects

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libdevel-cycle-perl
Package version 1.11
Package release 2
Package architecture all
Package type deb
Installed size 61 B
Download size 12.28 KB
Official Mirror ftp.br.debian.org
Devel::Cycle is a developer's tool for finding memory cycles in Perl objects.
Since Perl provides its automatic memory management using reference counting,
cyclical/circular references will result in memory that will never be freed.
Optionally, PadWalker (libpadwalker-perl) module enables reporting of cycles
in code closures as well.

Alternatives

Package Version Architecture Repository
libdevel-cycle-perl_1.11-2_all.deb 1.11 all Debian Main
libdevel-cycle-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libdevel-cycle-perl_1.11-2_all.deb
Source Package libdevel-cycle-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdevel-cycle-perl deb package:
    # sudo apt-get install libdevel-cycle-perl

Files

Path
/usr/share/doc/libdevel-cycle-perl/changelog.Debian.gz
/usr/share/doc/libdevel-cycle-perl/changelog.gz
/usr/share/doc/libdevel-cycle-perl/copyright
/usr/share/man/man3/Devel::Cycle.3pm.gz
/usr/share/perl5/Devel/Cycle.pm

Changelog

2012-03-21 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libdevel-cycle-perl (1.11-2) unstable; urgency=low
[ Ryan Niebur ]
* Email change: Jonathan Yu -> jawnsy@cpan.org
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Florian Schlichting ]
* Switch to source format 3.0 (quilt).
* Add unhandled_type_REGEXP.patch (closes: #658614).
* Bump dh compatibility to level 8 (no changes necessary).
* Bump Standards-Version to 3.9.3 (use copyright-format 1.0).
* Add myself to uploaders and copyright.
* Add spelling-error-in-manpage.patch.
2009-08-24 - Jonathan Yu <frequency@cpan.org>
libdevel-cycle-perl (1.11-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
+ Fix for incorrectly reported cycles (RT#47389)
* Standards-Version 3.8.3 (drop version dependency on perl)
* Use new short debhelper rules format
* Bump compat to 7, upgrade debhelper to >= 7
* Upgrade copyright information, use machine readable format
* Update control description
* Added myself to Copyright and Uploaders
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
2008-07-09 - gregor herrmann <gregoa@debian.org>
libdevel-cycle-perl (1.10-1) unstable; urgency=low
* New upstream release.
* debian/control: change my email address.
* Set Standards-Version to 3.8.0 (no changes).
2008-04-15 - gregor herrmann <gregor+debian@comodo.priv.at>
libdevel-cycle-perl (1.09-1) unstable; urgency=low
* New upstream release.
* Add libpadwalker-perl to Build-Depends-Indep and Suggests.
2008-04-12 - gregor herrmann <gregor+debian@comodo.priv.at>
libdevel-cycle-perl (1.08-1) unstable; urgency=low
* New upstream release.
* debian/control: remove trailing comma from Depends: line.
* debian/copyright: adjust years of copyright to upstream data.
* Refresh debian/rules, no functional changes.
2008-03-16 - gregor herrmann <gregor+debian@comodo.priv.at>
libdevel-cycle-perl (1.07-2) unstable; urgency=low
* debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field
(source stanza); Homepage field (source stanza). Added: /me to
Uploaders.
* debian/watch: use dist-based URL.
* debian/rules:
- delete /usr/lib/perl5 only if it exists (closes: #467753)
- update based on dh-make-perl's templates
- don't install README any more (short version of the POD documentation)
* Set Standards-Version to 3.7.3 (no changes).
* debian/copyright: use version-independent download URL.
2006-05-24 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org>
libdevel-cycle-perl (1.07-1) unstable; urgency=low
* Initial Release (closes: #368861)

See Also

Package Description
libdevel-declare-parser-perl_0.17-1_all.deb higher level interface to Devel::Declare
libdevel-declare-perl_0.006017-1+deb8u1_amd64.deb module to add new syntax to Perl
libdevel-dprof-perl_20110802.00-3+b1_amd64.deb deprecated Perl code profiler
libdevel-dumpvar-perl_1.06-1_all.deb Perl module to dump Perl variables
libdevel-ebug-perl_0.56-1_all.deb simple, extensible Perl debugger
libdevel-findref-perl_1.440-1+b1_amd64.deb Perl module to find variables referring to an object
libdevel-gdb-perl_2.02-2_all.deb module to open and communicate with a gdb session
libdevel-globaldestruction-perl_0.13-1_all.deb module to expose the flag that marks global destruction
libdevel-hide-perl_0.0009-1_all.deb module for forcing the unavailability of specified Perl modules (for testing)
libdevel-leak-perl_0.03-3+b1_amd64.deb utility for looking for perl objects that are not reclaimed
libdevel-lexalias-perl_0.05-1+b2_amd64.deb Perl module that provides alias lexical variables
libdevel-nytprof-perl_5.06+dfsg-2+b1_amd64.deb Perl statement and subroutine code profiler
libdevel-overrideglobalrequire-perl_0.001-1_all.deb module to safely override CORE::GLOBAL::require
libdevel-partialdump-perl_0.17-1_all.deb Perl module to dump subroutine parameters concisely
libdevel-patchperl-perl_1.28-1_all.deb Perl module to patch perl source à la Devel::PPPort's buildperl.pl
Advertisement
Advertisement