libdebug0_0.4.4-1.1_amd64.deb


Advertisement

Description

libdebug0 - Memory leak detection system and logging library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libdebug0
Package version 0.4.4
Package release 1.1
Package architecture amd64
Package type deb
Installed size 69 B
Download size 15.27 KB
Official Mirror ftp.br.debian.org
This library contains routines needed by many of the authors
other programs. It includes utilities to aid in debugging of
programs.
Some of the features currently supported by this library are
memory leak detection, hex dumping, and logging. The logging
system is especially useful. It adds syntax highlighting for
different log levels in debugging mode. There are different
modes for printing to console and files, duplicate line
detection and lots of other small things which makes life
simpler for the programmer.
This package contains files needed by programs linked against
this library.

Alternatives

Package Version Architecture Repository
libdebug0_0.4.4-1.1_i386.deb 0.4.4 i386 Debian Main
libdebug0 - - -

Requires

Name Value
libc6 >= 2.4
multiarch-support -

Download

Type URL
Binary Package libdebug0_0.4.4-1.1_amd64.deb
Source Package libdebug

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdebug0 deb package:
    # sudo apt-get install libdebug0

Files

Path
/usr/lib/x86_64-linux-gnu/libdebug.so.0
/usr/lib/x86_64-linux-gnu/libdebug.so.0.4.4
/usr/share/doc/libdebug0/changelog.Debian.gz
/usr/share/doc/libdebug0/changelog.gz
/usr/share/doc/libdebug0/copyright
/usr/share/lintian/overrides/libdebug0

Changelog

2012-01-06 - Jakub Wilk <jwilk@debian.org>
libdebug (0.4.4-1.1) unstable; urgency=low
* Non-maintainer upload.
* Move the static library and the .so symlink to multiarch directory
(closes: #648903).
* Mark the -dev package as Multi-Arch: same (closes: #648905).
* Use multi-arch paths in lintian override.
2011-07-19 - Peter Pentchev <roam@ringlet.net>
libdebug (0.4.4-1) unstable; urgency=low
* New upstream release to fix a compiler warning.
* Bump Standards-Version to 3.9.2 with no changes.
* Update the copyright file to the latest revision of the DEP 5
candidate format and bump the year on my copyright notice.
* Convert to multiarch:
- pass /usr/lib/triplet as "libdir" to dh_auto_install
- substitute DEB_HOST_MULTIARCH in libdebug0.install
- specify Multi-Arch: same for libdebug0 and Multi-Arch: foreign
for libdebug0-dev
- bump the debhelper build dependency to 8.1.3~ and add misc:Pre-Depends
for the libdebug0 package
* Upload to unstable.
2010-12-24 - Peter Pentchev <roam@ringlet.net>
libdebug (0.4.3-3) experimental; urgency=low
* Switch to Git and point the Vcs-* fields to Gitorious.
* Bump Standards-Version to 3.9.1 with no changes.
* Switch to bzip2 compression for the Debian tarball.
* Use hardening-includes instead of hardening-wrapper so that
the hardening flags are visible in CFLAGS and LDFLAGS.
* Bump the debhelper compatibility level to 8.
2010-06-28 - Peter Pentchev <roam@ringlet.net>
libdebug (0.4.3-2) unstable; urgency=low
* Fix the libdebug0-dev dependency on the exact binary:Version of libdebug0.
* Convert to the 3.0 (quilt) source format with no changes.
* Bump Standards-Version to 3.9.0 with no changes.
* Use dpkg-buildflags from dpkg-dev 1.15.7 to obtain the default values of
CFLAGS, CPPFLAGS, and LDFLAGS.
* Update the copyright file to the latest revision of the DEP 5 format and
bump the year on my copyright notice.
* Shorten the Vcs-Browser URL.
2009-05-28 - Peter Pentchev <roam@ringlet.net>
libdebug (0.4.3-1) unstable; urgency=low
* New maintainer.  Closes: #499260
* Override a "shlib calls exit" lintian warning - this is a debugging
library, it is supposed to exit on grave errors.
* Add a symbols file starting at libdebug0-0.4.2 obtained from mole.
* Make this a non-native package.
* Add a watch file.
* Convert the copyright file to the machine-readable format and
add my copyright notice.
* Add the Vcs-Svn and Vcs-Browser control fields.
* Bump the debhelper compatibility version to 7:
- add misc:Depends to the binary package
* Bump Standards-Version to 3.8.1:
- use binary:Version instead of hardcoding the dependencies between
the binary packages
- support "nostrip" in DEB_BUILD_OPTIONS.  Closes: #437346
- add the Homepage control field
* Build with lots of compiler warning flags.
* Build with -Werror if "werror" is in DEB_BUILD_OPTIONS.
* Enable build hardening unless "nohardening" is in DEB_BUILD_OPTIONS.
* Remove the unused debian/Makefile.
* Remove debian/libdebug0.postinst - dh_makeshlibs takes care of this.
* Do not try to clean the source in the "build" target, it's upstream's
job now.
* Use dh_install instead of dh_movefiles.
* Minimize the rules file using debhelper override targets.
* Pass prefix correctly during the install phase now that upstream
supports DESTDIR in the canonical way.
2008-01-16 - Luca Falavigna <dktrkranz@ubuntu.com>
libdebug (0.4.2-0.1) unstable; urgency=low
* Non-maintainer upload.
* debian/rules:
- Fix bashisms (Closes: #381565).
- Fix debian-rules-ignores-make-clean-error lintian warning.
- Fix debian-rules-missing-required-target lintian error by
providing binary-indep target (Closes: #395708).
* Makefile:
- Fix bashisms.
* Use debian/compat, fix debian-rules-sets-DH_COMPAT lintian warning.
2004-08-22 - Abraham vd Merwe <abz@debian.org>
libdebug (0.4.2) unstable; urgency=high
* Fixed man page sections.

See Also

Package Description
libdecentxml-java-doc_1.4-1_all.deb API documentation for libdecentxml-java
libdecentxml-java_1.4-1_all.deb XML parser optimized for round-tripping and code reuse
libdeclarative-connectivity_1.2.0-3+b1_amd64.deb Qt Mobility Connectivity QML plugin
libdeclarative-contacts_1.2.0-3+b1_amd64.deb Qt Mobility Contacts QML plugin
libdeclarative-feedback_1.2.0-3+b1_amd64.deb Qt Mobility Feedback QML plugin
libdeclarative-gallery_1.2.0-3+b1_amd64.deb Qt Mobility Document Gallery QML plugin
libdeclarative-location_1.2.0-3+b1_amd64.deb Qt Mobility Location QML plugin
libdeclarative-messaging_1.2.0-3+b1_amd64.deb Qt Mobility Messaging QML plugin
libdeclarative-multimedia_1.2.0-3+b1_amd64.deb Qt Mobility Multimedia QML plugin
libdeclarative-organizer_1.2.0-3+b1_amd64.deb Qt Mobility Organizer QML plugin
libdeclarative-publishsubscribe_1.2.0-3+b1_amd64.deb Qt Mobility Publish and Subscribe QML plugin
libdeclarative-sensors_1.2.0-3+b1_amd64.deb Qt Mobility Sensors QML plugin
libdeclarative-serviceframework_1.2.0-3+b1_amd64.deb Qt Mobility Service Framework QML plugin
libdeclarative-systeminfo_1.2.0-3+b1_amd64.deb Qt Mobility System Information QML plugin
libdecodeqr-dev_0.9.3-6.2+b1_amd64.deb C/C++ library for decoding QR code
Advertisement
Advertisement