libdbix-password-perl_1.9-1_all.deb


Advertisement

Description

libdbix-password-perl - Perl module for creating a global password file for DB passwords

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libdbix-password-perl
Package version: 1.9
Package release: 1
Package architecture: all
Package type: deb
Installed size: 80 B
Download size: 10.57 KB
Official Mirror: ftp.br.debian.org
Don't you hate keeping track of database passwords and such throughout your scripts? How about the problem of changing those passwords on a mass scale? DBIx::Password is one possible solution. It keeps track of all your virtual users, databases, password, etc. in one central file.

Alternatives

    Download

    Source package: libdbix-password-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libdbix-password-perl deb package:
      # sudo apt-get install libdbix-password-perl

    Files

    • /etc/dbix-password.conf
    • /usr/share/doc/libdbix-password-perl/README.Debian
    • /usr/share/doc/libdbix-password-perl/changelog.Debian.gz
    • /usr/share/doc/libdbix-password-perl/changelog.gz
    • /usr/share/doc/libdbix-password-perl/copyright
    • /usr/share/man/man3/DBIx::Password.3pm.gz
    • /usr/share/perl5/DBIx/Password.pm

    Changelog

    2009-05-09 - Peter Pentchev <roam@ringlet.net> libdbix-password-perl (1.9-1) unstable; urgency=low [ Peter Pentchev ] * Adopt into the Debian Perl Group. Closes: #503531 * Use quilt for patch management. * Remove the autogenerated test.pl in the clean target. * Only depend on debhelper once :) * Remove the empty prerm, postrm, and preinst scripts. * Remove the postinst script - its only purpose was to output a warning on upgrades from versions that are not even in oldstable. * Bump the debhelper compatibility level to 7: - add misc:Depends to the binary package - minimize the rules file, adding debian/clean and debian/install * Convert the copyright file to the machine-readable format. * Add a watch file. * Add the Vcs-Svn and Vcs-Browser control fields. * Bump Standards-Version to 3.8.1: - add the README.source file to document the use of quilt - add the Homepage control field * New upstream release. * Allow the module to be loaded even without a config file. * Break out the config file parsing into separate functions. * Do not install the useless README file. [ gregor herrmann ] * Remove unneeded debian/dirs. * Mention module name in debian/control's long description.

    2006-10-30 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-10) unstable; urgency=low * Did some clean-up in debian/rules (closes: #395613)

    2006-06-30 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-9) unstable; urgency=low * Corrected typo in description (closes: #375852)

    2004-08-16 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-8) unstable; urgency=low * Corrected manpage section to 3perl

    2003-12-30 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-7) unstable; urgency=low * Build against perl 5.8.2-2 * Updated Standards-Version

    2003-02-17 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-6) unstable; urgency=high * Previous version messed the syntax of /etc/dbix-password.conf and rendered the package unusable. So priority is high.

    2003-02-06 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-5) unstable; urgency=low * Removed attr. field from /etc/dbix-password.conf (closes: #179881)

    2003-01-31 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-4) unstable; urgency=low * Corrected typo in the example in dbix-password.conf (closes: #178892) * Updated maintainer's email address

    2002-09-17 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-3) unstable; urgency=low * Suppressed install notes in manpage. * corrected typo in /etc/dbix-password.conf (closes: #149991) * Forgot to close this one before (closes: #143635)

    2002-08-21 - Eric Van Buggenhaut <ericvb@debian.org> libdbix-password-perl (1.8-2) unstable; urgency=low * Build all package in binary-indep target (closes: #157474)

    Advertisement
    Advertisement