libdbix-introspector-perl_0.001003-1_all.deb


Advertisement

Description

libdbix-introspector-perl - module to detect what database code is connected to

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libdbix-introspector-perl
Package version: 0.001003
Package release: 1
Package architecture: all
Package type: deb
Installed size: 75 B
Download size: 16.82 KB
Official Mirror: ftp.br.debian.org
DBIx::Introspector is a module factored out of the DBIx::Class database detection code. Most code that needs to detect which database it is connected to assumes that there is a one-to-one mapping from database drivers to database engines. Unfortunately reality is rarely that simple. For instance, DBD::ODBC is typically used to connect to SQL Server, but ODBC can be used to connect to PostgreSQL, MySQL, and Oracle. Additionally, while ODBC is the most common way to connect to SQL Server, it is not the only option, as DBD::ADO can also be used. DBIx::Introspector can correctly detect which database you are connected to, because it was factored out of a complex, working codebase. On top of that it has been written to be very extensible. So if you needed to detect which version of your given database you are connected to that would not be difficult.

    Download

    Source package: libdbix-introspector-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libdbix-introspector-perl deb package:
      # sudo apt-get install libdbix-introspector-perl

    Files

    • /usr/share/doc/libdbix-introspector-perl/changelog.Debian.gz
    • /usr/share/doc/libdbix-introspector-perl/changelog.gz
    • /usr/share/doc/libdbix-introspector-perl/copyright
    • /usr/share/man/man3/DBIx::Introspector.3pm.gz
    • /usr/share/man/man3/DBIx::Introspector::Advent.3pm.gz
    • /usr/share/perl5/DBIx/Introspector.pm
    • /usr/share/perl5/DBIx/Introspector/Advent.pod
    • /usr/share/perl5/DBIx/Introspector/Driver.pm

    Changelog

    2014-06-21 - gregor herrmann <gregoa@debian.org> libdbix-introspector-perl (0.001003-1) unstable; urgency=medium * New upstream release.

    2014-03-01 - gregor herrmann <gregoa@debian.org> libdbix-introspector-perl (0.001002-1) unstable; urgency=medium * New upstream release. * Update year of upstream copyright.

    2014-01-14 - gregor herrmann <gregoa@debian.org> libdbix-introspector-perl (0.001000-1) unstable; urgency=low * Initial release (closes: #735319).

    Advertisement
    Advertisement