libdbd-ldap-perl_0.20-1_all.deb


Advertisement

Description

libdbd-ldap-perl - Perl extension for LDAP access via an SQL/Perl DBI interface

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libdbd-ldap-perl
Package version 0.20
Package release 1
Package architecture all
Package type deb
Installed size 119 B
Download size 34.62 KB
Official Mirror ftp.br.debian.org
DBD::LDAP is a DBI extension module adding an SQL database interface to
standard LDAP databases to Perl's database-independent database interface.
You will need access to an existing LDAP database or set up your own using
an LDAP server, ie. "OpenLDAP", see (http://www.openldap.org).
The main advantage of DBD::LDAP is the ability to query LDAP databases via
standard SQL queries in leu of cryptic LDAP "filters".  LDAP is optimized for
quick lookup of existing data, but DBD::LDAP does support entry inserts,
updates, and deletes with commit/rollback via the standard SQL commands!

Alternatives

Package Version Architecture Repository
libdbd-ldap-perl_0.20-1_all.deb 0.20 all Debian Main
libdbd-ldap-perl - - -

Requires

Name Value
libdbi-perl -
libnet-ldap-perl -
perl -

Download

Type URL
Binary Package libdbd-ldap-perl_0.20-1_all.deb
Source Package libdbd-ldap-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdbd-ldap-perl deb package:
    # sudo apt-get install libdbd-ldap-perl

Files

Path
/usr/share/doc/libdbd-ldap-perl/changelog.Debian.gz
/usr/share/doc/libdbd-ldap-perl/changelog.gz
/usr/share/doc/libdbd-ldap-perl/copyright
/usr/share/man/man3/DBD::LDAP.3pm.gz
/usr/share/perl5/JLdap.pm
/usr/share/perl5/DBD/LDAP.pm

Changelog

2011-10-03 - Jonas Genannt <jonas.genannt@capi2name.de>
libdbd-ldap-perl (0.20-1) unstable; urgency=low
* New Upstream Release
* Bumped up Standards Version
* Bumped up Debhelper compat version
* d/control: added Homepage field
- added ${misc:Depends}
- removed version depend on perl
* Switch to dpkg-source 3.0 (quilt) format
* d/copyright: translation to DEP5
* d/watch: added watch file
* d/rules: reduced rules
2006-02-08 - Jonas Genannt <jonas.genannt@capi2name.de>
libdbd-ldap-perl (0.09-1) unstable; urgency=low
* New Upstream Release
* bumped Standards-Version to 3.7.2 (no changes needed)
* debian/copyright: added upstream homepage url
2005-11-06 - Jonas Genannt <jonas.genannt@capi2name.de>
libdbd-ldap-perl (0.07-1) unstable; urgency=low
* new maintainer (Closes: #271430)
* debian/control new standards version
* changed selection to perl (Closes: #310235)
* new upstream version (Closes: #321972)
* cleaned up the debian/rules
* fixed path to perl in JLdap.pm (Closes: #310236)
* changed compat version to 4
* added debian/compat file
* debian/rules changed to Build Indep, thanks lintian
2002-11-09 - Ivan Kohler <ivan-debian@420.am>
libdbd-ldap-perl (0.05-1) unstable; urgency=low
* Initial Release (closes: Bug#168417).

See Also

Package Description
libdbd-mock-perl_1.45-1_all.deb Mock database driver for testing
libdbd-mysql-perl_4.028-2+deb8u2_amd64.deb Perl5 database interface to the MySQL database
libdbd-mysql_0.9.0-3_amd64.deb MySQL database server driver for libdbi
libdbd-odbc-perl_1.50-1+b1_amd64.deb Perl Database Driver implementing ODBC for DBI
libdbd-odbc-ruby1.8_0.2.5+gem2deb-1_all.deb Transitional package for ruby-dbd-odbc
libdbd-odbc-ruby_0.2.5+gem2deb-1_all.deb Transitional package for ruby-dbd-odbc
libdbd-pg-perl_3.4.2-1_amd64.deb Perl DBI driver for the PostgreSQL database server
libdbd-pg-ruby1.8_0.3.9+gem2deb-1_all.deb Transitional package for ruby-dbd-pg
libdbd-pg-ruby1.9.1_0.3.9+gem2deb-1_all.deb Transitional package for ruby-dbd-pg
libdbd-pg-ruby_0.3.9+gem2deb-1_all.deb Transitional package for ruby-dbd-pg
libdbd-pgsql_0.9.0-3_amd64.deb PostgreSQL database server driver for libdbi
libdbd-sqlite2-perl_0.36-2+b1_amd64.deb Perl DBI driver with a self-contained RDBMS (SQLite2 version)
libdbd-sqlite3-perl_1.44-1_amd64.deb Perl DBI driver with a self-contained RDBMS
libdbd-sqlite3_0.9.0-3_amd64.deb SQLite3 database driver for libdbi
libdbd-sqlite_0.9.0-3_amd64.deb SQLite database driver for libdbi
Advertisement
Advertisement