libdbd-firebird-perl_1.18-2_amd64.deb


Advertisement

Description

libdbd-firebird-perl - Perl DBI driver for Firebird RDBMS server

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libdbd-firebird-perl
Package version 1.18
Package release 2
Package architecture amd64
Package type deb
Installed size 350 B
Download size 97.82 KB
Official Mirror ftp.br.debian.org
DBD::Firebird is a Perl Database Driver module which works with the generic
DBI module, adding support for Firebird databases. It enables access to
Firebird databases from Perl scripts.

Alternatives

Package Version Architecture Repository
libdbd-firebird-perl_1.18-2_i386.deb 1.18 i386 Debian Main
libdbd-firebird-perl - - -

Requires

Name Value
libc6 >= 2.14
libdbi-perl -
libfbclient2 >= 2.5.0.25784~ReleaseCandidate1.ds2
libfbembed2.5 >= 2.5.0.25784~ReleaseCandidate1.ds2
perl >= 5.20.2-3
perl-dbdabi-94 -
perlapi-5.20.2 -

Download

Type URL
Binary Package libdbd-firebird-perl_1.18-2_amd64.deb
Source Package libdbd-firebird-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdbd-firebird-perl deb package:
    # sudo apt-get install libdbd-firebird-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/Firebird.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/FirebirdEmbedded.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/Firebird/GetInfo.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/Firebird/TableInfo.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/Firebird/TypeInfo.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/Firebird/TableInfo/Basic.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/DBD/Firebird/TableInfo/Firebird21.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/DBD/Firebird/Firebird.so
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/DBD/FirebirdEmbedded/FirebirdEmbedded.so
/usr/share/doc/libdbd-firebird-perl/README
/usr/share/doc/libdbd-firebird-perl/changelog.Debian.gz
/usr/share/doc/libdbd-firebird-perl/changelog.gz
/usr/share/doc/libdbd-firebird-perl/copyright
/usr/share/man/man3/DBD::Firebird.3pm.gz
/usr/share/man/man3/DBD::Firebird::TableInfo::Basic.3pm.gz
/usr/share/man/man3/DBD::FirebirdEmbedded.3pm.gz

Changelog

2015-04-01 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.18-2) unstable; urgency=high
* High urgency for security fixes
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Damyan Ivanov ]
* Add patch from Stefan Roas fixing potential buffer overflow in certain
error conditions (CVE-2015-2788)
(Closes: #780925)
* add patch from upstream Git replacing all sprintf usage with snprintf
2014-04-02 - Xavier Guimard <x.guimard@free.fr>
libdbd-firebird-perl (1.18-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Xavier Guimard ]
* Imported Upstream version 1.18
* Update debian copyright years
* Remove patch disabling threaded events tests now included upstream
2014-01-09 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.16-2) unstable; urgency=medium
[ Damyan Ivanov ]
* add arm64 to BAD_ARCH list on request from Noskaj
"This is the only thing in the Ubuntu diff" on IRC
* add patch from upstream Git disabling threaded events tests during
automated testing
Closes: #732324 -- FTBFS on i386
[ Xavier Guimard ]
* Bump Standards-Version to 3.9.5
2013-12-02 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.16-1) unstable; urgency=low
* Imported Upstream version 1.16
+ Fixes FTBFS with DBI 1.630 (Closes: #729680)
* Update years of upstream copyright
2013-09-10 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.15-2) unstable; urgency=low
* skip fork-based event tests on armel and armhf
2013-09-09 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.15-1) unstable; urgency=low
* New upstream release
+ fixes tests on s390x (Closes: #719855)
2013-09-09 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.14-1) unstable; urgency=low
* New upstream release
* export environment vars disabling fragile tests and certain tests on
certain bad platforms.
(Closes: #719582)
2013-08-15 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (1.12-1) unstable; urgency=low
* New upstream release
* add libfile-watch-perl to build-dependencies
* drop patch released upstream
* drop filebird2.5-server from build-dependencies
* update years of copyright
* require version 0.31 of libtest-exception-perl for building
2013-05-18 - gregor herrmann <gregoa@debian.org>
libdbd-firebird-perl (1.11-1) unstable; urgency=low
* Team upload.
[ Xavier Guimard ]
* Imported Upstream version 1.11
+ Remove debian/patches/git/skip-event-tests.patch that has been included
in upstream release
+ fixes build include flags when firebird is not found (Closes:#700427)
* Bump standards-version to 3.9.4
* Upgrade debhelper dependency to 9.20120312
* Update debian/copyright (format and years)
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Damyan Ivanov ]
* add patch removing unnecessary (and wrong) conversion from utf8 to native
bytes when feeding character data to firebird
Closes: #704265 -- FTBFS with perl 5.16: test failures
2011-11-04 - Damyan Ivanov <dmn@debian.org>
libdbd-firebird-perl (0.91-2) unstable; urgency=low
* add a patch from upstream c3306d5 allowing conditional skipping ov event
tests
* rules: skip event tests on number of architecures
these are armel, ia64, kfreebsd-amd64, kfreebsd-i386 and s390
it *seems* that the problem is not in dbd-firebird itself
as the very same tests pass on 7 other archtectures

See Also

Package Description
libdbd-freetds_0.9.0-3_amd64.deb Freetds database server driver for libdbi
libdbd-ldap-perl_0.20-1_all.deb Perl extension for LDAP access via an SQL/Perl DBI interface
libdbd-mock-perl_1.45-1_all.deb Mock database driver for testing
libdbd-mysql-perl_4.028-2+deb8u2_amd64.deb Perl5 database interface to the MySQL database
libdbd-mysql_0.9.0-3_amd64.deb MySQL database server driver for libdbi
libdbd-odbc-perl_1.50-1+b1_amd64.deb Perl Database Driver implementing ODBC for DBI
libdbd-odbc-ruby1.8_0.2.5+gem2deb-1_all.deb Transitional package for ruby-dbd-odbc
libdbd-odbc-ruby_0.2.5+gem2deb-1_all.deb Transitional package for ruby-dbd-odbc
libdbd-pg-perl_3.4.2-1_amd64.deb Perl DBI driver for the PostgreSQL database server
libdbd-pg-ruby1.8_0.3.9+gem2deb-1_all.deb Transitional package for ruby-dbd-pg
libdbd-pg-ruby1.9.1_0.3.9+gem2deb-1_all.deb Transitional package for ruby-dbd-pg
libdbd-pg-ruby_0.3.9+gem2deb-1_all.deb Transitional package for ruby-dbd-pg
libdbd-pgsql_0.9.0-3_amd64.deb PostgreSQL database server driver for libdbi
libdbd-sqlite2-perl_0.36-2+b1_amd64.deb Perl DBI driver with a self-contained RDBMS (SQLite2 version)
libdbd-sqlite3-perl_1.44-1_amd64.deb Perl DBI driver with a self-contained RDBMS
Advertisement
Advertisement