libdata-dumper-simple-perl_0.11-4_all.deb


Advertisement

Description

libdata-dumper-simple-perl - Easily dump variables together with their names (Data::Dumper-like)

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libdata-dumper-simple-perl
Package version: 0.11
Package release: 4
Package architecture: all
Package type: deb
Installed size: 76 B
Download size: 12.81 KB
Official Mirror: ftp.br.debian.org
This module allows the user to dump variables in a Data::Dumper format. Unlike the default behavior of Data::Dumper, the variables are named (instead of $VAR1, $VAR2, etc.) Data::Dumper provides an extended interface that allows the programmer to name the variables, but this interface requires a lot of typing and is prone to tyops (sic). This module fixes that.

Alternatives

    Download

    Source package: libdata-dumper-simple-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libdata-dumper-simple-perl deb package:
      # sudo apt-get install libdata-dumper-simple-perl

    Files

    • /usr/share/doc/libdata-dumper-simple-perl/changelog.Debian.gz
    • /usr/share/doc/libdata-dumper-simple-perl/changelog.gz
    • /usr/share/doc/libdata-dumper-simple-perl/copyright
    • /usr/share/man/man3/Data::Dumper::Simple.3pm.gz
    • /usr/share/perl5/Data/Dumper/Simple.pm

    Changelog

    2008-03-08 - gregor herrmann <gregor+debian@comodo.priv.at> libdata-dumper-simple-perl (0.11-4) unstable; urgency=low * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/rules: - delete /usr/lib/perl5 only if it exists (closes: #467740) - update based on dh-make-perl's templates * debian/watch: use dist-based URL. * Set Standards-Version to 3.7.3 (no changes).

    2006-10-01 - gregor herrmann <gregor+debian@comodo.priv.at> libdata-dumper-simple-perl (0.11-3) unstable; urgency=low * Use $(CURDIR) [make] instead of $(PWD) [sh] to fix issues with sudo.

    2006-06-16 - gregor herrmann <gregor+debian@comodo.priv.at> libdata-dumper-simple-perl (0.11-2) unstable; urgency=low * Moved debhelper to Build-Depends. * Set Standards-Version to 3.7.2 (no changes). * Set Debhelper Compatibility Level to 5. * Removed empty /usr/lib/perl5 from package. * Added libtest-pod-perl and libtest-pod-coverage-perl to Build-Depends-Indep.

    2005-12-05 - Gunnar Wolf <gwolf@debian.org> libdata-dumper-simple-perl (0.11-1) unstable; urgency=low * New upstream release

    2005-10-24 - Gunnar Wolf <gwolf@debian.org> libdata-dumper-simple-perl (0.10-1) unstable; urgency=low * New upstream release * Added build-dependency on libmodule-build-perl * Bumped up standards-version to 3.6.2

    2005-05-25 - Gunnar Wolf <gwolf@debian.org> libdata-dumper-simple-perl (0.07-1) unstable; urgency=low * New upstream release

    2004-12-27 - Gunnar Wolf <gwolf@debian.org> libdata-dumper-simple-perl (0.06-1) unstable; urgency=low * Initial Debian version (Closes: #287471)

    Advertisement
    Advertisement