libdancer-plugin-dbic-perl_0.2100-1_all.deb


Advertisement

Description

libdancer-plugin-dbic-perl - DBIx::Class interface for Dancer applications

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libdancer-plugin-dbic-perl
Package version: 0.2100
Package release: 1
Package architecture: all
Package type: deb
Installed size: 37 B
Download size: 19.46 KB
Official Mirror: ftp.br.debian.org
Dancer is a Perl web application framework. Dancer::Plugin::DBIC provides an easy way to obtain DBIx::Class::ResultSet instances via the function schema(), which it automatically imports. You just need to point to a dsn in your Dancer configuration file. So you no longer have to write boilerplate DBIC setup code.

    Download

    Source package: libdancer-plugin-dbic-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libdancer-plugin-dbic-perl deb package:
      # sudo apt-get install libdancer-plugin-dbic-perl

    Files

    • /usr/share/doc/libdancer-plugin-dbic-perl/README.gz
    • /usr/share/doc/libdancer-plugin-dbic-perl/buildinfo_all.gz
    • /usr/share/doc/libdancer-plugin-dbic-perl/changelog.Debian.gz
    • /usr/share/doc/libdancer-plugin-dbic-perl/changelog.gz
    • /usr/share/doc/libdancer-plugin-dbic-perl/copyright
    • /usr/share/man/man3/Dancer::Plugin::DBIC.3pm.gz
    • /usr/share/perl5/Dancer/Plugin/DBIC.pm

    Changelog

    2014-05-20 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.2100-1) unstable; urgency=medium [ upstream ] * New release. [ Jonas Smedegaard ] * Update README.source to emphasize control.in file as *not* a show-stopper for contributions. * Bump to standards-version 3.9.5. * Fix use canonical Vcs-Git URL. * Update watch file to use metacpan.org URL. * Update copyright info: + Extend coverage of packaging. + Add git URL as alternate source. * Stop track tarball checksum: Check against upstrem git instead. * Update package relations: + (Build-)depend explicitly on libdbi-perl. + Build-depend on libmoose-perl, libmoosex-types-perl and libmoosex-types-loadableclass-perl. + Build-depend on recent libsql-translator-perl. + Fix stop bogusly build-depend on libdbd-sqlite3.

    2013-03-03 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.1802-1) unstable; urgency=low [ upstream ] * New release. + Added the resultset and rset keywords. + Fixed tests to pass on Dancer 2. + Updated version requirement for Dancer: A newer Dancer is required to use the plugin_args() function. [ Jonas Smedegaard ] * Bump standards-version to 3.9.4. * Tighten (build-)dependency on libdancer-perl. * Use anonscm.debian.org URL for Vcs-Git.

    2013-01-17 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.1700-1) unstable; urgency=low [ upstream ] * New release. + Added support for Dancer 2. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) [ Jonas Smedegaard ] * Add README.source, referring to wiki page about CDBS + git-buildpackage packaging style. * Tidy rules file. * Extend coverage of Debian packaging to include recent years, and tighten its licensing to GPL-3+. * List upstream tracker URL as upstream contact address.

    2012-11-02 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.1601-1) unstable; urgency=low * New upstream release. [ Jonas Smedegaard ] * Update package relations: + Relax to build-depend unversioned on cdbs: Needed version satisfied in stable, and oldstable no longer supported. + Relax to recommend (not depend on) libdbix-class-schema-loader-perl. * Fix typo in module name in long description. * Update copyright file: + Fix use comment and license pseudo-sections to obey silly restrictions of copyright format 1.0. * Bump debhelper compatibility level to 8. * Fix build-depend on and recommend libdbd-sqlite3-perl, and enable regression tests.

    2012-04-24 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.1506-1) unstable; urgency=low * New upstream release. * Use anonscm.debian.org for Vcs-Browser field. * Update copyright file: + Quote license strings in License comment field. + Update email of upstream maintainer.

    2012-03-19 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.1505-1) unstable; urgency=low * New upstream release. [ gregor herrmann ] * Remove debian/source/local-options; abort-on-upstream-changes and unapply-patches are default in dpkg-source since 1.16.1. [ Jonas Smedegaard ] * Bump standards-version to 3.9.3. * Update copyright file: + Bump format to 1.0. + Quote license strings in comments. * Update package relations: + Relax build-dependency on cdbs: Needlessly tight. + Relax build-depend unversioned on debhelper and devscripts: Needed versions satisfied even in oldstable.

    2011-04-22 - Jonas Smedegaard <dr@jones.dk> libdancer-plugin-dbic-perl (0.1504-1) unstable; urgency=low * Initial packaging release. Closes: bug#623738.

    Advertisement
    Advertisement