libcxsparse3.1.2_4.2.1-3_amd64.deb


Advertisement

Description

libcxsparse3.1.2 - concise sparse matrix library (complex, int and long int support)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcxsparse3.1.2
Package version 4.2.1
Package release 3
Package architecture amd64
Package type deb
Installed size 217 B
Download size 64.49 KB
Official Mirror ftp.br.debian.org
Suitesparse is a collection of libraries for computations involving
sparse matrices.  This package includes the following dynamic library:
CXSparse    CSparse extended: complex matrix, int and long int support

Alternatives

Package Version Architecture Repository
libcxsparse3.1.2_4.2.1-3_i386.deb 4.2.1 i386 Debian Main
libcxsparse3.1.2 - - -

Requires

Name Value
libc6 >= 2.7
multiarch-support -

Download

Type URL
Binary Package libcxsparse3.1.2_4.2.1-3_amd64.deb
Source Package suitesparse

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcxsparse3.1.2 deb package:
    # sudo apt-get install libcxsparse3.1.2

Files

Path
/usr/lib/x86_64-linux-gnu/libcxsparse.so.3.1.2
/usr/share/doc/libcxsparse3.1.2/NEWS.Debian.gz
/usr/share/doc/libcxsparse3.1.2/changelog.Debian.gz
/usr/share/doc/libcxsparse3.1.2/copyright

Changelog

2013-12-01 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.1-3) unstable; urgency=low
* Upload to unstable.
* Register user guides for KLU, CAMD, SPQR and LDL in doc-base.
2013-11-13 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.1-2) experimental; urgency=low
* Really fix BLAS/LAPACK dependencies of libsuitesparse-dev
- remove obsolete ATLAS specialized libraries (Closes: #645846)
- add virtual package libblas.so as a BLAS alternative (Closes: #645844)
* Remove Daniel Rus Morales from Uploaders, with his consent. Thanks
Daniel for your work!
* d/rules: do not regenerate d/control automatically, this is
forbidden
* d/rules: fix get-orig-source rule
* d/control: use canonical URLs for Vcs-* fields
* Mark debug package as Multi-Arch: same
* Ship libsuitesparseconfig.a in the -dev package.
* Bump Standards-Version to 3.9.5, no changes needed.
2013-05-03 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.1-1) experimental; urgency=low
* New upstream release (Closes: #706709)
- debian/library-soname.pl: update soversion numbers
* debian/rules: recreate d/control when d/library-sonames.pl is
modified
2013-04-29 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.0-1) experimental; urgency=low
[ Christophe Trophime ]
* New upstream release (Closes: #653660, #687282)
- Renamed UFconfig to SuiteSparse_config
- Update patches to new release
- debian/library-soname.pl: update soversion numbers
[ Sébastien Villemot ]
* debian/control.in:
- fix Maintainer field (Closes: #674266, #674268, #674270, #674271, #674272,
#674273, #674274, #674275, #674276, #674277, #674278, #674279, #674280,
#674281)
- add myself to Uploaders
- remove obsolete DM-Upload-Allowed flag
* Remove obsolete README.source
* debian/rules: clean *.oo files
* Bump to debhelper compat level 9
* Update debian/copyright
* Remove symbols files: they are useless since we bump the soversion
at every new upstream release
* Clean up build flags
- make sure to inject flags from dpkg-buildflags
- buildflags.diff: new patch to remove spurious flags in upstream build
system
- remove -m64 flag on amd64 CPUs (Closes: #701654)
* Fix version in NEWS.Debian, to make lintian happy
* parallel-build.diff: new patch, fixes parallel build
* Multiarchify the package
* Fix BLAS/LAPACK dependencies of libsuitesparse-dev:
- remove obsolete ATLAS specialized libraries (Closes: #645846)
- add libopenblas-dev as a BLAS alternative (Closes: #645844)
* Bump to Standards-Version 3.9.4, no changes needed
* Suitesparse_config_Makefile.diff: new patch, creates a PIC version
of the (small) config code, for embedding in other shared libs
* KLU_Demo_Makefile.diff: new patch, needed for creating the right
dependencies between shared libraries
* Create a new shared library package for SPQR (Closes: #589296)
* Update README.Debian
2012-08-04 - Evgeni Golov <evgeni@debian.org>
suitesparse (1:3.4.0-3) unstable; urgency=low
* Team upload.
[ Sylvestre Ledru ]
* Standard-Version updated to 3.9.3 (no changes requiered)
[ Evgeni Golov ]
* [f782819] Add -g to CFLAGS. (Closes: #682177)
* [d43b31b] Honour CFLAGS in debian/patches/09-CSparse_Lib_Makefile.diff
[ Anton Gladky ]
* [3a0e1c1] Move repository into debian-science.
2010-04-15 - Sylvestre Ledru <sylvestre@debian.org>
suitesparse (1:3.4.0-2) unstable; urgency=low
* Maintainer changed to Debian Science
* Updated list of Uploaders (Closes: #571884, #550417)
* Standards-Version updated to version 3.8.4
* Link against -llapackgf-3 changed to -llapack (Closes: #577879)
* Removed doc-central recommends (Closes: #566361)

See Also

Package Description
libcxxtools-dev_2.2.1-1_amd64.deb library of unrelated but useful C++ classes
libcxxtools9_2.2.1-1_amd64.deb library of unrelated but useful C++ classes
libcyrus-imap-perl24_2.4.17+nocaldav-0+deb8u2_all.deb Interface to Cyrus imap client imclient library [dummy package]
libcyrus-imap-perl_2.4.17+nocaldav-0+deb8u2_amd64.deb Interface to Cyrus imap client imclient library
libdacs-dev_1.4.28b-3_amd64.deb Distributed Access Control System (DACS) - shared library
libdacs1_1.4.28b-3_amd64.deb Distributed Access Control System (DACS) - shared library
libdaemon-control-perl_0.001006-1_all.deb module for creating init scripts in Perl
libdaemon-dev_0.14-6_amd64.deb lightweight C library for daemons - development files
libdaemon-doc_0.14-6_all.deb lightweight C library for daemons - documentation
libdaemon0_0.14-6_amd64.deb lightweight C library for daemons - runtime library
libdancer-logger-psgi-perl_1.0.1-2_all.deb PSGI Log handler for Dancer
libdancer-perl_1.3132+dfsg-1_all.deb effortless web application framework
libdancer-plugin-auth-extensible-perl_0.30-1_all.deb module providing extensible authentication framework for Dancer apps
libdancer-plugin-database-core-perl_0.08-1_all.deb shared core library for Dancer and Dancer2 database plugins
libdancer-plugin-database-perl_2.10-1_all.deb Dancer plugin providing easy database connections
Advertisement
Advertisement