libcurses-widgets-perl_1.997-6_all.deb


Advertisement

Description

libcurses-widgets-perl - Curses widget interface for Perl

Distribution: Debian 8 (Jessie)
Repository: Debian Main amd64
Package name: libcurses-widgets-perl
Package version: 1.997
Package release: 6
Package architecture: all
Package type: deb
Installed size: 237 B
Download size: 76.41 KB
Official Mirror: ftp.br.debian.org
This module provides a standard library of functions and widgets for use in creating Curses-based interfaces. Should work reliably with both Curses and nCurses libraries. Current widgets include text field, list box, button sets, calendar, message box, input box

Alternatives

Requires

    Download

    Source package: libcurses-widgets-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libcurses-widgets-perl deb package:
      # sudo apt-get install libcurses-widgets-perl

    Files

    • /usr/share/doc/libcurses-widgets-perl/changelog.Debian.gz
    • /usr/share/doc/libcurses-widgets-perl/changelog.gz
    • /usr/share/doc/libcurses-widgets-perl/copyright
    • /usr/share/man/man3/Curses::Widgets.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::ButtonSet.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::Calendar.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::ComboBox.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::Label.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::ListBox.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::ListBox::MultiColumn.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::Menu.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::ProgressBar.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::TextField.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::TextMemo.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::Tutorial.3pm.gz
    • /usr/share/man/man3/Curses::Widgets::Tutorial::Creation.3pm.gz
    • /usr/share/perl5/Curses/Widgets.pm
    • /usr/share/perl5/Curses/Widgets/ButtonSet.pm
    • /usr/share/perl5/Curses/Widgets/Calendar.pm
    • /usr/share/perl5/Curses/Widgets/ComboBox.pm
    • /usr/share/perl5/Curses/Widgets/Label.pm
    • /usr/share/perl5/Curses/Widgets/ListBox.pm
    • /usr/share/perl5/Curses/Widgets/Menu.pm
    • /usr/share/perl5/Curses/Widgets/ProgressBar.pm
    • /usr/share/perl5/Curses/Widgets/TextField.pm
    • /usr/share/perl5/Curses/Widgets/TextMemo.pm
    • /usr/share/perl5/Curses/Widgets/Tutorial.pod
    • /usr/share/perl5/Curses/Widgets/ListBox/MultiColumn.pm
    • /usr/share/perl5/Curses/Widgets/Tutorial/Creation.pod

    Changelog

    2013-09-12 - Axel Beckert <abe@debian.org> libcurses-widgets-perl (1.997-6) unstable; urgency=low [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/rules: remove /usr/lib/perl5 directory only if it exists. * debian/watch: use dist-based URL. * Refresh debian/rules, no functional changes. Don't install README any more. * Split out changes to upstream code into proper patches; add quilt framework. * Add debian/README.source to document quilt usage, as required by Debian Policy since 3.8.0. * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * debian/control: Added: ${misc:Depends} to Depends: field. [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Change my email address. [ Gunnar Wolf ] * Removing myself as an uploader. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * Switch to source format "3.0 (quilt)" + Remove quilt traces from debian/rules and build dependencies + Remove debian/README.source * Bump debhelper compatibility to 9 + Update versioned debhelper build-dependency accordingly + Fixes lintian warning package-uses-deprecated-debhelper-compat-version * Clarify debian/copyright with regards to GPL versions + Fixes lintian warning copyright-refers-to-versionless-license-file * Bump Standards-Version to 3.9.4 (no changes) * Revamp debian/rules + Use dh_auto_{configure,build,install,clean} + Remove now obsolete variable definitions + Remove now obsolete parameters from dh_clean and dh_installchangelogs + Finally switch to a minimal dh7 style debian/rules file * Also fixes the following lintian warnings: + dh-clean-k-is-deprecated + debian-rules-missing-recommended-target + spelling-error-in-manpage * Add myself to Uploaders

    2006-10-01 - gregor herrmann <gregor+debian@comodo.priv.at> libcurses-widgets-perl (1.997-5) unstable; urgency=low * Use $(CURDIR) [make] instead of $(PWD) [sh] to fix issues with sudo.

    2006-09-14 - Gunnar Wolf <gwolf@debian.org> libcurses-widgets-perl (1.997-4) unstable; urgency=low * Transferred ownership to the Debian Perl Group * Minor fixes in build process

    2006-05-18 - David Moreno Garza <damog@debian.org> libcurses-widgets-perl (1.997-3) unstable; urgency=low * New maintainer (Closes: #279782). * Adding a watch file. * BORDER => 0 now displaying widgets (Closes: #341715). - Thanks to William Thompson. * Standards-Version updated to 3.7.2.

    2005-02-26 - Stephen Quinney <stephen@jadevine.org.uk> libcurses-widgets-perl (1.997-2) unstable; urgency=low * QA Upload * Changed Maintainer to Debian QA Group <packages@qa.debian.org>

    2004-03-02 - Stephen Zander <gibreel@debian.org> libcurses-widgets-perl (1.997-1) unstable; urgency=low * New upstream release, Closes: #181908 * Apply patch to make ListBox.pm keep the bottom element of a list in view when paging down & the top element of a list in view when paging up, Closes: #171719

    2002-08-13 - Stephen Zander <gibreel@debian.org> libcurses-widgets-perl (1.992-1) unstable; urgency=low * New upstream version.

    2002-01-11 - Stephen Zander <gibreel@debian.org> libcurses-widgets-perl (1.2-1) unstable; urgency=low * New upstream source * New maintainer, Closes: #123501

    2000-01-09 - Raphael Bossek <bossekr@debian.org> libcurses-widgets-perl (0.9-1) unstable; urgency=low * New upstream version.

    Advertisement
    Advertisement