libcurses-perl_1.32-1_amd64.deb


Advertisement

Description

libcurses-perl - Curses interface for Perl

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main amd64
Package name libcurses-perl
Package version 1.32
Package release 1
Package architecture amd64
Package type deb
Installed size 398 B
Download size 90.73 KB
Official Mirror ftp.br.debian.org
libcurses-perl (the Curses module from CPAN) will let you
use the ncurses/curses terminal screen manipulation
routines from Perl programs.

Alternatives

Package Version Architecture Repository
libcurses-perl_1.32-1_i386.deb 1.32 i386 Debian Main
libcurses-perl - - -

Requires

Name Value
libc6 >= 2.4
libncursesw5 >= 5.6+20070908
libtinfo5 -
perl >= 5.20.1-1
perlapi-5.20.1 -

Download

Type URL
Binary Package libcurses-perl_1.32-1_amd64.deb
Source Package libcurses-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcurses-perl deb package:
    # sudo apt-get install libcurses-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.20/Curses.pm
/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Curses/Curses.so
/usr/share/doc/libcurses-perl/README.Debian
/usr/share/doc/libcurses-perl/README.gz
/usr/share/doc/libcurses-perl/changelog.Debian.gz
/usr/share/doc/libcurses-perl/changelog.gz
/usr/share/doc/libcurses-perl/copyright
/usr/share/doc/libcurses-perl/examples/demo
/usr/share/doc/libcurses-perl/examples/demo.form.gz
/usr/share/doc/libcurses-perl/examples/demo.menu
/usr/share/doc/libcurses-perl/examples/demo.panel
/usr/share/doc/libcurses-perl/examples/demo2
/usr/share/man/man3/Curses.3pm.gz

Changelog

2014-09-25 - Axel Beckert <abe@debian.org>
libcurses-perl (1.32-1) unstable; urgency=medium
* Team upload
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Axel Beckert ]
* Import new upstream release
+ Drop one patch and two hunks which were applied upstream
* Bump Standards-Version to 3.9.6 (no changes needed)
2014-05-21 - Damyan Ivanov <dmn@debian.org>
libcurses-perl (1.31-1) unstable; urgency=medium
[ gregor herrmann ]
* debian/rules: remove unused variable, drop parameter which debhelper
passes by default.
[ Damyan Ivanov ]
* Imported Upstream version 1.31
* refresh t_upstream_spelling.diff to apply cleanly
* forward t_upstream_spelling.diff upstream
* add a patch fixing encoding issues in Curses.pm POD
* add two new files to debian/copyright
* declare conformance with Policy 3.9.5 (no changes needed)
2014-03-09 - intrigeri <intrigeri@debian.org>
libcurses-perl (1.28-2) unstable; urgency=medium
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ intrigeri ]
* Bump debhelper compat level to 9.
* Adjust versioned Build-Depends on debhelper to (>= 9.20120312~)
to get hardening build flags.
* Reformat debian/control with cme fix dpkg.
* Link to the versioned GPL-1 symlink in /usr/share/common-licenses.
* Don't override dh_auto_configure, to get hardening build flags.
2010-01-28 - Franck Joncourt <franck@debian.org>
libcurses-perl (1.28-1) unstable; urgency=low
[ Ryan Niebur ]
* Update ryan52's email address
[ Franck Joncourt ]
* New upstream release.
* Add /me as Uploader.
* Switch to dpkg-source 3.0 (quilt) format:
+ Removed useless README.source file which only documented the usage of
quilt.
+ Removed BD on quilt.
+ Removed debhelper option (--with-quilt).
* Updated BD:
+ Use of the override_dh targets requires at least debhelper (>= 7.0.50).
+ Relaxed versionned dependency on perl (>= 5.8) since oldstable has
5.8.8.
* Bumped up Standards-Version to 3.8.4 (no changes).
* Added patch t_upstream_spelling.diff to fix a spelling error.
2009-06-21 - Ryan Niebur <ryanryan52@gmail.com>
libcurses-perl (1.27-2) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ryan Niebur ]
* patch from Barry deFreese to fix build on Hurd (Closes: #533698)
* Add myself to Uploaders
* Debian Policy 3.8.2
* update d/rules format a bit
2009-01-24 - gregor herrmann <gregoa@debian.org>
libcurses-perl (1.27-1) unstable; urgency=low
* New upstream release.
2009-01-05 - gregor herrmann <gregoa@debian.org>
libcurses-perl (1.26-1) unstable; urgency=low
* New upstream release.
* debian/control:
- switch Vcs-Browser field to ViewSVN
- add ${misc:Depends} to Depends: field
- change my email address
* Set debhelper compatibility level to 7; adapt
debian/{control,compat,rules}.
* debian/copyright: update formatting.
2008-09-11 - Gunnar Wolf <gwolf@debian.org>
libcurses-perl (1.24-1) unstable; urgency=low
* New upstream release
* Added myself as an uploader
* Standards-version -> 3.8.0 (no changes)
2008-03-15 - Roberto C. Sanchez <roberto@debian.org>
libcurses-perl (1.23-1) unstable; urgency=low
[ Roberto C. Sanchez ]
* New upstream release.
[ David Paleino ]
* debian/control: removed myself from Uploaders

See Also

Package Description
libcurses-ui-perl_0.9609-1_all.deb curses-based OO user interface framework for Perl
libcurses-widgets-perl_1.997-6_all.deb Curses widget interface for Perl
libcutl-1.8_1.8.1+ds1-1_amd64.deb C++ utility library
libcutl-dev_1.8.1+ds1-1_amd64.deb C++ utility library, development files
libcv-dev_2.4.9.1+dfsg-1+deb8u1_amd64.deb Translation package for libcv-dev
libcv2.4_2.4.9.1+dfsg-1+deb8u1_all.deb computer vision library - libcv* translation package
libcvaux-dev_2.4.9.1+dfsg-1+deb8u1_amd64.deb Translation package for libcvaux-dev
libcvaux2.4_2.4.9.1+dfsg-1+deb8u1_all.deb computer vision library - libcvaux translation package
libcvc3-5-java_2.4.1-5_all.deb Java bindings for CVC3 (bytecode library)
libcvc3-5-jni_2.4.1-5_amd64.deb Java bindings for CVC3 (native library)
libcvc3-5_2.4.1-5_amd64.deb Automatic theorem prover library for SMT problems
libcvc3-dev_2.4.1-5_amd64.deb Automatic theorem prover library for SMT problems (development files)
libcvector2-dev_1.0.3.1-1.1_amd64.deb ANSI C implementation of dynamic arrays (development files)
libcvector2_1.0.3.1-1.1_amd64.deb ANSI C implementation of dynamic arrays
libcvm1-dev_0.96-1.1_amd64.deb Credential Validation Modules (development files, documentation)
Advertisement
Advertisement